OpenHab2 and EnOcean Binding Problem


I’m trying to setup my enocean binding and get my devices running.

I receive in the log file:

openhab> log:tail org.openhab.binding.enocean
09:03:52.714 [INFO ] [.enocean.internal.bus.EnoceanBinding] - Connecting to Enocean [serialPort='/dev/ttyUSB0' ].

I would have expect more information (even Debug) due to my item and sitemap and based on other posts /experiances in the community here. My setup as follows:

Switch Button01top    "Switch left top"     <wallswitch> { enocean="{id=00:1B:2D:24, eep=F6:02:01, channel=A, parameter=I}" }
Switch Button01bottom "Switch left bottom"  <wallswitch> { enocean="{id=00:1B:2D:24, eep=F6:02:01, channel=A, parameter=O}" }
Switch Button02top    "Switch right top"    <wallswitch> { enocean="{id=00:1B:2D:24, eep=F6:02:01, channel=B, parameter=I}" }
Switch Button02bottom "Switch right bottom" <wallswitch> { enocean="{id=00:1B:2D:24, eep=F6:02:01, channel=B, parameter=O}" }

Frame label="SchalterTest" 
        Switch item=Button01top
        Switch item=Button01bottom
        Switch item=Button02top
        Switch item=Button02bottom

Furthermore the binding is configured as:


When I press the sender, my USB 300 is blinking, so I assume he is receiving sth. Why does the log not shows that? Furthermore I installed the EnOceanSpy from hfunke. Using this tool I am getting the sending device telegram. That means that the sender is sending and the USB300 is receiving the information. And by the way, the physical light is switching on :slight_smile:. While using the button in OH2, nothing is happening apart from the following log:

2017-10-03 10:46:50.952 [ItemCommandEvent          ] - Item 'Button01top' received command OFF
2017-10-03 10:46:50.980 [ItemStateChangedEvent     ] - Button01top changed from ON to OFF

Well, the visualization is changing from switch = on to Switch = off and the other way around, but my physical light is not changing the status.

Did I missed setting sth. up? Hope you can help me out getting EnOcean running.

Thank you very much in advance.

Hi @Woogi,

first of all I have to say, that I do not know the old enocean binding. However to interact with your physical enocean things, you first have to pair your openhab things with your physical ones (eg teach in). So you could try to activate the learning mode of your device and switch your OH2 button afterwards.

However you could also use my new openhab2 enocean binding, which supports a brider range of EEPs as the old one. You find the discussion about it here.

Best regards