Openhab2 designer where to download?

Hi.

I’m looking for the openhab2 designer for download.
But I’m having a hard time finding something.
Most links from here:


And here:

go to nil.

So where can I download it?

Manfred

Just look here: http://docs.openhab.org/installation/designer.html

Thomas

Thanks.
But the links under:

Come back with a timeout.
Is this just a temporary glitch?

Manfred

It seems as if the Eclipse Foundation servers are down, I cannot even access http://www.eclipse.org/
So yes, that should be temporary, try again tomorrow!

Yep, was just temporary.
Works again today.

Thanks

When downloading the designed from https://github.com/eclipse/smarthome/blob/master/docs/documentation/community/downloads.md#designer-builds it failes to load on macOS.

@Kai: Also the link “consists out of OSGi bundles” on that page is broken (404 not found)

It seems that the designer needs or refresh.

Is there any command line option to very the syntax of a rule file? I get the message

2017-08-10 08:17:30.158 [WARN ] [el.core.internal.ModelRepositoryImpl] - Configuration model 'zwave.rules' is either empty or cannot be parsed correctly!
2017-08-10 08:17:37.491 [INFO ] [el.core.internal.ModelRepositoryImpl] - Validation issues found in configuration model 'zwave.rules', using it anyway:
There is no context to infer the closure's argument types from. Consider typing the arguments or put the closures into a typed context.

which is not very helpful. I did several changes to the rule file and already tried to isolate the code block causing that error, but without success.

You are looking at the source code of the documentation. The published version is here: https://www.eclipse.org/smarthome/documentation/community/downloads.html

yep, that’s the version I tried, but it fails to start on 2 different macs (running latest macOS)

@Kai: Starting this version of 2 different systems fails, eclipse log:

!SESSION 2017-08-12 15:17:56.870 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_121
java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=de_DE
Command-line arguments:  -os macosx -ws cocoa -arch x86_64

This is a continuation of log file /Users/markus/.eclipse/org.eclipse.platform_4.4.0_555202545_macosx_cocoa_x86_64/configuration/1502543877171.bak_3.log
Created Time: 2017-08-12 15:18:43.051

!ENTRY org.eclipse.osgi 4 0 2017-08-12 15:18:43.052
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: The platform metadata area could not be written: /private/var/folders/4y/vwvhk_fs1938xbk0k6z1h5t80000gn/T/AppTranslocation/8AB380A6-5B2B-4E3C-BB67-FA9BB0BE19CC/d/Eclipse SmartHome Designer.app/Contents/MacOS/workspace/.metadata.  By default the platform writes its content
under the current working directory when the platform is launched.  Use the -data parameter to
specify a different content area for the platform.
	at org.eclipse.core.internal.runtime.DataArea.assertLocationInitialized(DataArea.java:61)
	at org.eclipse.core.internal.runtime.DataArea.getStateLocation(DataArea.java:129)
	at org.eclipse.core.internal.preferences.InstancePreferences.getBaseLocation(InstancePreferences.java:44)
	at org.eclipse.core.internal.preferences.InstancePreferences.initializeChildren(InstancePreferences.java:199)
	at org.eclipse.core.internal.preferences.InstancePreferences.<init>(InstancePreferences.java:59)
	at org.eclipse.core.internal.preferences.InstancePreferences.internalCreate(InstancePreferences.java:209)
	at org.eclipse.core.internal.preferences.EclipsePreferences.create(EclipsePreferences.java:391)
	at org.eclipse.core.internal.preferences.EclipsePreferences.create(EclipsePreferences.java:379)
	at org.eclipse.core.internal.preferences.PreferencesService.createNode(PreferencesService.java:389)
	at org.eclipse.core.internal.preferences.RootPreferences.getChild(RootPreferences.java:63)
	at org.eclipse.core.internal.preferences.RootPreferences.getNode(RootPreferences.java:101)
	at org.eclipse.core.internal.preferences.RootPreferences.node(RootPreferences.java:90)
	at org.eclipse.core.internal.preferences.AbstractScope.getNode(AbstractScope.java:38)
	at org.eclipse.core.runtime.preferences.InstanceScope.getNode(InstanceScope.java:80)
	at org.eclipse.ui.preferences.ScopedPreferenceStore.getStorePreferences(ScopedPreferenceStore.java:244)
	at org.eclipse.ui.preferences.ScopedPreferenceStore.<init>(ScopedPreferenceStore.java:133)
	at org.eclipse.ui.plugin.AbstractUIPlugin.getPreferenceStore(AbstractUIPlugin.java:285)
	at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:593)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:579)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
	at org.eclipse.smarthome.designer.ui.internal.application.Application.start(Application.java:32)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:382)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:236)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:498)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1465)

Tried several downloads. Note: Started working with the 1.8 designer on those systems (may be some left-overs from old designer versions?)

move downloaded file to programs - et voila, problem solved