OpenHAB2 - Failed installing rrd4j: Permission Denied

Dear all,

I’m upgrading to OH2 and have installation on Ubuntu x86 system, following the guide (, installing the official release.

I successfully installed several add-ons (e.g. MQTT Binding, Weather Binding) through the Paper UI. These add-ons I tested, fully working. However, when I tried to install RRD4j Persistence add-on I got error message in the Log:
[ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-persistence-rrd4j’: Permission denied

Paper UI shows that add-on is installed, however it is surely not. When I click uninstall the add-on in Paper UI, in the log I get:
[INFO ] [core.karaf.internal.FeatureInstaller] - Uninstalled ‘openhab-persistence-rrd4j’

But again, rrd4j was not installed, because of missing rrd4j.cfg file and message in Log:
[WARN ] [thome.ui.internal.chart.ChartServlet] - Illegal argument in chart: No Persistence service found.

What permissions on which folder should I grant?

Thank you for your help

Hello, i’m pasting and copy the same answer from another post. Try to do these check:

I hope for you will be only a mistake in directory owners.

OpenHab2 for install 1.9 binding (and also rrd4j) NEED to create some files inside /etc/openhab2 directory; The default owner and group is openhab:openhab.

One of the first action I (and maybe you also) made is

sudo chown -hR mylinuxuser:mylinuxuser /etc/openhab2

Because I need to edit Items and Sitemap from another PC!!!

These Action prevent Openhab2 to create the 1.9 binding relative files inside /etc/openhab2 folder…and give out missing of installation and several binding errors

Try out these before install

sudo chown -hR openhab:openhab /etc/openhab2

And in the other folders you change the ownership.

Install the binding and all you need and only at the end come back to
sudo chown -hR mylinuxuser:mylinuxuser /etc/openhab2

Please let me know if you are able to solve by these way. I had the same issue

1 Like

Hello Muplex, this worked:

sudo chown -hR openhab:openhab /etc/openhab2

Strange is that the Weather Binding is v1.9 as well and was installed without any issue.

Thank you very much!

yeah =)
I’m Very happy to be helpful.

Maybe for the weather binding installed without problems because the weather configuration file was already inside the folder and openhab don’t need to create a new one.

Best Regards,

I am running OpenHAB 2.1.0 on a Synology Diskstation DS218+.
Although it seemed that persistence with rrd4j was installed properly, it did not work: i.e., no charts were drawn, and the openhab.log contained the following warning message(s) after navigating to a chart in the sitemap:

[WARN ] [thome.ui.internal.chart.ChartServlet] - Illegal argument in chart: No Persistence service found.

The tip with changing the ownership for directory /etc/openhab2 seems to have fixed this issue.
Note that I had to create the folder on my own as it did not exist before. (It might also be that this was the problem)

The following command was successful for me:

sudo chown -hR openhab2 /etc/openhab2