Openhab2 offline

I have made an account on
openhab cloud is installed and running in openhab2
the error I am getting is–"Your openHAB is not online. Please check if your installation is running or recheck the openHAB settings in your account. "
the java version is 1.8.0_131-b11…
how can I solve this problem?

Did you

  1. Check verification email?
  2. Enter the uuid and secret?
  3. Restart the openhab server?

After following @Branden_Smale’s advice, check the log for anything relevant.

You need the latest Java.

The Cert/Root authority that OpenHab uses for its cloud (LetsEncrypt) wasn’t added to the list of trusted Java authorities until the latest version.

I think the latest Java is build

I had the exact same problem. Updating Java worked for me.

my email is verified, I entered the correct uuid and secret value, I restart the openhab server too…
sorry for the late reply.

ok. I will try this thing too.
thank you in advance.

Can you post how you got it working?

This might help others with the same problem.

i dont try upto now…actually am stuck in another problem so am trying to solve it in openhab2…

In another similar thread, a user encountered problems where the UUID/Secret changed for unknown reasons.

It’s helpful when seeking help from the community to post the relevant parts of your log. In this case, the contents of the log is what led to the solution.

Indeed, logs is one of the first places I look, though sometimes I still miss something simply coz i dont know what to look for. :slight_smile:

I am still puzzled why it changed. When i check the status in myopenhab, as in the screenshot i placed, on- and offline seemed to alternate over time, till it suddenly stopped working totally.

Oddly, though i experienced consistent ‘offline’ through my phoneapp, I still could get on the myopenhab UI’s via my desktop, till that suddenly also was no longer possible.

Logging in to myopenhab revealed it was offline. Only then i realized the problem was not in my phoneapp but in myopenhab.

I should have realized the UUID/secret had changed because my logs showed different values than my myopenhab, but as for the life of me i never even considered those keys could change, i didnt check the log keys against the myopenhab keys.

I had seen Geetika’s question but didnt get further with the solutions for the very reason that when i did check my keys, they seemed correct as in ’ yes those are the keys i entered months ago’. I had no way of knowing or even suspecting they were ‘no longer’ correct

1 Like

i have updated my java version “latest Java is build” but still got the same error…

Geetika, what do your logfiles say, do they mention the same keys a your myopenhab does?
I immediately believe that the keys in myopenhab match the ones you received, but do they match what is in these files:
File regular Installation APT Installation
UUID userdata/uuid /var/lib/openhab2/uuid
Secret userdata/openhabcloud/secret /var/lib/openhab2/openhabcloud/secret

hello sir,
the secret and UUID is same in both places ( and openhab2)

Try restarting openHAB and/or the computer it’s installed on. Go to your logs, look for something about the openHAB cloud connector, and post that on here.

hello sir
I have restarted openhab2 and raspberry pi also. when I check the logs I got one error and that is
"[error] [io.openhabcloud.internal.CloudClient] - Socket.Io error not authorized"

and sir my email is verified…i don’t know what is wrong…

Thanks, Just to be clear, my problem was already solved, but I presume yr advice was meant for Geetika.

@Kees_van_Gelder Yes, it was, sorry!

no worries, just wanted to clarify

finally openHAB2 is online
After updating the JAVA my problem has not been solved so I just uninstall openhab2 and again install it.
Update the UUID and SECRET in my Account and refreshes the account and then openHAB is ONLINE…