Openhabian 1.6 - Ethernet eth0 - Device not reachable

RPi 3b+
Openhabian 1.6
XFi ISP

Background: I went to update my OS and openhab installation on my RPi that has been working for over a year (probably closer to 2 years). Somehow, between the two updates the system got totally hosed. At the time I figured there may have been some incompatibilities. At any rate, after fighting with it for awhile, I got tired and put it away for awhile, figuring I would just reimage and start over.

Over the past couple of days I have been trying to get it to run. I am running into the same issue, no IP address assigned by DHCP.

It is a clean base installation. The only things connected to the RPi are the power, ethernet, TV (so I can see what’s going on), and a USB keyboard.
I have tested all the physical connections and they are fine.
My PC (static) and other devices (DHCP) all function normally.
Seeing as how my RPi wasn’t getting a DHCP address (169.254.0.10), I configured it for a static address. The static address shows up in ifconfig -a, but still no connection to the router. I ping the router from the RPi: device unreachable. I ping the RPi from my workstation (Fedora): device unreachable.

I have been reading forums for the past 3 days.

Some have this issue with no resolution.
Some have it, but turns out to be a hardware issue (new devices). I know this isn’t my issue because it has been working for 2 years, and I have tried 2 different RPi boards - same problem.
Most are not even closely related.

I have come to the conclusion that there has to be something in the new Openhabian release. I don’t want to use WiFi as that defeats the purpose of a closed network.

Any ideas? Thank you in advance.

Todd

Have you read the debug guide ? Provide a debug log as explained there. Without that it’s useless guessing in the dark, that probably noone will want to do for you.
However if your HW is fine and you properly configured a static IP and it still doesn’t work it’s not a problem with openHABian but with your switch or router config. MAC cache or ACLs eventually.
Noone can know. It’s your devices.

I would try reimaging with raspian lite. It will only take a moment. See if that gets an ip if so then your hardware is good. Then switch back to the openhabian image which is based on raspian lite.

Any entry in /var/log/messages ? What does dmesg show ?

I’ve reimaged it a couple of times, although with the same image file. But I have put the SD Card in two different RPi’s and got the same results. All my other devices (workstation, phones, etc. - wired or WiFi - static or DHCP) all are working normally. I have tested my wiring - good. I have tried two different switches - same results. I’ll try the Raspian Lite. I’ll look at some other versions as well.

BTW, here’s the ping results from my workstation:

PING 10.5.0.10 (10.5.0.10) 56(84) bytes of data.
From 10.5.0.5 icmp_seq=1 Destination Host Unreachable
From 10.5.0.5 icmp_seq=2 Destination Host Unreachable
From 10.5.0.5 icmp_seq=3 Destination Host Unreachable
From 10.5.0.5 icmp_seq=4 Destination Host Unreachable
From 10.5.0.5 icmp_seq=5 Destination Host Unreachable
From 10.5.0.5 icmp_seq=6 Destination Host Unreachable
^C
--- 10.5.0.10 ping statistics ---
7 packets transmitted, 0 received, +6 errors, 100% packet loss, time 6141ms
pipe 4
[todd@workstation ~] $ ^C
[todd@workstation ~] $ ping 10.5.0.1
PING 10.5.0.1 (10.5.0.1) 56(84) bytes of data.
64 bytes from 10.5.0.1: icmp_seq=1 ttl=64 time=2.03 ms
64 bytes from 10.5.0.1: icmp_seq=2 ttl=64 time=33.0 ms
64 bytes from 10.5.0.1: icmp_seq=3 ttl=64 time=1.03 ms
^C
--- 10.5.0.1 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 1.028/12.010/32.974/14.829 ms
[todd@workstation ~] $ 

Hi Danny and Wolfgang,

Thank you so much for your help. I believe you pushed me in the right direction. Here’s what I’ve found out, so far:
When I looked on my TV (RPi monitor), I had let it sit for a couple of days, it had scrolled a bunch of errors about a swap file.
I realized I hadn’t added a swap filesystem and must need one.
I shutdown the RPi and put the SD card in my computer. Since you had mentioned the dmesg log file I looked for it, but couldn’t find it anywhere, which was weird, since it is a system-level log file.
That started me thinking and I remembered that the root filesystem needed to be expanded (it’s amazing what basics you forget when you don’t do it a lot). I realized that maybe the system didn’t have enough room to run and expand the necessary files (dmesg log file and possibly drivers).
I re-imaged the card again, expanded the root fs, and added the swap fs.
Of course it complained that the root fs needed to be the last fs (which I wasn’t aware of), so I re-imaged AGAIN, moved the root FS to the end and expanded it, then added the swap fs.
I booted the RPi atain and let it run overnight. I didn’t have time to check on it this morning, so I will look at it tonight when I get home.
I just wanted to let you know what I was up to so you didn’t think I ignored you. I am very grateful to you for getting me on the right track (I hope - we’ll find out tonight). I will post the results.

Thank you again,

Todd

1 Like

well, it didn’t work. I tried 3 os’s, (64-bit Openhabian, 32-bit Openhabian, NOOBS Raspberry Pi OS), WiFi works fine, but wired does not. I did see during boot where the dhcpcd failed. I also still can’t find the dmesg log file. I know it has to be there, I guess I’m just looking in the wrong place. At any rate, I’ll keep you posted.

Todd

Ok now we are on to something. We need to probably start examining your router and cables tied to router. Seems like you have some issue there with the dhcp lease.

Here are 2 pictures, one of my ifconfig, and one of the dhcpcd error.

Here is my Openhabian splash screen:

###############################################################################
###############  openHABianDevice  ############################################
###############################################################################
##        Ip = Unable to parse ip . Please debug.
##   Release = Raspbian GNU/Linux 10 (buster)
##    Kernel = Linux 5.4.51-v7+
##  Platform = Raspberry Pi 3 Model B Rev 1.2
##    Uptime = 0 day(s). 0:4:21
## CPU Usage = 0% avg over 4 cpu(s) (4 core(s) x 1 socket(s))
##  CPU Load = 1m: 0.31, 5m: 0.77, 15m: 0.40
##    Memory = Free: 0.37GB (40%), Used: 0.57GB (60%), Total: 0.95GB
##      Swap = Free: 2.39GB (100%), Used: 0.00GB (0%), Total: 2.39GB
##      Root = Free: 8.58GB (67%), Used: 4.06GB (33%), Total: 13.34GB
##   Updates = 21 apt updates available.
##  Sessions = 1 session(s)
## Processes = 120 running processes of 32768 maximum processes

The first line states it’s unable to parse an IP address.
I’ve reseated all the cables going between the RPi and the router. all my other devices are receiving addresses from the dhcp server, whether wired or wifi.

Thanks,

Todd

dmesg is a command. You just need to execute dmesg on the command line e.g.:

sudo dmesg

Have you tried to connect your Pi instead of an other computer / instead of the other computer ( meaning at the same place, using the same cable, port etc. ) ?

Hey guys… I GOT IT WORKING!!! at least eth0 on DHCP. And did I have to jump through some hoops. Let’s see if I can pidce this together and give you the necessary steps I took (leaving out the wild goose chases). BTW, I still get the “## Ip = Unable to parse ip . Please debug.” error on the Openhabian splash screen.

I have edited the etc/dhcpcd.conf:

interface eth0
static ip_address=10.5.0.10/24
#static ip6_address=fd51:42f8:caae:d92e::ff/64
static routers=10.5.0.1
static domain_name_servers=75.75.75.75 75.75.76.76 8.8.8.8

Then I edited /etc/network/interfaces:

auto eth0
iface eth0 inet dhcp

Rebooted…

Now my ifconfig -a shows:

        inet 10.5.0.109  netmask 255.255.255.0  broadcast 10.5.0.255
        inet6 2601:204:c003:e0a0:ba27:ebff:fe76:3095  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::ba27:ebff:fe76:3095  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:76:30:95  txqueuelen 1000  (Ethernet)
        RX packets 1671  bytes 281495 (274.8 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 375  bytes 72815 (71.1 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 15  bytes 1038 (1.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 15  bytes 1038 (1.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether b8:27:eb:23:65:c0  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Now it just depends on how adamant I am about a static IP.

It appears from my reading that this has been a known problem. I’m obviously not the first person to come across this issue. It seems that the installation disables eth0 (I could be mistaken, but read “openHABian setup fails due to ipv6
It appears to go over some of the issues. At any rate…

Thank you Danny and Wolfgang for all your help. You pointed me in the right direction. Now the thing to see is if I can repeat it… :upside_down_face:

Todd

2 Likes

Glad you got it. I don’t have ip v6 anywhere on my home network… I don’t for a reason. That reason, I had squirrels many years ago so I disabled and never looked back!

Wonder if you disable ipv6 on your router if it would work out the box.

That is a good possibility. I don’t use IPv6 either. there really isn’t a good reason to use it for a private network. Chances are you’re not gong to run out of addresses, especially on a home network. At any rate, I’ll look into it. This is just the first step in becoming functional again.

BTW, I was able to repeat the process on another (slightly newer) version of the OS (I had another SD Card with a base install on it).

I’m sure I’ve used the command at some point, but’s it’s been so long that I forgot. I was sure it was a log file. Maybe in an older Linux version. Oh, well, it really doesn’t matter now. Thank you for reminding me. I’ll try to store that information in my swiss cheese of a memory. :grin:

Hi Danny,

I tried to find a way to disable IPv6 on my router, but there doesn’t appear to be a way to do it.
Oh well, I’ll have to muddle through with it.

Thanks,

Todd

1 Like

ipv6=disable in /etc/openhabian.conf