Openhabian 2.4 -- Problems with Zwave devices

  • Platform information:
    • Hardware: Rasp 2
    • OS: Openhabian
    • openHAB version: 2.4

I’ve upgraded my OH -installation to 2.4. After the Upgrade I’m facing a lot of errors. * The main problem is that my Zwave Aeotec Multisensor 6 Device are listet as “unknown device” . I removed them, cleaned the cache an added them again. No succes. OH finds them, but without any sensors.

  • Another issue I find is that I get a lot of error messages, “Error 503: jersey not ready yet” and sometimes an “Error 500: Internal server error”.
  • All the rules doesn’t show up any more in PaperUI.
  • Cleaning the cache and rebooting, remove things an readd them doesn’t solve the issues.

Thank you

Did an in-place upgrade to 2.4 the other day (Pi with Aeon Gen 5 Zwave USB stick). For some reason the Zwave controller device ID changed, or got replaced. Meant that existing items no longer worked until I modified the .items file(s) to reflect the new ID.

Only pointing out to you and others, in case it helps

Or use the old id when adding the stick …

I have had the same after upgrading. Clearing the cache didn’t help, but after a second reboot those problems vanished.

Did you follow the upgrade procedure ?

Rules never show in PaperUI unless you’re using the Experimental Rules Engine which you really shouldn’t do unless you’re an expert aware of the implications. Move to the standard engine.

It’s highly likely that the device just needs to wake up so that the binding can discover the device and work out what it is.

Should it make any sense to set the ‘wake up time’ for the battery devices to 60s before upgrading to 2.4 ? So when you discover the z-wave devices ( after following the steps ) they will be found faster proper ?
I have the same thing with my wall switches.
Have tried to manual wake them up but unfunality no success. I assume that when you push the new wake up time to the devices they won’t be changed until i set them agian ?


You could try to set this - but you will either need to wake up the device manually so that it is set, or you will need to wait for the wakeup interval so that it gets set. So I’m not sure it’s a lot different than just upgrading, and then still waiting for the wakeup period…

Correct - the binding can only change the wakeup after the device wakes up…

The other items (switch, window sensor) work well! Only the Multisensor-devices won’t work.

Thanks @chris for your reply.
Maybe it isn’t the best approach to do this.
And just try again with manual wake-up.

Can I just add the found devices to a thing ? And after waking up the change ? Or do I need to discover it over an over until they are properly found ( did the last way for all my battery devices )

Thanks again and for you brilliant work with the bindings !!

I’m not sure what you mean? A device is the same thing as a “thing”…

In general, you need to discover the device before you can use it.

I just did the followong steps:

  1. Removed all zwave-devices (via PaperUI)
  2. Stoped OH
  3. Cleaned the cache (cli-cache)
  4. Reboot the system
  5. Searching for new zwave-devices
  6. Switch and door sensor are found correctly, still the Aeotec Multisensor 6 devices show up as “unknown device”. I didn’t add the unkown devices as a thing
  7. know i will wait until the are found once again, maybe as a known device.

I meant to keep them in the inbox, wake the device and search again for new devices. Or just add the discovered devices them and wake the device. ?
What will be the best way ?

Ah, ok - understood. It should not matter. Either way it will not really do anything until the device type is known. The protocol stack is independent of openHAB, so it will not affect the discovery process.

Hope this works. But waiting in till the device wake up can be really long. Can you wake it up manual ?

Yes, there is normally a button or something to press to wake a device up. Check the manual - every device is different.

My issue was due to a RTFM…
Pushed the wrong button on the Wall remotes.
They are now all found correct.
I did wake the node, but it didn’t send node information. That’s a other button on the device.



I did it again and again. No change. I will switch back to my old OH 2.3 installation an wait until all the issues are solveld.
Thank you.

Upgraded from 2.3 to 2.4, and following upgrade guide, to remove and add back all things, using PaperUI.

After the upgrade the Fibaro FGMS001 stopped sending motion events. Luminans, battery and temperature worked fine. The thing was removed and added back again, cleared cache, but no success.
At last I removed the thing, and used Habmin for adding the thing. Whoa, success! The motion detektor now works as expected again.

What is the recommended tool for adding Zwave things? should I use Habmin or PaperUI?

I use PaperUi for my Zwave devices. For me its more easy and a better overview than Habmin. In the beginning I used Habmin, but had some problems with correct inclusion.