openHABian hassle-free openHAB Setup

Well, I actually set up OpenHAB 1.7 on Raspi by myself a year ago. With NOOBS as a basis. So I know there is a simple GUI to use. But as far as I understand there is no way to have the Openhabian installation to be used with a GUI. And there’s the question: why? How can I install a GUI or is it not possible? How can I change the keyboard layout if not by using the raspi-config?
Openhabian seems to me simple in the first way but then it’s like it always has been: Linux-guys who think others have to use a terminal… It’s annoying but that’s the way it is. I dont have to use this kind of installation… :slight_smile:

There was discussion from another member about using the GUI with openHabian, I believe it’s up in this thread, maybe about a month ago… I don’t know what the outcome of the discussion was.

And, OpenHab can be installed on other platforms too…

Hello Uwe,

rasp-config is a tool for the Raspbian system. openHABian contains a few modifications in regards to that. That’s why the tool is not working properly. I’ve been wanting to make it obsolete and remove it eventually. There are only a few options which are really meaningful, mainly the localization options. I didn’t get around to implement these because barely anybody is asking about them. Why? Because most do not matter :slight_smile:

The only real tasks I’d need to add as openhabian-config menu options are changing the timezone and locale of your system as well as the user password. All of these are very simple and I actually already covered that in documentation (for now):

Changing the keyboard layout and changing to GUI: These options are not really relevant. As I already tried to explain, openHABian prevails as a headless system. It doesn’t make sense to restrict yourself to a weak system with very limited capabilities, when you could just use your powerful every-day PC for 90% of the work and an SSH remote console for executing commands on the dedicated slave. That’s how 99% percent of RPi users are using their system, for this and many other good reasons.

It really doesn’t make sense. Listen to the “Linux-guy who think others have to use a terminal…” - I’m not saying this to torture you :slight_smile: I’ve started with a display once, just as you did.

I don’t want to force you into anything. If you want to make the experience for yourself, here is the thread @RHINESEL was referring to… Edit: @uwe_mutz this seems like the optimal choice to get the latest PIXEL GUI onto your Raspberry Pi: (last answer)

As you are one of the few users who actually brought forth negative feedback, I’d be more than interested in any other concerns you have regarding the “hassle-free” claim. Best wishes, Thomas

@ThomDietrich, while you’re around… any idea about this? All the stuff I’m getting via Google is jibberish to me.

Also, regarding time zone. When doing the basic setup, the system was adjusting the timezone from the openhabian config file which was listing Europe/Brussels. I finally figured it out (after my rules were firing all at the wrong times) and changed it to my zone of America/New_York but I don’t remember ever having to do this before, it always adjusted to the correct local timezone.

To clarify… when updating OpenHabian I don’t remember ever having to reset my timezone. I know I had to set it on the system initially. Is there someway for the openhabian config file to recognize the existing timezone and adjust itself based on that?

I was hoping this issue would vanish magically, just as it appeared :sparkles:
Yes there were some changes related to the Pine64 and most of them are actually to make sure 32bit packages are installed also there. On top of all: on a RPi these specific parts are not even executed.

I’m really not sure why this issue (which till now only you and @anfaenger reported) exists or where it came from. If you can’t find a solution on your side, I’m not really able to help atm. “Did you try turning it off and on again?”

time zone: There was a big change here and yes Europe/Berlin is the default which is now (I suppose) more enforced than before. Of course it would be desired to have your system choose the right one on it’s own. The change to allow that once again shouldn’t be as complicated.

Of course and that’s what I intended to achieve very soon. Hey, I’ve already mentioned that in the announcement for v1.1 :smiley:

Try this in case you are running the km200-binding which needs strong encryption support:
@ThomDietrich Can we integrate this step in the setup procedure ?

Zulu JVM - Setup strong encryption:

Accept the license agreement, then download and install the strong encryption policies (use sudo!):

cd ZuluJCEPolicies
cp *.jar /usr/lib/jvm/zulu-embedded-8-armhf/jre/lib/security

This worked for me, the error in the log is gone afterwards. I rebooted to make sure everthing is working fine after the file exchange.

Interesting. This is needed only for the KM200 binding? Any other use cases or potential downsides?

Up to now I personally only needed it for km200 (Buderus / Junkers heating gateway), but I assume this may become more interesting when IOT is finally considering security and encryption.

@Kai any concerns from your side (by the best of your knowledge)?

Concerns regarding what exactly? Having it included in openHABian directly? Having it as an option without asking the user to approve the license? Having it as an option with some additional license and disclaimer info as on the Zulu site?
I don’t really have a clear advice and IANAL. Afaik, if we would include it, we would have to make sure (by our license/download terms) that it must not be exported to restricted countries; this might be tricky to do. So imho it should only be an option and we should probably refer to the Zulu terms so that the user accepts them when downloading.

At the moment I’m not able to check this. Will take until saturday.

Edit: Once more I started from scratch. At the moment, after a fresh installation, SAMBA is ok. (But I’m still building up.)

Well, yes, I’ll give you a response - no problem. PN in german language?
By the way: tried to shut the system off: neither shutdown, poweroff, reboot, … would work for me. So I’m not even able to look for Linux commands because they dont work…

What I expected OpenHABian to be:

  • fully functional Linux System and fully configurable (keyboard layout (yes, one needs that for even simply writing “set-timezone” on a german keyboard layout…), time zone, etc.)
  • GUI
  • OpenHAB preinstalled --> OK
  • all necessary Add-Ons preinstalled (Samba, VNC, etc.) --> OK, I suppose
  • everything preconfigured --> OK
  • read to use (without sitemap, etc. of course) --> 90%


Also for Satel binding

Just a quick one: Can you please check, if the repositories are complete? Didn’t get ANY update in a while, so I am wondering if some repos may be missing?

These are the ones that get checked,but I can’t see a repo where the system may pull OpenHAB2 updates from:
[22:40:49] openhabian@openhab:~$ sudo apt-get update

Get:1 jessie InRelease [22.9 kB]
Get:2 jessie InRelease [14.9 kB]
Ign stable InRelease
Get:3 stable Release.gpg [821 B]
Ign stable InRelease
Hit stable Release.gpg
Hit stable Release
Get:4 stable Release [6,050 B]
Get:5 jessie/main armhf Packages [8,981 kB]
Hit stable/main armhf Packages
Get:6 jessie/main armhf Packages [147 kB]
Get:7 stable/main armhf Packages [666 B]
Ign jessie/main Translation-en_US
Ign stable/main Translation-en_US
Ign jessie/main Translation-en
Ign stable/main Translation-en
Ign jessie/main Translation-en_US.UTF-8
Ign stable/main Translation-en_US.UTF-8
Get:8 jessie/contrib armhf Packages [37.5 kB]
Get:9 jessie/non-free armhf Packages [70.3 kB]
Get:10 jessie/firmware armhf Packages [1,232 B]
Ign stable/main Translation-en_US
Ign stable/main Translation-en
Ign stable/main Translation-en_US.UTF-8
Ign jessie/contrib Translation-en_US
Ign jessie/contrib Translation-en
Ign jessie/contrib Translation-en_US.UTF-8
Ign jessie/firmware Translation-en_US
Ign jessie/firmware Translation-en
Ign jessie/firmware Translation-en_US.UTF-8
Ign jessie/main Translation-en_US
Ign jessie/main Translation-en
Ign jessie/main Translation-en_US.UTF-8
Ign jessie/non-free Translation-en_US
Ign jessie/non-free Translation-en
Ign jessie/non-free Translation-en_US.UTF-8
Fetched 9,282 kB in 35s (265 kB/s)
Reading package lists… Done
Thanks a lot :slight_smile:

I don’t know what’s happening but “sudo shutdown -h now” for a shutdown and “sudo shutdown -r now” for a reboot has always worked for me.

1 Like

Hello Community,

im a new user to Openhab and really appreciate the work that was done on openhabian!

I really need some help of the community:

With the last update i did from the openhabian-config my networkshare via samba is not working anymore… (user openhabian:openhabian?). I get an error that i dont have the permissions, the folders conf, log, sys and userdata i see. So what am i doing wrong?

Openhab with default installation working problemless



@ThomDietrich, any input here for me? I’m not sure, but I’d guess there should be some of the cloudbee or bintray repositories listed (or whereever the repos have been moved to lately) ?

These ones will provide openhab2 :wink: you’re on the stable version by default so only get updates on major releases.

Hi, is it possible to run openhabian on a orange pi plus 2e?

Just figured out, that there wasn*t any update to the stable version release at all, since the release of 2.0.0-1. Wasn’t aware of this before, so it’s clear why some functions may be missing here.

I must admit, it has become a little bit difficult to stay up to date with the development of OH2, since there are so many things not fully documented yet. One must be lucky to use the right keywords to find specific answers currently, as so many things are spread across different chats and are in different states of maturity. Since OH2 was targeted at making things easier for the average user (I’m not a developer), it feels that this is not really the case yet :grin: