openHABian hassle-free openHAB Setup

Hi all,

I did the same as user Estranged with the same result. Everyone any idea?


Use openhabianpi-raspbian-20170318-git9767b24-crc9616e8a1.img.xz instead of openhabianpi-ua-netinst-20170317-gitbd31755f-crc88a5ae46.img.

I have used 20170318-git9767b24-crc9616e8a1.img.xz, but the result was the same. Any other idea? Thanks for your answer!

Best regards

Look at this topic Unable to boot on RPI3 with latest update

thanks for nice and easy setup of openhab 2 :slight_smile:
I have installed openhabian on both a PI3 and a PI0. On PI0 I can not figure out how to change SSID and PW. I have tried to enter configuration menu: sudo openhabian-config, and then option: 31 WiFi Setup, but an error appears and saying that this option only works on PI3, the same option is working fine on my PI3.
Have also tried to change in the config file on the memory card where I changed it before installation, without any luck.

Is there anything I am missing? Hoping someone can point me in the right direction :grinning:

has no wifi :grinning: unless you have a pi0w

I am sorry I ment pi0w :wink:

1 Like

Hey Jostein,
openHABian is under constant improvement and while the Pi0W as a supported device and the wifi support as a feature during setup where added, I missed to add the Pi0W as one of the supported devices for function 31.

I’ve implemented the needed change. Would you please Update and test it?

Btw. from the diff you’ll see that the file /etc/wpa_supplicant/wpa_supplicant.conf is which you normally want to edit in your situation.


this worked like a charm! Thank you very much for fast response and nice fix :smile:


1 Like

Nice to read I was not the only one struggling! :slight_smile: I spent about a full weekend (and some evenings) and lost the motivation in the process struggling(*) with the Linux setup (never even got to see openHAB). This because the openHABian required Ethernet for the self-configuring part (I only have WiFi where I setup the system) and I tried to learn the Linux part to get it to work anyway… I guess I will give it a second try once I have the time again.

I really like the concept of openHABian and recognize all the time and effort put into it. It is close - but not fully 100% idiot-proof (yet) for Linux-illiterates like me. :wink:

(*) I tried on RPi3b, RP0w and Pine64+ - all with built in WiFi


I used the openhabian-config to switch back to snapshot.
However, after reboot I get a log entry that the packages cannot be found:

[ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-persistence-mapdb, ...

Isn’t the addons’ new location covered by the switch tool from stable to snapshot?
Do I need to install openhab from the openhabian-config again?
(I did not try it yet, because I am afraid to mess it all up :wink:
Thanks in advance.

Hey Idus,
I’m confused about the narrative of your comment. Did openHABian work or not work for you? Both Ethernet and Wifi are supported. Please check the documentation for more details, regarding Wifi also check the last changelog: openHABian hassle-free openHAB Setup

I’d be happy to address these few percent, what’s itching?

Not sure what’s going on there but the switch to snapshot barely does more than changing the used repository and triggering an update, just as documented here:

Did you try installing the add-on again from within PaperUI? Also please try restarting openHAB. The first start after the upgrade might be jolty.

Thanks for your lightin-fast response. :slight_smile:
I have setup all required addons (including PaperUI) in the addons.cfg.
Unfortunately none of these are installed:

Failed installing 'openhab-persistence-mapdb, openhab-binding-exec, openhab-voice-marytts, openhab-binding-network, openhab-binding-denon1, openhab-ui-habpanel, openhab-persistence-jdbc-h2, openhab-misc-hueemulation, openhab-binding-mqttitude1, openhab-binding-mqtt1, openhab-transformation-map, openhab-binding-sony, openhab-ui-habmin, openhab-action-mqtt, openhab-misc-myopenhab, openhab-transformation-exec, openhab-binding-systeminfo, openhab-ui-paper, openhab-binding-caldav-personal, openhab-binding-wol1, openhab-binding-http1, openhab-transformation-javascript, openhab-binding-tcp1, openhab-binding-weather1, openhab-transformation-regex, openhab-transformation-jsonpath, openhab-binding-zwave, openhab-binding-caldav-command, openhab-action-telegram, openhab-persistence-rrd4j, openhab-ui-basic, openhab-binding-ntp, openhab-binding-astro': Keine Berechtigung

“Keine Berechtigung” confuses me.
So there might something be wrong with access rights!?

Will openhab find the addons if I place the latest addons.kar in the /usr/share/openhab2/addons folder?

After a reboot I checked the karaf console and found the bindings with "bundle:list -s"
HOwever, some are “active” and some “resolved”.
Does the latter mean they are not running yet?

After copying the addons.kar file into /usr/share/openhab2/addons all addons seemed to be loaded.
A more thourough check is needed though.
Problem solved so far … :slight_smile:

Hello again,

I do not criticize openHABian - I understand it is a mouthful and far better than most packages on the Linux platform. But as a Linux novice - I compare to the OSX or Windows platforms when it comes to n00b PnP to be 100%. It is exceptionally good to be 97% n00b proof on a Linux platform.

a) To be clear it did not work

b) As previously stated - I did not/do not have Ethernet available where I would install it. I started with the information stated on “” - continued on “” as well as browsing “”.

I finally found the text about configuring a file to have the WiFi work… but the documentation was not clear (to me) if it was something I should do on the installed openHABian system (had to learn some more about Linux for that), the SD-drive on another Linux system or (finally) edit the SD on my Windows system… so I tried it all… on all three platforms I have available (RPi3b, RPi0w and Pine64+) - several attempts on each. Still without managing to connect to my WiFi network (801.11a/b/n). I used different micro-SD cards and readers if the writing of the image became corrupt. I created a seperate WiFi net with extremely simple login etc. The installation most often stated that it skipped the WiFi-setup and that no Ethernet was detected - and then I only had the option to restart. Even if I managed to exit there - I could not find or start openHABian configuration tool. THAT might have been a nice option to actually start in the configuration tool either way - so one could set the WiFi and restart?

Gotto run for now.

Cheers and thank you again for the effort! :slight_smile:

Hey @Idus,
this change should address your concerns, what do you think?

The article update will be available in the official documentation shortly.


Nice work!

I would suggest the following or a version of it to make it crystal clear for beginners:

row 179
Insert and access the first SD card partition from your file explorer on your ordinary computer

…to point out that it is not done on the system that you are trying to create (not obvious)

rows 93, 101, 127, 135
with username ´openhabian´ and password ´openhabian´

…to emphasize both parameters (since the previous to some can be dubious).

The first one is where I struck out myself - the second one is from another document case that I was involved in that created unnecessary support-issues.



…curious though.

If no WiFi is setup the way described… why not be able to open the openHABian configurator efter the first run? Why does it “stuck” if (then) there is no Ethernet. Should it not then just go straight to the configurator for you to set the WiFi after the installation?

Just a reflection of mine!

Installing openhabianpi-raspbian-20170318-git9767b24-crc9616e8a1.img.xz on a RaspberryPi 2 and found my old edimax wifi USB dongle (EW-7811Un) works like a charm after setting the wifi_ssid and wifi_psk in openhab.config.

Unfortunately when your wifi name contains a space you need use double quotes, which is something that should be documented to make it even more hassle free. At least without the double quotes the green led was rapidly flashing to indicate this issue.

1 Like

Just installed Openhabian on a fresh Ubuntu server 1604 following the manual installation method as per the docs.

When I run openhabian-config the menu does not include all options. Please see below to understand.

I’ve ran the Update option to update the openhabian configuration tool but this didn’t help.

Has anyone come across this before? Any idea why the menu in incomplete?