openHABian hassle-free openHAB Setup

I tried openhabian:habopen now. Doesn’t work either. @mstormi I had access to the.conf with my SD card in my pc. Changed it, doesn’t work. I will now reinstall everything and hope

Soo. I tried the other passwords (was quite sure i tested them too but forgot to list them) and didnt work either. I reinstalled and bam, first try success. Something possibly went wrong with the installation, now it works perfectly. :smiley:

having troubles getting the UUID and secret. I have read all the documentation and checked all the paths via ssh and no files are being created. I do have the connector enabled, tried via paperui and via addons.cfg with multiple reboots. Permissions in /var/lib/openhab2 look good. I am at a loss here, has anyone experienced this?

Edit 1: I am getting a permission error which is blocking uuid and secret from being created as found in the openhab.log. Looking into it now.

Edit 2 (Solved): Like I mentioned, I already checked permissions so I didn’t think it was that. I ended up disabling zram in openhabian-config, restarted, and that did the trick. Not sure the details of zram but something with it was causing issue.

What do you mean by that? Your post is lacking context. Why do you think it is related to openHABian ?
Use openhab-cli reset-ownership next time.

Most likely there wasa problem of file/folder ownership.

Is it possible that you had zram enabled when you ran openhab-cli reset-ownership?

Hi @ThomDietrich
I found recently openhabian-config > openHAB related got a new feature call

Default order     Reset config load order to default (random)


Can you advise what this feature for?

It’s the ‘undo’ option for the ‘Delayed rules load’ option right above.

Thanks, sorry to my bad English.

I tried to install openHabian on my RasperryPi. But I stuck directly at “[openHABian] Changing default username and password…” . I waited an hour with no changing. Then I tried it again with a new flash image but nothing changes. Any suggestions?

Try the beta debug guide. You probably did not use Ethernet or your DHCP/DNS/Inet setup is crippled.

I have a successful setup of openHABian 1.5 in my new RPi 3B+ with an Ethernet connection.
Yesterday I tried to move it to a more central place within my house to improve zwave network, sadly I do not have a LAN cable at this location.

So I used openhabian-config to active my Wifi network, SSID and PW worked correctly after a reboot as the Pi gets an IP from my router.
First the Pi seems to loose its IP address all 1-2 seconds an got it back on its own. after some testing I got that worked with some reboots and switch off power safe mode.

I attached Keyboard an Display on the Pi, Network is working, can ping other devices in my network, even my Onedrive mounted fine with rsync, so also internet connector.

I tried to connect to my Pi via SSH and even openHAB UI but it will not work, only access from was possible.
After a lot of investigation about the issue I still cloud not get it work.
I switched back to Ethernet manually, sadly there is no config option to do that in openhabian-config and my Ethernet was gone completly even if I plug in the cable and do a reboot.

Any suggestion on what could be the issue ?
Ports for ssh and openhab where listening in the IP (from netstat -lntp) no iptables or something like that.


openHABian really is Raspbian Buster under the hood when it comes to networking, and that’s a very complex topic. You can try asking for help in a Raspbian forum or similar, but noone can tell from your description what you changed or did and what state it is in now.
It’s probably easiest to flash a new SD card with openHABian and import your OH config from backup.

Thought this is an openHABian thread so I assumed someone has challanged the same issues here.
Searched around a lot by google finding many forums but now luck.

At least, all I did was “enable WIFI” with openhabian-config.
I’m using the onboard wifi chip

Wifi is working fine local on the Pi include internet connection.
But can’t reach any service like openhab or ssh from my windows PC for example or any other machine on the network.

I will keep searching other forums as well in the meantime, still hoping to get some help here too.

How are you trying to reach the Pi? By IP address? Or by hostname? Remember that as you moved it, the old address may be sitting on the DHCP server for a while. Can you try using the new IP address? Such as: http://192.168.1.XXX:8080 - fill in the correct IP.

Thanks for your time and the answer.
Yes I know that, would say I’m an professional somehow on networking an other things, as It is also my job.
Checked the routes DHCP Leases and also removed the old lease and reservation from the router.
Tried ping and also dns resolution, cleared DNS caches as wenn.
So I’m definitly connect to the correct ip.

Hello everybody!
I’m running a openHABian setup on a rpi3(non+) + ssd (boot from sd card).
i’m thinking to get a rpi4 and upgrade to latest openHABian.

what’s my best approach here?
amanda is intended for backup an thus not suited for a migration, right?
and backup-cli will not help with mosquitto, grafana and other things if i understood correctly?

will there be any noticable difference(=increase) in performance with the new pi4 (4gb?)?

best regards

Well you could use Amanda to migrate, too, but it’s unknown if your RPi3 OS/kernel will flawlessly work in a RPi4 (pretty likely it will not).

Your best approach is to dist-upgrade the OS, upgrade openhabian-config and stick with your box.

hmm, too bad.
thanks for your advice!

I would like to share my experience with the sudo openhabian-config CLI tool.
I’m a new to the openHAB world and succesfully managed to install openHAB via openHABian on my Raspberry Pi. Everything worked out very well, so a big thanks to the community for the automated installation :clap:, until I came to the point of using the sudo openhabian-config tool. Afterwards it looks like a very basic knowled of Linux CLI tools, but in that situation of selecting the options of the lists in the CLI tool I had no glue how to select the several options. The soltuion is the keyboard space.

I would like to share my suggestion of improving the experience for beginners: Could it be possible to point out available keyboard commands and their affact on the system in the CLI tool? Either on the start page, in the “00 | About openHABian” or “99 | Help” menue entry?

Example list of possible commands:

|| Prompted option in the CLI----------|| Keyboard command-----||
|| Go into sub menu------------------------|| key: enter / new line--------||
|| Jump between List - Execute - Exit–|| key: shift-----------------------||
|| Selection of an list item / option-------|| key: space--------------------||
|| Deselection of an list item / option----|| key: space--------------------||

I don’t know, if this is here the right place for my reply. If not, please let me know!

so i updated to latest openHABian recently and everything works fine.
turns out my setup runs on jessie:

[18:57:34] openhabian@openHABianPi:~$ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"

on the official raspberrypi page it says

Upgrading an existing Jessie image is possible, but is not guaranteed to work in every circumstance. If you wish to try upgrading a Jessie image to Stretch, we strongly recommend making a backup first — we can accept no responsibility for loss of data from a failed update.

and i foudn the same info for update Stretch > Buster…

does anybody know if a dist upgrade on openHABian (usually) goes through without problems or do i have to expect trouble?
and should i go jessie > stretch > buster or straight jessie > buster?