openHABian hassle-free RPi image - login failed


I am happy that this Raspberry image for openhab2 exists. I tried it and the installation is probably ok, but I have some trouble with the passwords.
Via the login “pi” and the password “raspberry” I get access via WinSCP. But that’s it. On the Raspberry screen I have to type the openHABianPi login and the corresponding password. But neither via the “pi” nor the login “openhab” and the passwor “habopen” runs.

Also the access via the browser with “http://openhabianpi:8080/” results in a failure “no access” respectively what are the correct passwords

Did I made a mistake?

Me too!
I did sudo apt-get install lightdm
and in sudo raspi-config BootOptions I selected Desktop Login as user ‘pi’ at the graphical desktop.
But I can’t login on raspi-graphical-desktop.

ok, I tries the installation proces again and now it runs. Probably there was a failure within the 1st installation.

Hey guys, let me try to clarify a few things.

so far so good.

I accept that this might only be my believe and does not have to be true for all use cases… still I’ve earned some experiences with embedded devices over the years, so please let me say the following:
Do not use the Raspberry Pi like a desktop system. The RPi is supposed to sit in a corner serving as a headless system. If you want to interact with it you should connect from your (powerful) real/office/work PC via WinSCP and putty or whichever tools you prefer.

Anyway, this should have worked. One hunch is that you got trapped by the QWERTZ vs. QWERTY problem. You should have tried to type pi and raspberrz (This wouldn’t happen via putty :stuck_out_tongue_winking_eye: ). On the other hand openhab:habopen does not work as this is a system user dedicated to openhab and not empowered with a shell.

@ThomDietrich Didn’t really think about it. You’re probably right.

I use the raspi-display to watch installation progress, when I do a new installation.
And at the end of such a installation the login screen appears.
So just because the login-screen appeared, I tried to login and then wondered why I couldn’t login.
Because I’m a beginner and do not know what else is coming up, I thought that maybe, sometime it could be useful.

@SteMo Does this mean, you can login on raspi-desktop with the same user/password you use when you login with WinSCP?

No, i can’t login direct with thr Raspi screen but via WinSCP and openHAB2 runs.
So far, so good, but now the next problem occurs. I thought it’s all solved with the image file.
I want to use the z-wave module on my Raspi (not a stick) but I get the failure in the paper UI:
“Serial Error: Port /dev/ttyAMA0 does not exist”

With ls /dev via Putty I see the ttyAMA0.

What happens here? Has someone the same problem. I had this problem also with openHAB1 and could solve it, but with openHAB2 all the pathes looks different.

Check the last paragraph here: openHABian hassle-free openHAB Setup

I run Raspberry Pi3 with raZberry z-wave-controller-board.

@SteMo Did you do installation with openHABian and then run sudo openhabian-config and choosed option 20 Serial Port?

I used the preset options like you see below

Then you have to set port configuration to /dev/ttyS0 in openHAB

This works for me.
@ThomDietrich Thanks for this great and easy to use tool!

thanks for the more in detail description :wink:
Actually for a Razberry to be usable you’d need to disable Bluetooth… to my knowledge. I do not own one myself.

Either it’s disabled on your system already (check /boot/config.txt) or you own a different Razberry version?

Thank you for this really excellent support. It runs.

1 Like

@ThomDietrich How can I check raZberry version? (Edit)

That’s my /boot/config.txt

Your config.txt tells me, that Bluetooth is not disabled on your system. The Razberry should not work :smile: I’m not sure about the version question, it should be printed on your PCB. But whatever the version is, I was under the impression you need to disable Bluetooth for all of them :slight_smile: