Openhabian - Raspberry Pi 3 - Installing git package... FAILED


I have brand new Raspberry Pi which I used for two weeks testing openhab. However I had some issues during two weeks, openhab was running slow so been advised to reinstall openhabian and start again.
Last night I have had removed micro SD card (32GB Sandisk Ultra), formatted as per tutorials and reload openhabian image. After approximately an hour I tried to access RPI via dashboard (http://openhabianpi:8080) in order to complete the installation. But something is stopping access , cant access dashboard.
As I know the IP address of RPI , I was able to SSH to it. Upon typing default username and password was able to access it and found this status:

2017-11-29_02:37:20_UTC [openHABian] Starting the openHABian initial setup.
2017-11-29_02:37:20_UTC [openHABian] Storing configuration… OK
2017-11-29_02:37:20_UTC [openHABian] Changing default username and password… O
2017-11-29_02:37:20_UTC [openHABian] Setting up Ethernet connection… OK
2017-11-29_02:37:20_UTC [openHABian] Ensuring network connectivity… OK
2018-03-31_10:33:54_UTC [openHABian] Waiting for dpkg/apt to get ready… OK
2018-03-31_10:34:13_UTC [openHABian] Updating repositories and upgrading install
ed packages… OK
2018-03-31_10:38:56_UTC [openHABian] Installing git package… FAILED
2018-03-31_10:38:56_UTC [openHABian] Initial setup exiting with an error!

So I tried , again by formatting SD card and writing openhabian (the latest realese v1.4) to SD card. Every time it ended at the same place, showing that git package installation has FAILED.
I tried this process 4 times yesterday , every time with the same result.

This morning I decided to try brand new 32GB SD card (Sandisk Ultra) , wrote the image and was hoping that this would work but the result were exactly the same as when I was using first card.

Just to add , both my cards are genuine, tested them with FAKEFLASHTEST software and it has passed test.
First card was used without problems for about two weeks.

My PSU is genuine Raspberry unit with the rating of 2.5A.

Can I ask for help please?

1 Like

I’m having the same problem after downloading the currently available image today using Raspberry Pi 2 Model B v1.1

UPDATE: Swapped out power cable … no change. Power cycled the Pi, it seems to be working now? shrug

At least is not only me.
I`m using RPI 3 model B with openhabian v1.4

i fixed the problem by copying this script
to /boot/
You can also manualy add the line apt update &>/dev/null under this line:
echo -n "$(timestamp) [openHABian] Installing git package… "

That fixed my problem.
Hope I could help


Thanks sparky.

I tried that but that didn`t worked for me.

Its strange as Im trying to install the same version (1.4) as I had on RPI till yesterday.

Tried my second SD card (brand new) but without any luck.

Just to check - I should be connecting my RPI to home router before powering up for the first time ?

I have the same issue and tried the various solutions without any luck. Did any one solve this problem?

Same issue, what’s wrong?

I had the same problem with an attached Echo Dot. When I restarted the Pi and detached the Dot everything worked. :smiley:

Thanks, that worked for me.

The same error happened during my installation. By logging on to the Raspberry and re-executing the sudo apt-get install git command, I received an error message telling me to run another command first (I forgot which one). Then after running this command the apt database was fixed and then rebooting the device did restart the installation that then continued fine.


Thanks, that helped! Had to run an apt-get update first however - Look like the installer script is broken?

1 Like

I had the same issue. As far as I can remember the install scripted failed at one stage because a git clone had not completed successfully. I either commented out the line in install script or deleted the git workspace and rebooted. It then worked.

Thanks. That worked for me too.

I have same problem then find this thread.
I fix the problem by manual install the git package and then reboot

This thread help me too

BTW currently installing Openhabian 1.5 on Rpi 3 - same problem.

root@openhab:/home/openhabian# cat /boot/first-boot.log
2019-07-10_01:21:39_BST [openHABian] Starting the openHABian initial setup.
2019-07-10_01:21:39_BST [openHABian] Storing configuration… OK
2019-07-10_01:21:39_BST [openHABian] Starting webserver with installation log… OK
2019-07-10_01:21:45_BST [openHABian] Changing default username and password… O K
2019-07-10_01:21:51_BST [openHABian] Setting up Ethernet connection… OK
2019-07-10_01:21:51_BST [openHABian] Ensuring network connectivity… OK
2019-07-10_01:21:51_BST [openHABian] Waiting for dpkg/apt to get ready… OK
2019-08-07_19:04:54_BST [openHABian] Updating repositories and upgrading install ed packages… OK
2019-08-07_19:07:12_BST [openHABian] Installing git package… FAILED
2019-08-07_19:07:52_BST [openHABian] Initial setup exiting with an error!

sudo apt-get install git

Fixes the issue, but is there is something to fix in release?

I was trying to install openhabian on my raspberry. I got the same message

This posting helped a lot
I performed this commands:
sudo dpkg --configure -a
sudo apt-get install gi
sudo reboot

After that the first boot runs without errors.
I think, someone should fix this in the install image.
Now I’m ready for the first experience of openHAB :smiley:

I think(,) someone should read the docs first.

Maybe you are right :wink:
BUT the initial boot did not work. So I looked with my browser at :80 (yes I did not read that) and after that I used SSH und used google with the error [openHABian] Installing git package… FAILED
I found this thread. After I used the three commands on the console
sudo dpkg --configure -a sudo apt-get install gi sudo reboot
everything runs fine. :+1:
Now I’m trying to get my SmartMeter running :wink: