OpenHabianpi:8080 stopped working

.I am having difficulty setting up OpenHabian on a Rasberry Pi3B+.
I have had it working initially but found I no longer had a config file when I came to add my first real device. I decided to reinstall OpenHabian on the RPi to get back to a first time installation. I have now tried three times, but cannot get a response. On the second occasion I started with a new SD. These subsequent attempts were with a different router since I have changed IP provider.
Runing the windows diagnostics I get the following:-

resource (openhabianpi) is online but isn’t responding to connection attempts.

The remote computer isn’t responding to connections on port 8080, possibly due to firewall or security policy settings, or because it might be temporarily unavailable. Windows couldn’t find any problems with the firewall on your computer.

I have pinged the device and that responds correctly.

I can log onto Habian using PuTTY and this is what I get.

2018-03-13_22:53:38_UTC [openHABian] Starting the openHABian initial setup.
2018-03-13_22:53:38_UTC [openHABian] Storing configuration… OK
2018-03-13_22:53:38_UTC [openHABian] Changing default username and password… OK
2018-03-13_22:53:39_UTC [openHABian] Setting up Ethernet connection… OK
2018-03-13_22:53:39_UTC [openHABian] Ensuring network connectivity… OK
2018-03-13_22:53:39_UTC [openHABian] Waiting for dpkg/apt to get ready… OK
2018-03-13_22:53:54_UTC [openHABian] Updating repositories and upgrading installed packages… FAILED
2019-10-20_16:30:49_UTC [openHABian] Initial setup exiting with an error!

The following is the file which I used to create the bootable SD

I have looked at other posts on the forum but they are beyond my current understanding. I am following the instruction by B K Hobby on YouTube with a windows 10 machine.
I feel sure that it is something simple to get it running if anyone can help. I do not know anything about Linux.

Have you tried the latest 1.5 image of openhabian?
I had this issue a while back and found a small delay in one of the script files helped. When I checked while installing the 1.5 image it looks like those delays were added.

The short answer on why you can’t access port 8080 is because the install failed.

1 Like

Nailed it… try again

There is a known issue with new installs of openhabian because the location of the ZULU Java JRE changed at AZUL. There are workarounds proposed until openhabian is fixed.

While this thread purports to be for Pi4, the problem also exist on other Pi model. [SOLVED] (Raspberry Pi 4) openHABian v1.5.0 Error w/ Installing Zulu Embedded OpenJDK

Thanks for your reply. The 1.5 image has made no difference. I am aware that the instal failed. I would like to know how to find out why. It looks like I shall have to give up openhabian.

please check Bob Dickenson’s reply directly above yours. I believe there is your answer

I have tried but I can’t understand it. Thisis a shame because I like the look of OpenHabian. I am going to try and see if I can get Home Automation to load on the pi.

from the thread on github step by step

You need to SSH in to you device …
then execute this command…
sudo nano /opt/openhabian/functions/java-jre.bash
then press Ctrl+w (find)
and paste this # Fetch and copy new JAVA runtime
then delete the line BELOW this one.

And paste this
cond_redirect wget -nv -O "$jdkTempLocation"/zulu8.tar.gz

Then press Ctrl+o (not zero but O… it means save)
And then press Ctrl+x to exit

Then execute this command
sudo nano /boot/first-boot.bash
and find this line
(again press Ctrl + w and paste the line)
echo -n "$(timestamp) [openHABian] Cloning myself... "
You will see this three lines…
echo -n "$(timestamp) [openHABian] Cloning myself... " [ -d /opt/openhabian/ ] && rm -rf /opt/openhabian/ # check if we have remnants of a previous installation attempt. git clone -b master /opt/openhabian &>/dev/null

You need to disable these lines… You could delete them but it is better to put hash tags on the beginning (# )
the lines shoul look likne this

# [ -d /opt/openhabian/ ] && rm -rf /opt/openhabian/ # check if we have remnants of a previous installation attempt.
# git clone -b master /opt/openhabian &>/dev/null 

And again press Ctrl + o (not zero) and Ctrl + x
then execute a reboot
sudo reboot
and wait a while you should see openhab working if you navigate to :8080
If after aboul an hour still nothing SSH again and reboot again

Sorry I’ve taken so long but I discovered that the sd card was faulty and had to get a new one. I have now reinstalled with the latest version. I cannot openhabianpi:8080 but I can access it using the ip address. Before I start trying to edit the files on the sd card, is this necessary since I have a means of access?
I can access the files to edit through putty. If I open from the browser, I can get the Habian software.
I have to thank you for the detailed text you sent.

1 Like

If use of the openhabianpi hostname does not work but using its IP address does then your DNS and/or DHCP is not setup to work properly which is beyond openhabian scope so don’t start messing around with openhabian config. Check how your router assigns names in DHCP.