OpenWebNet binding openHAB2 - Gateway not connecting

Tags: #<Tag:0x00007fc3f748beb8> #<Tag:0x00007fc3f748bda0> #<Tag:0x00007fc3f748bcb0>

Hello everyone,

First of all I’d like to thank @massi, @gozilla01 and all other contributors for their fantastic work on the BTicino/OpenWebNet binding.

It was working perfectly… until last night :weary:

My setup

  • BTicino MyHomeServer1, firmware 2.14.16, connected via LAN to the modem which assignes a fixed local IP of 192.168.0.2
  • Raspberry Pi 3 model B with Raspbian + Docker, connected via WiFi to the same network of the MyHomeServer
    • Container 1: MQTT broker (image pascaldevink/rpi-mosquitto), running with --net=host - shouldn’t be relevant for the issue
    • Container 2: Node-RED (image nodered/node-red-docker:rpi) which I use for MQTT messages handling, all the logic and external communication (listens to openHAB events & sends openHAB commands through the node-red-contrib-openhab2 node); only port 1880 is binded to host port 1880
    • Container 3: openHAB v2.5.0.M1 (image openhab/openhab:milestone, installed following [official guide), running with --net=host, which I use just for the binding to the MyHomeServer1 (I installed the binding following the README-beta, so also installing the two features through Karaf)

The issue

At my first install, the binding correctly found my gateway, connected to it and discovered all the Switch and Automation Things, which I added to openHAB. Status of Things was correctly received from the gateway, and commands were correctly received by the MyHomeServer1 from openHAB. Also Node-RED <-> openHAB connection was doing great. Dreamland, basically.

Yesterday evening, I installed Dataplicity daemon on the RPi (not on a container), to have a Wormhole on port 80 and be able to use IFTTT with Node-RED - this in my opinion shouldn’t impact OH configuration, but I’m adding it for completness.

All of a sudden (but not right after Dataplicity install), MyHomeServer1 stopped receiving commands from OH, and OH displayed OFFLINE - COMMUNICATION_ERROR status.

By enabling log at debug level as per README-beta, this is what I see in log:tail when I try to re-set the connection:

12:27:27.053 [INFO ] [smarthome.event.ThingUpdatedEvent    ] - Thing 'openwebnet:bus_gateway:myhome' has been updated.
12:27:27.055 [DEBUG] [ebnet.handler.OpenWebNetBridgeHandler] - ==OWN== BridgeHandler.initialize() 
12:27:27.063 [DEBUG] [ebnet.handler.OpenWebNetBridgeHandler] - ==OWN== Bridge type: openwebnet:bus_gateway
12:27:27.058 [DEBUG] [ebnet.handler.OpenWebNetBridgeHandler] - ==OWN== BridgeHandler.getConfigStatus() 
12:27:27.074 [DEBUG] [ebnet.handler.OpenWebNetBridgeHandler] - ==OWN== Creating new BUS gateway with config properties: 192.168.0.2:20000, pwd=*********
12:27:27.085 [INFO ] [smarthome.event.ConfigStatusInfoEvent] - ConfigStatusInfo [configStatusMessages=[]]
12:27:27.086 [DEBUG] [rg.openwebnet.bus.MyHomeJavaConnector] - ##gw-openwebnet-connector## Created MyHomeJavaConnector 192.168.0.2:20000
12:27:27.119 [DEBUG] [ebnet.handler.OpenWebNetBridgeHandler] - ==OWN== Trying to connect gateway...
12:27:27.147 [ERROR] [org.openwebnet.AbstractOpenGateway   ] - ERROR IN Java $MODULE$: connection cannot be established
12:27:27.157 [DEBUG] [ebnet.handler.OpenWebNetBridgeHandler] - ==OWN== BridgeHandler.getConfigStatus() 
12:27:27.179 [INFO ] [smarthome.event.ConfigStatusInfoEvent] - ConfigStatusInfo [configStatusMessages=[]]
12:27:42.994 [INFO ] [ebnet.handler.OpenWebNetBridgeHandler] - ==OWN== BridgeHandler status still UNKNOWN. Setting device=openwebnet:bus_gateway:myhome to OFFLINE
12:27:43.015 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'openwebnet:bus_gateway:myhome' changed from UNKNOWN to OFFLINE (COMMUNICATION_ERROR)

Please also note that:

  • BTicino official MyHome_UP app (v2.4.0) still works in local mode (both with Installer Code and User Code) and in remote mode (mail+password)
  • If I send something to the MyHomeServer1 using a simple Node-RED flow, I get *#*1## in response
  • In the OH Inbox I see a detected gateway: BUS Gateway MyHomeSERVER1 (192.168.0.2, v2.14) - if I add it, I get the same error
  • I think MyHomeServer1 firmware v2.14.16 is quite new

Things that I tried to fix the issue (with no luck)

  • Rebooting RPi and MyHomeServer1
  • Restarting Docker service
  • Restarting OH container
  • Executing OH while Node-RED was stopped
  • Deleting the OH container and re-building it (using the same mounted volumes to keep user data)
  • Re-building the OH container using image v2.4.0 (instead of milestone), also with completely fresh install (no prior user data)
  • Uninstalling and reinstalling the binding
  • Removing and re-adding the gateway Thing
  • Using HABmin interface instead of Paper UI to add the gateway
  • Changing OPEN password from the app, updating the details on OH

Unfortunately I don’t speak Java and I’m quite new to OH, therefore I can’t dive into the code and try to do a deeper level debugging.

If anyone is willing to help me on this, I’d be super grateful!

Thanks

Hi everybody,

getting the same error too:

ERROR IN Java $MODULE$: connection cannot be established

I have OH 2.4 stable and OpenWebNet 2.5 M2-1, usually I update this biding through Eclipse Market but I’m having the same error using old OWN (f. i. 2.4.0-beta7, 8, 9-1) versions (by direct upload to “addons” folder).

I’m afraid something has changed in OH2’s core :frowning:

My OH2 environment always worked with OWN flawlessly until last thursday, when I used openhabian-config to update system… Since then I started getting that error…

Andre

Guys, check the main thread:

Have a little patience and I will upload a new updated version that will work again with no changes in configuration.

Massi

Oh! That’s why It wasn’t working :slight_smile:

Thanks Massi, we’ll wait for the new biding!!!

Good to hear this - thanks @massi, looking forward to the update! :smiley:

here:

also this version lasts 1 month?

Yes, until it is formalized in OH.
Massimo is working to make it official, probably with the OH 2.5.0.M2 release

Ok thank

A stupid question. Is there a stable version that does not expire? I have to install it at my client’s home.

Thank you @massi - you’re a rockstar :sunglasses:

each version lasts 3m after release

not at the moment; I am evaluating several options…

Bticino Binding
binding-bticino1 - 1.13.0 this does not work anymore?

This is the old v1 binding. It is part of the official OH distribution and should have no expire. It has a completely different structure and approach from the v2 binding.

1 Like

Hello,
I have the same problem… How can I solve this problem?

Ciao, ho anche io questo problema, sto usando l’ultima versione disponibile del binding… come hai risolto?
grazie molte

Guarda sopra, devi seguire il main thread per aggiornamenti. Comunque il problema si risolve con l’installazione dell’ultimo rilascio di mvalla, ti suggerisco di installarlo sempre via Eclipse market place

@Andrew_082 grazie mille
Ho risolto reinstallando il binding…
Mi chiedevo se è possibile interfacciarmi anche con l’allarme bticino BTI 4201 @massi
Grazie molte
Luca

hello,
I have the same problem but reinstall doesn’t fix the problem
Yesterday I’ve deleted all the items and things from paperUi because I’ve written things and items file already tested: when I’ve finished the gateway was OFFLINE and the log says

[ERROR] [org.openwebnet.AbstractOpenGateway  ] - ERROR IN Java $MODULE$: connection cannot be established

I had the last version installed 2 weeks ago (2.5.0.201906162031)

Hello, Same problem. After restarting Openhab the gateway no longer works. I’m using the latest version of the binding ( 2.5.0.201906162031):

[ERROR] [org.openwebnet.AbstractOpenGateway  ] - ERROR IN Java $MODULE$: connection cannot be established

Some idea?