Paper UI - 500 Internal Server Error

I update today at latest snampshot. When I load Paper UI, i got a small dark grey box at bottom right, with a 500 internal server error.
Effect is that “Control” section is empty, and I do not have “Extension Section”.

Issue is with all browsers, and i grabbed console log with chrome:

Opening the URL ,I got this code:

{"error":{"message":"The template variable \u0027actionName\u0027 has no value","http-code":500,"exception":{"class":"java.lang.IllegalArgumentException","message":"The template variable \u0027actionName\u0027 has no value","localized-message":"The template variable \u0027actionName\u0027 has no value"}}}

Looking at the communiti i found this: Paper UI / Control triggers ERROR 500: Internal server error

Can you help me please?


I have just downloaded the latest #1050 build of openHAB and installed the Demo environment for testing. The REST interface is working fine.

Do you see anything in your openhab.log or error log? Would be nice to see the exception that occurred behind the scenes on the server.

Hi @triller-telekom,
I removed cometVISU ui AddOn, and now I do not get 500 Internal Server Error anymore, and I get back AddOn section, but if I click on Control, items are not loaded.
I have logs, what I have to search for?
May I send log to you?


You can search for the term “Exception” inside the logs and see if there is one that occurs ones you try to access the rest endpoint when the error 500 shows up.

after removed CometVISU ui, 500 Internal server error was gone. But if I click on Control, items are not loaded.

Control in paperUI only shows items which are bound to an existing channel. Are you sure that the items you are expecting to see are connected to valid channels of a thing?

Hi @triller-telekom
Things are linked to Item. This installation of OH worked fine until last update where I experienced this issue.
OH is working, I have hundred of item linked to things working fine.
Only page Control is empty.
There is not exeption when I open Control Page on Paper UI, perhaps I need to enable some specific log?



Strange, I don’t know what might have happend there…

Is there something in the local cache of the browser which might lead to a problem? Could you please try a “Ctrl + Shift + r” in chrome to force a reload?

If this also doesn’t help, can you please create an issue here?:

And please create a link to this thread in the issue and describe which version of OH you had installed before and to which version you switched.

Hi @triller-telekom,
how can i retrieve current version and which version of OH you had installed before?

Force reload do not solved.


Getting the current version: If using openhabian, simply connect via ssh, user openhabian and see in the welcome message something like: openHAB 2.2.0~20170913092906-1 (Build #1037), or if installed differently conenct to the OSGI console via ssh openhab@localhost -p 8101 which should show you something like “2.2.0-SNAPSHOT Build #1037

How to get the version you had before, is up to the system you know. have a look at its log files.

Hi @triller-telekom
thanks for patience. I have a snapshot of my OH2 VM, took before the upgrade. I reverted to this snapshot and grabbed the version.
I’ll open the issue.

Many Thanks

github issue: