Paper UI incomplete on fresh install - unable to create items

Tags: #<Tag:0x00007f7454245458>

Hi everyone,

I have just installed a fresh setup of openHABian with 2.5.0.M4 and I keep running into weird behaviour.

It seems like there is some issue with the interfaces. Paper UI does not seem to work completely - it’s missing links that I know from before - right now I’m in the process of adding items but I do not have the menu item for that and neither the linking option in the things. What am I doing wrong?

Thanks in advance!

@sihui wow thanks, I must have looked through that configuration menu 5 times and missed it each time. That’s what was I was missing.

Actually, I’m fine with “Simple mode” - how do I get the name of the item for the sitemap though? It’s not displayed anywhere else but in the Items table. And without it I cannot add an item to the sitemap. Any ideas?

Cheers!

Not really,
You will run into problems, like naming your items etc…
Disable the simple mode, friendly advice

1 Like

Good advice from Vincent, but if you still want to know:

Go to your things channels and select “Linked items”, you will get a popup with all your existing items.

grafik

@sihui Pretty sure that’s not available for me. Another unchecked option?

Sorry, no idea. I’m not using PaperUI for items …

@goddib have you stopped openHAB, clear cache and restarted. Go have a coffee before you try to open paper ui?

I had something like this happen once in an upgrade all I needed was cache cleared and a restarts.

A thought if you have not tried.

@Thedannymullen how would I best go about doing that cache clearing? I haven’t done that yet - last time I did that I did something wrong and needed a reinstall.

Somebody needs to do a PR for the official tutorial removing the advice to use Simple Mode.

2 Likes

Yeah that didn’t make a difference. Alright I will just without the simple mode.

1 Like