PaperUi, ClassicUI and HABpanel missing

When I browse to openhab:8080 I now only see Log Viewer, Help and HABmin.
I haven’t done anything or even looked at openhab for a few days and it was working fine before.
What has gone wrong and where do I start to fix it?
I have rebooted openhab but this didn’t fix it.

What do you see in the logs?

How did you install OH?

How did you install the add-ons?

I’m running openhab on a Raspberry Pi 3 using the downloaded image and flashing to an SD card.
The only add-on I use is MQTT added in PaperUI. All items and things installed from scripts.
This has been running for about a month or more, not a new install.

That’s the answer to two of my three questions.

Logs?

I’ve just shutdown completely and powered off and back on. There are no errors in the log. After intialisation the only entries in the log are mqtt messages from my Sonoff Bridge and a nodemcu with DS18B20s attached.

If I enter;
http://openhab:8080/paperui/index.html
in the browser I get

HTTP ERROR 404

Problem accessing /paperui/index.html. Reason:

Not Found

How did you shutdown? When you just yank the power there is a high probability of file system corruption.

Which log file are you looking in? Errors will be in in openhab.log.

Do you see the missing UIs listed after “ui” in /var/lib/openhab2/config/org/openhab/addons.config?

I used sudo shutdown -h now. Disconnected the power once it was shutdown then reconnected the power.
Log file is tail -f /var/log/openhab2/openhab.log /var/log/openhab2/events.log
This is all that is in my addons.config

:org.apache.felix.configadmin.revision:=L"2"
package=“minimal”
service.pid=“org.openhab.addons”
ui=“habmin”

an earlier backup contained the following

:org.apache.felix.configadmin.revision:=L"19"
action=“mqtt”
binding=“davis1,mqtt”
legacy=“true”
misc=",openhabcloud"
package=“standard”
persistence=“mapdb,mqtt”
remote=“true”
service.pid=“org.openhab.addons”
transformation=“jsonpath,map”
ui=“dashboard,basic,paper,habpanel,homebuilder,classic”

Should I restore the old one or edit the current one?

The file you have now will only install the habmin add-on and nothing else. Have you ever edited /etc/openhab2/services/addons.cfg? It appears that perhaps you may have edited addons.cfg to add habmin which caused everything else to be uninstalled.

If not and everything is commented out in addons.cfg, stop openHAB, restore addons.config, and then restart openHAB. It may take a few minutes to reinstall all the addons.

Thanks again Rich for your help.
I deleted addons.config and rebooted but addons.config was still minimal.
I then restored the backup file with all the settings including ui and it’s working.
Thinking back a week or more ago I did try using addons.cfg but had problems and commented out everything again but I guess it had an effect on addons.config.
Trouble is at 72 the short term memory is not what it used to be and after using openhab for about 6 months I’ve probably forgotten half of what I’ve learnt but help from you and others on this forum prompts the memory.

1 Like

Where do I find the addons.config?

“It depends” (on your install)

1 Like

Stop openHAB before editing.

1 Like

See post 6 above from Rich.

Once again I’ve done an openhab update through openhabian-config and it’s restarted with only Log Viewer and Help. I’ve checked addons.config and it only had minimal entries. I copied back an earlier backup with all entries and restarted but I still only get Log Viewer and Help. I’ve checked /var/lib/openhab2/config/org/openhab/addons.config and it contains the following

:org.apache.felix.configadmin.revision:=L"19"
action=“mqtt”
binding=“mqtt,modbus,davis1”
legacy=“true”
misc=",openhabcloud"
package=“standard”
service.pid=“org.openhab.addons”
transformation=“jsonpath,map”
persistence=“mapdb,mqtt”
remote=“true”
ui=“dashboard,basic,paper,habpanel,homebuilder,classic”

Where do I go from here?

From, to?

I’d be suspicious of anything still v1 in your addons.cfg

I removed
action=“mqtt”
binding=“… davis1”
persistence=“… mqtt”
and rebooted but it’s no different.
It appears mqtt is working.
I get the following error in the log

2020-09-21 19:10:59.299 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-persistence-mapdb, openhab-ui-homebuilder, openhab-transformation-map, openhab-ui-basic, openhab-ui-classic, openhab-misc-openhabcloud, openhab-ui-habpanel, openhab-ui-paper, openhab-transformation-jsonpath’: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=openhab-binding-modbus; type=karaf.feature; version="[2.5.8,2.5.8]"; filter:="(&(osgi.identity=openhab-binding-modbus)(type=karaf.feature)(version>=2.5.8)(version<=2.5.8))" [caused by: Unable to resolve openhab-binding-modbus/2.5.8: missing requirement [openhab-binding-modbus/2.5.8] osgi.identity; osgi.identity=org.openhab.binding.modbus.sunspec; type=osgi.bundle; version="[2.5.9,2.5.9]"; resolution:=mandatory [caused by: Unable to resolve org.openhab.binding.modbus.sunspec/2.5.9: missing requirement [org.openhab.binding.modbus.sunspec/2.5.9] osgi.wiring.package; filter:="(osgi.wiring.package=org.openhab.binding.modbus.discovery)" [caused by: Unable to resolve org.openhab.binding.modbus/2.5.9: missing requirement [org.openhab.binding.modbus/2.5.9] osgi.wiring.package; filter:="(osgi.wiring.package=org.openhab.io.transport.modbus.endpoint)" [caused by: Unable to resolve org.openhab.io.transport.modbus/2.5.9: missing requirement [org.openhab.io.transport.modbus/2.5.9] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.apache.commons.pool2)(version>=2.8.0)(!(version>=3.0.0)))"]]]]

Well, that’s a step forward then.

How can you tell?

I see mention of sunspec addon, not seen in your addons.cfg
Have you xxx.jar files in your /addons folder?

Or look in the addons.config file in the userdata tree. Stop openHAB before editing though.

I’ve removed action=“mqtt”, persistence=“… mqtt”and binding=“… davis1” and it still failed. I then removed modbus from bindings and it came good. I then added Davis1 back into bindings just to see if it had an effect and it is still working but I’m not getting any data from my weather station but that must be an unrelated problem.

Thanks for your help.