Paradox EVO Binding

…one more thing I just remembered. Which version is your IP150?
After certain version there is no option to directly connect to IP150 but instead you need to use Paradox cloud services. There was somewhere in the net a guide how to downgrade the firmware of it…

Same result with 2.5.0_M2 Paradox Binding does not start. I copied the openhab.log information.
I go back to 2.5.0 Build#1645 snapshot. Binding works with that version. Also I do not see in the bindigs list of Openhab, so the binding is still not included in the distribution. If there is newer version what works with these versions pls share.

Paradox_Binding_250M2.log (151.3 KB)

Witch openhab version do you use? See my reply’s, same problem I have, if I go above 2.5.0.#1645 snapshoot or same with 2.5.0 M2. Try it with 2.5.0 M1 or with 2.5.0.#1645. It will work seamless.

Hm… interesting. It seems that the thing handler factory is not working OK which comes from the framework. After that since the communication stays open it seems the retry cannot connect to the panel, thus making the updates also not working.
I’m again on travel now. Will come home today. Let me get back to you with version I use and maybe I can upload you the .jar I’m using for testing…
When I have time I will update to latest milestone and will test it myself as well.

Thanks! No hurry, I’m fine with working snapshoot. As I use mainy Zwave and Zwave has some issues what will be fixed soon and there are some fix between my snapshoot and M2 I would like to upgrade.

I’ve uploaded the very latest version which should be in the productive build on the binaries page on the
Previous version which works fine with 2.4 and 2.5 but not with milestone is moved to filename -OLD.jar

If you could give it a try would be great as I currently have some issues with my eyes and I try not to push myself too hard in the coding area after work…

Thanks in advance for understanding,

guys i have a Paradox evoHD. i am not sure if this addon will work.
i have my openhab updated but the binding does not appear. i downloaded the above link into the addons folder, restarted openhab and still i can’t find it. any ideas?

my version is 2.5.0 1645 and i downloaded the -OLD.jar to the addons folder. i tried to restart but nothing. it doesn’t show up

I have just downgraded back to 1645 and it works fine.
Check openhab.log about error messages.

Hi, thanks for the update. At first look it works with M2. But zone status reading was not working. Probably I need to reconfigure through PaperUI as there are changes as I saw. I do not have more time, so I put back 1645 but I’ll test it latest on the weekend and give you a feedback. Thanks!

well i am on 1645 and i have downloaded the paradoxalarm-2.5.0-old.jar in the openhab2/addons folder.

i restarted and all but… i see nothing

Have you configured bridge? I.e. IP, passwords, etc? Please raise binding level to DEBUG and send me the log file.
It could be that HD uses different protocol even though it’s not too likely. Another guy also had issues with EVOHD few posts up.

P.s. you put the jar in addons folder, right?

I haven’t configured anything yet because i can’t see the addon.
i downloaded it in the addons folder check the image

i am not sure what i am doing wrong but it is not in my binding list

When you copy it into the openhab/addons folder after a few minutes you need to see the binding in configuration bindings menu, plus inbox add menu as well. or, check openhab.log in User/Log folder and you need to see error message of binding installation.

hi, my jar file was corrupted. i deleted it and download it again. now it shows up.

i need to find tomorrow my installer password and try to check if it can work with my EVOHD. no idea if it works.


  1. IP150 Password… is it the 4 digit code?
  2. pc password ok i need to ask about the 6 digit code from my installer tomorrow
  3. port which one is it? in my web panel of the ip150 there are two… software and http
  4. panel type… should i input EVOHD?


EDIT. i managed to login (from what it looks like in the log file but i am still getting communication error in the openhab thing status

here is the log

Same error like the guy above. It is either different communication protocol in the HD or IP150 is newer version and you cannot connect directly to it. Can you check the version of IP150? Should be possible through the keypad or the web-interface of the IP150.

here is the log that i get

and IP Module
Firmware version 1.39.02

as for the panel…
Firmware version 1.20

i can login directly to my IP150 through ip on Chrome.

1.x should be OK.
Then the panel itself is using different protocol. To be sure you need to raise the log level of Paradox binding to TRACE send me the log file (it’s going to become big, because in TRACE, I log every TCP packet that we send/receive to panel).

Problem is that I cannot do the reverse engineering of the protocol. @Jean_Henning and @jpbarraca did the protocol reverse engineer and I used their knowledge for the low-level stuff to code it in Java add on for Openhab.

i tried to do the logging (never done that before)

not sure if this helps at all

I’m afraid that will not work. :slight_smile:
Please open the file ./userdata/etc/org.ops4j.pax.logging.cfg
and add at the end the following lines: = org.openhab.binding.paradoxalarm
log4j2.logger.paradox.level = TRACE
log4j2.logger.paradox.additivity = false
log4j2.logger.paradox.appenderRefs = paradox
log4j2.logger.paradox.appenderRef.paradox.ref = paradox = paradox
log4j2.appender.paradox.type = RollingRandomAccessFile
log4j2.appender.paradox.fileName = ${openhab.logdir}/paradox.log
log4j2.appender.paradox.filePattern = ${openhab.logdir}/paradox.log.%i
log4j2.appender.paradox.immediateFlush = true
log4j2.appender.paradox.append = true
log4j2.appender.paradox.layout.type = PatternLayout
log4j2.appender.paradox.layout.pattern = %d{yyyy-MM-dd HH:mm:ss.SSS} [%-5.5p] [%-36.36c] - %m%n
log4j2.appender.paradox.policies.type = Policies
log4j2.appender.paradox.policies.size.type = SizeBasedTriggeringPolicy
log4j2.appender.paradox.policies.size.size = 10MB
log4j2.appender.paradox.strategy.type = DefaultRolloverStrategy

Then restart the paradox binding and send me the paradox.log file that will be produced.

IMPORTANT SECURITY NOTE: I would propose that you send the file in personal message because some of the data can be used to be retrieve your passwords from the TCP packets. Be aware that if I have harmful intentions I may also retrieve this data and use it for the same purposes, so it’s up to you to accept or deny taking such risk. Please do not post the trace log here because anyone with access to community pages will be able to retrieve it and use it.

Once you send the file make sure to reduce the logger log level back to INFO from TRACE

Hello, I have EVO192 and it works fine. I can confirm that the latest version is working with openHAB 2.5.0.M2 Milestone Build. I’m working on new config file structure. I was success with the IP150 Panel, all Partitions and one of the Zones. I will finish all zones by tomorrow. It is a little bit tricky as I have to add first in Paper UI, copy ID to the text file. As soon as I finish, I’ll share my findings.