Paradox EVO Binding

hey thank you for the reply.

unfortunately i cannot share that kind of information since it is a multi-apartment installation.

don’t know if there is another way or someone else who can share it

As the problem is at your system, there is no sense to set up error trace for somebody else. This is what Polychronov requests from you. You need to open this file, add these lines to the end and check openhab.log for error messages. Or reinstall binding and check messages of the failed installation. If you do not provied it, he can’t fix your problem.

Hello, I have finished reconfiguration and openHAB 2.5.0.M2 Milestone Build works with your last version. No problem, partiton states, zone states reading work well. Thank You!

New zone configuration steps for xxx.things and xxx.items files:
Add Zone through PaperUI selecting IP150 bridge and add zone#:

Copy selected part of the link in the browser and delete zone in PaperUI:

Create zone in the .things file and save:

Create Items in .items file, change contact to Contact and save items file:

It should looks like this:

and you finished.

Not sure if these steps are really required. Are you sure that you cannot create them straight out of PaperUI?
I’m not 100% sure but when I tested the auto discovery I believe I was able to create items directly from the paperUI once the thing has been discovered…

Everything works in PaperUI. I just prefer text files. I can document PaperUI version if you want. It is easier than text files.

I have this error message about in every 5 sec in openhab.log.
Everything works fine, I just wanted to give information. Probably it is normal.

do the zones/partitions update normally?

If yes, this means that there is some issue with lifecycle of handlers. A restart of OpenHAB should fix this issue.

If they do not update for some period I would advise you to do the reset of binding using the command LOGOUT/LOGIN.

Socket closed means that the communicator’s socket to the Paradox system is down. I need to look into this and maybe do a remediation, i.e. a reset or something. If there are two bridge handlers active in the system though I can’t do much. Only a reset of the openhab will fix the problem.



Zones, partitons update work, no problem. This message was existing at previous versions as well. I will try suggested fixes and come back with the results.

Hello, Simple OH restart solved the problem. I haven’t seen any error message in the last 1,5 hours.

After another 1 hr error message has restarted.
After certain time of messages, it seems that it restarts itself:

Hm… this stack trace is not from latest binding version. Actually it is from version before the real refactoring occurred. I just checked into the code we don’t have anywhere anymore Thread.sleep() because this was one of the major issues I had to solve.
Are you sure that you use the latest .jar, i.e. org.openhab.binding.paradoxalarm-2.5.0-SNAPSHOT.jar and not the org.openhab.binding.paradoxalarm-2.5.0-OLD.jar?

I’m afraid that these logs appear to be for much older release…

Also in the latest release I figured recently that from time to time the communication gets lost and only a manual logout/login fixes the issue. Unfortunately there is nothing related in the logs which means I need to improve the logging and see what the issue is. I also need to implement a reconnect functionality like in the old binding but not sure when…

I use this one:

I thought that I use the good one, but I think I have used an older version. I have downloaded again, and I will check how it behaves today and tomorrow.

Yep. The new one is 100K+, this is the old one, now moved to -OLD.

No, the new one does not work. See openhab.log file. paradox_new.log (21.7 KB)

With the new version I do not see anything in Inbox manual discovery:

Than I put back _old version and communicator can’t start:

OK. That seems very annoying. Looks like the Panel object has not been created yet when the scheduled read starts which is very strange.
I see that you have made the logging in separate file already, right?
If so, can you raise the logging of Paradox to DEBUG (this has no problem in sniffing packets and reading passwods. The risk is TRACE level.)
Also please restart OpenHAB with new binding installed and send me the full logs from the very beginning. I need to see what happens when in order to fix this.

P.S. My best guess is some racing occurs here due to the asynchronous creation and reading… Interesting that I don’t have it here on my machine… :frowning:

ok, I will use the latest one and save a full log file. Could be that binding was not completely unisntalled? Probably I have to clean temp files first. I tried to find, but I couldn’t.