Philips TV (2016+) Binding

jointspace
philips
binding
Tags: #<Tag:0x00007f1e65b3d4d8> #<Tag:0x00007f1e65b3d320> #<Tag:0x00007f1e65b3d0a0>
(Benjamin) #41

Mhm, strange. Any logstatements which indicate what went wrong? You can retrigger the pairing process if you remove the PIN entry from the things settings. Afer success, you can save away the username and password. Next time they vanish (still shouldnt happen at all) you could manually set them at the things configuration.

Cheers

0 Likes

(Mariusz) #42

I have to admit that the username and password vanished after changing volume from number as originally stated to dimmer. After than I cannot retrieger the pairing. I have tried many times. Even removed the binding, restart, reboot the raspberry and install the binding again. How can I retrieger it, than? Please advise.
Thanks.

0 Likes

(Benjamin) #43

Did you also remove the thing itself? Try that and then remove the binding from the addons folder and place it in there again. Your tv should then be placed again into your inbox. Your tv also has a fixed/static ip address, right?

0 Likes

(Mariusz) #44

Thank you for your guides. Working like a charm.

0 Likes

(Benjamin) #45

Great, thanks for your feedback!

Just for the record: which tv model do you own?

0 Likes

(Mariusz) #46

It’s 65PUS8102/12
Thanks

0 Likes

(Jan) #47

Got a 55PUS7101/12
Seems to work all only thing is when I switch the TV off I can’t switch it on again…

0 Likes

(Benjamin) #48

Hey, thanks for your feedback!
Please see the notes in the initial post about turning on the tv, you are required to use Wake-On-Lan first.

Cheers

0 Likes

(Jan) #49

thank you

0 Likes

(Grzegorz W.) #50

Hello,

I’m only confirming that I was able to run this addon with 65PUS8303/12 TV.

I’m wondering about one thing. Do you know why not all channels appear in PaperUI when configuring item when we compare channel number with docs:

0 Likes

(Benjamin) #51

Hey, thanks your feedback! There should be a button “Show more” at the item configuration page. Then you should see all the channels.

1 Like

(Grzegorz W.) #52

ah … right. I don’t know how I missed that.

Thanks

0 Likes

(Svilen) #53

Finally binding for Philips Android TV. I have 55PUS8303 and there was no any problem with the auto discovery and the pairing. Power OFF is working, surprisingly ON also is working (no WON binding or similar installed). Ethernet connected to LAN if it matters.
Ambilight ON/OFF also is working properly.
Hey Benjamin, thanks a lot for your job, the time spent on it and the result.
Didn’t have much time to test other features, just tagged it to Siri and Alexa trough their bindings - all tested works great.
If any issues later on occur will let you know as a feedback.
By the way the TV got its Oreo update few days ago - before the update the model indicated in the Android menu->About was 55PUS8303, after the update is TPM171E - the TPM platform model, but here in OH discovery is Philips 55PUS8303.
Waiting your progress on the binding - if can change the source and the Ambilight mode and they to be tag-able - it would be great.
Once again - thanks for your job!

0 Likes

(Benjamin) #54

Thanks for your kind words! I’m happy to hear that everything worked as expected.
That’s pretty cool that WOL is working out of the box for you - that means, the network card of your tv is not turning off after the tv is turned off.
Also interesting that your tv model description changed after the update, I will check that out on my tv later.
Changing the source is sadly not supported anymore by the jointspace API… I have no clue why. That’s why I am using CEC for turning on/off and changing the source, its pretty reliable.
Btw: I am also using the newest version of the alexa skill from openhab, it’s working like a charm. Tagging all the features like pause etc. made it possible for me, to use alexa even though the official “philips tv alexa skill” is not supported for my tv model.

0 Likes

(Svilen) #55

Small update and feedback - next day there was configuration error with the TV - couldn’t retrieve the credential, deleted and paired again and already 2-3 days no any problems. For source changing I put some hopes on Harmony Elite (now purchasing). Regarding Philips Smart TV Voice Control skill - I think it’s still not made available - from Philips has said once all planned model got their Oreo roll out they will make it available.

0 Likes

(Daniel Linder) #56

I have the 8503, which is basically the same model - but with the “soundbar”. In my case the “ON command” is working for a time period of 20 minutes after power off. Then it goes into some “sleep mode”, and only wakes up by WOL. Have you tried if your TV works different?

0 Likes

(Svilen) #57

Yes, 8503 is the same except the soundbar. What do you mean by works different? If I turn it off in the evening using Alexa -> OpenHab Skills/Cloud Connector -> Philips TV Binding there is no problem to turn it on the same way in 2 minutes or in 6-8 hours in the morning.

0 Likes

(Daniel Linder) #58

OK, then I’ve probably enabled some “energy saving” feature. Or - there are some actual hardware/software differences between our TVs.

0 Likes

(Svilen) #59

I think except the soundbar all other is identical. Maybe LAN affects it other way. But I still get after restart of OH: Status: OFFLINE - CONFIGURATION_ERROR Error occurred during retrieval of credentials.
Needs removing and new discovery with pairing with new code and all is ok, till next OH restart.

0 Likes

(Igor) #60

Tried installing it today, but got some errors.
I put the jar in addons folder and this was in the log.
Do I have to add missing packages manually (via Karaf) or?

2019-03-31 23:07:19.161 [WARN ] [org.apache.felix.fileinstall ] - Error while starting bundle: file:/usr/share/openhab2/addons/org.openhab.binding.philipstv-2.5.0-SNAPSHOT.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.philipstv [235]
Unresolved requirement: Import-Package: org.eclipse.jdt.annotation; resolution:=“optional”
Unresolved requirement: Import-Package: org.eclipse.smarthome.config.discovery.upnp

at org.eclipse.osgi.container.Module.start(Module.java:444) ~[?:?]
at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:383) ~[?:?]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1260) [10:org.apache.felix.fileinstall:3.6.4]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1233) [10:org.apache.felix.fileinstall:3.6.4]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.startAllBundles(DirectoryWatcher.java:1221) [10:org.apache.felix.fileinstall:3.6.4]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:515) [10:org.apache.felix.fileinstall:3.6.4]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:365) [10:org.apache.felix.fileinstall:3.6.4]
at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:316) [10:org.apache.felix.fileinstall:3.6.4]
0 Likes