Pi3/habmin/razberry: no nodes (solved)

Tags: #<Tag:0x00007efec3be5d98> #<Tag:0x00007efec3be5b68> #<Tag:0x00007efec3be5a50>

Hallo,

let me please point to the reply I posted 8 days ago when I tried to get help with my habmin/razberry problem.

https://community.openhab.org/t/openhab-dont-recognize-razberry-board-dont-see-node-in-habmin/5311/35

If further informations (log-files) are required, please let me know.

I saw that post a couple of days ago, but it looks like you did nothing wrong.
In the meantime I did several new installs and never encountered that error again.
If nobody else answers to your problem, I would do a complete new install before wasting too much time.

Good luck.

Thank you.

I already did a complete new install the way I described in the other post.

To me it feels like the problem depends on the raZberry-board being connected to Raspberry Pi3 by port = /dev/ttyS0.
But because z-way is able to include and exclude devices, I think /dev/ttyS0 should be ok and also the raZberry hardware should be ok.

I’m confused.

Should I try openhab2?

Why not. Put it on a separate sd card and then you are always able to switch back with just a card change.
To do a quick install you could use

Ok, I’ll try oh2. Thank you.

Hallo Anfänger :wink:

This might be important to you:

@ThomDietrich
your openhabhian-hassle-free-rpi-image exactly fits my needs because I’m a newbie to almost everything. (raspberry pi3, linux, openhab and zwave)
Reading your guide, you immediately got me with „A home automation enthusiast shouldn’t need to be a Linux enthusiast!“ By the way, I appreciate what you are doing. Thank you very much.

Today I started trying to follow your guide step by step.

  1. I downloaded „openhabian-ua-netinst-20160915-git9e034e7.img“ from https://github.com/ThomDietrich/openhabian/releases

  2. Wrote the image-file to the sd-card using Win32DiskImager (Windows10)

  3. Connected Ethernet, SD card and power to my Raspberry Pi3.

  4. Additionally connected my tv by hdmi-interface. So I’m able to watch the installation-protocoll.

  5. Waited until installation was finished and the login screen appeared on the tv-screen.

  6. Waited additionally one hour. (Worked in the garden :wink:)

  7. Logged in on rpi3 from my windows-pc using putty, with user pi and password raspberry.

  8. OpenHABian welcome-screen is displayed. But unfortunatly following message appears:
    As I suppose, there shouldn’t appear such a message.

    awk: cannot open /usr/share/openhab2/runtime/karaf/etc/branding.properties (No such file or directory)

  1. Tried to connect to the openHAB 2 portal http://openhabianpi:8080 without success.
    Am I right? The openHAB 2 portal should be available without additional installation.

  1. Rebooted the system with sudo shutdown -r now, but got the same message again.

  2. Repeated step 1 (image-file downloaded image-file again) to step 11, but got the same message again.

  3. Made a full upgrade with sudo apt-get update and sudo apt-get upgrade
    and again rebooted the system with sudo shutdown -r now. But still the message appears as shown.

Did I made something wrong?

No, not at all, it’s just broken at the moment:

Okay, thank you.

:frowning: What a shame! You did everything right and still no success. How disappointing, right!? Don’t worry, this doesn’t happen normally and will be resolved soon
As you can read in the other message, there is a problem right now. You have two options: Wait for 1-2 days till the next working release is available and start anew OR you follow this fix we hacked together here. Whatever you do, pay close attention to both threads to know when the problem got solved and what you might pay attention to:

Thanks for the nice writeup btw…! :wink:

„A home automation enthusiast shouldn’t need to be a Linux enthusiast!“ -> I didn’t even know I wrote that. Thanks I’ll put it in the first posting :smiley:

Hallo everybody,

I did a complete new installation this week, and it works!
At least, I solved my basic problem “openhab didn’t recognize the raZberry-board” by changing from openhab1 to openhab2.

If there’s someone out there with Raspberry Pi3 and RaZberry, also
struggeling with z-wave-installation like I did. The following may be useful.

Here’s what I did, step by step:

  1. I downloaded „openhabian-ua-netinst-20160915-git9e034e7.img“ from https://github.com/ThomDietrich/openhabian/releases

  2. Wrote the image-file to the sd-card using Win32DiskImager (on Windows10)

  3. Connected Ethernet, SD card and power to my Raspberry Pi3.

  4. Additionally connected the Raspberry Pi3 to my tv by hdmi-cable. So I was able to watch the installation-protocoll on the tv-screen. (Not necessary, but helpful to me.)

  5. Waited until installation was finished and the login screen appeared on my tv-screen. (If you don’t have a tv-screen connected, you need to watch the led, like discribed in openHABian hassle-free openHAB Setup )

  6. Just to see, if installation was successful and works, With my browser I connect to the openHAB Dashboard with http://192.168.1.106:8080/start/index and to the openHAB Classic UI with http://openhabianpi:8080. They worked.

  7. Logged in on rpi3 from my windows-pc using puTTY, with user pi and password raspberry.

  8. Made a full upgrade with sudo apt-get update and sudo apt-get upgrade

  9. Additionally I did sudo apt-get dist-upgrade and sudo apt-get clean (Somewhere I read that this could be done.)

  10. Started the openhabian configuration tool with sudo openhabian-config

  11. I executed the following options:

    01 Update

    02 Basic Setup

    03 Java 8

    04 openHAB 2

    20 Serial Port (This is important! And you have to do a reboot after this.)

  12. I connect to the openHAB Dashboard again with http://192.168.1.106:8080/start/index

  13. In the Dashboard-screen I choosed Extensions wich shows a list of all bindings available.

  14. Scrolled down to z-wave-binding and installed it

  15. Selected menu INBOX which showed no entries.

  16. Pushed the ADD-Button

  17. A new screen appeared. I selected the entry z-wave-binding

  18. A new screen appeared. I selected z-wave-serial controller

  19. A configuration-screen appeared with empty fields . After a few seconds some fields were updated automatically with parameters.

  20. Into the empty field named serial port I wrote /dev/ttyS0 and then saved this change.

  21. The menu CONFIGURATION > THINGS appeared with a new thing „Z-Wave Serial Controller“ marked green.

  22. The INBOX showed two new things. (My two nodes, which I have included using z-way, before I did this installation.)

  23. Choosed INBOX and pushed the buttons of each node. For each node a menu appeared and I pushed Add Thing

  24. Choosed CONTROL. Now my Z-Wave Serial Controller (raZberry) and my two nodes appeared.
    But the nodes (sensor and switch) didn’t show data. After a reboot they did.

Ok, hope I didn’t forget something.
That’s it. Now I’m ready to use.
Next step on my list: Install and learn, how to use HABmin.

@ThomDietrich @sihui Thanks.

3 Likes