Pioneer fur VSX831 not working


I‘m a beginner testing openhab2. Love the interface and easy configuration, but there is one device, which seems to not work: i can‘t get the Pioneer VSX831 woth the pioneer binding running. It‘s shows unsupported and is not reacting on any action. Any ideas or workarounds?

First, ensure communication to the VSX to work (try a telnet from your OH box to the AVR on the port you configured in the UI to be used). If that doesn’t work, it’s unrelated to the binding.
If it does, check out this. Works with my VSX-931.
As this code is not yet included in the standard distributions, you have to remove your pioneeravr binding in PaperUI and drop that file into /usr/share/openhab2/addons and eventually issue a bundle:start command on the Karaf console (the CLI to listen on port 8101).
(I guess this is confusing for a beginner - sorry -, but take the time to understand it. Have a couple of searches on this forum on other bindings like the ZWave dev binding thread to be installed the same way, too).

Fantastic. Thanks so much for this. I’ll have a closer look and try. It worked with FHEM, so I’m assuming it’s not on the AVR end. I’ll let you know if I can make it work.Thanks again, Markus

I couldn’t get this one work. BUT, I tried the ONKYO binding and this seems to work well for PIONEER VSX831. Good to know :slight_smile:

What? How did you get that to work then?

i just installed the binding. It identified my PIONEER VSX-831 as a new thing (Unsupported Onkyo AV Receiver) and worked perfectly.

Oh sounds amazing! I’ll try that too, lets see what it brings!

Hi there, i have followed your advice and onkyo binding works like a charm, except for volume control… i have seen that the volume is a half of the real one (100% on binding is ~50% on the receiver).
Did you have the same issue and, if yes, how did you solve it?

Thanks a lot!