PioneerAVR Onkyo binding volume issues

I have an issue with my Pioneer VSX-1131 (identical to VSX-531 and VSX-831). The binding with PioneerAVR doesn’t work but Onkyo binding works well. The thing is created as “Unsupported Onkyo AV Receiver” with the following channels:


“power/input/mute” work well but “volume” doesn’t fit to the Pioneer volume dB ranges:

The Pioneer VSX-1131 has a volume range from -82 dB to 0 dB.
I created a dimmer item and put it as slider item into sitemap. But slide range 0% to 100% doesn’t match to volume range -82 dB to 0 dB. 0% is 0 dB but 100% is only -32 dB!

Any idea??

Thanks and regards

Change the item type to Number
and change the slider in the sitemap to a setpoint:

Setpoint item=<itemname> [label="<labelname>"] [icon="<iconname>"] minValue=<min value> maxValue=<max value> step=<step value>

Ugly but should work well enough for you to find the “real” values needed for the volume
We can then use a js transform later to deal with that

Hi Vincent,
thanks for your answer. Okay I changed it that way, and now the Setpoint has my needed range from -82 to 0.
But now there is no volume change on my VSX-1131 AVR.

For this is now a js transform necessary, right? I think I need possibility to set volume on the AVR but also to read the current volume value from the AVR to update my item e.g. if volume is changed manually on the AVR.

Could you please give me a hint for this?

Can you post your Number item definition so that I can add the transformation

I’m not sure if I’m on the right way :frowning:

as described first I added thing for “Onkyo binding” and found my AVR automatically. Here the settings:

And here the linked items:

So first that looks fine in the PaperUI but in PaperUI Control the items don’t work (e.g. power or mute)

So I think before we go forward on the volume issue first the “standard control” of the AVR should work!?

Regarding volume issue:
my understanding is that the linked volume item to the thing “HebsAV” must be a Dimmer…so I linked my item Device_HebsAV_Volume. But I also created a number item VolumeAV1 and in sitemap this SetPoint:

So this SetPoint works well but now we have to update Device_HebsAV_Volume from SetPoint VolumeAV1 with a transformation - right?

Change your VolumeAV1 set point to 0 to 100 step 1
We just need a rule:

rule "Sitemap volume change"
    Item VolumeAV1 changed
    var volumeIn = VolumeAV1.state as Number
    var volumeOut = ((volumeIn * 82 / 100) - 82)

Hi Vincent,
wonderful…that was the significant hint - thank you very much!!!

Now I first have to find solution for my (new) main issue that my Onkyo binding to my VSX 1131 doesn’t work anymore. Maybe I’m wrong but I thought the day before yesterday it worked (for power/mute/input) but then I did current firmware update from 2089-3040-7070-0008 to 2099-4040-7080-0008…maybe that’s the cause :frowning:
I also tried sending eISCP commands direct from my openHABian…also didn’t work :frowning:

Did you update the firmware on your AVR? Is that what you mean?
Maybe try unistalling the binding and reboot OH and re-install the binding and rediscover the things

Yes correct…I did firmware update on my AVR.
Okay let me try do this…

It didn’t work :frowning: After re-installing Onkyo binding automatic search for things doesn’t find my AVR. And manual thing creation works but items (power/mute) still don’t work. It makes me crazy :angry:

You will think I’m crazy…I just retried it…today binding with PaperUI Control and also eISCP commands from openHABian work well :slight_smile: I’m sure I did it same way yesterday! Seems to be an easter egg in the software :joy:

Hi everyone,

I know this thread is kind of old - at the same time I’m facing the exact same issue and have not gotten anything to work over the last 2 hours. From my findings it is not possible to use a “Number” item for the volume since the channel is always automatically set as “Dimmer”.

Overall did I only find one way to control the volume on my receiver over the complete range: Sending a raw command without feedback. In consequence I can only go up and down 1dB each and do not see the current setting.

Has anyone else gotten this to work? If yes, how?