Plugwise Home Automation binding for OpenHAB

@QNimbus: Do you know if your plugin also works with the Plugwise stretch? That would be genius!
I looked into it, and looks like both are working with an xml http API, so i am gonna give it a try. I have about 10 circles including one for my sun-panels. I’ll keep you posted.

Hmm… here i am already… Looks not good… installed the Jar and also the xstream jar.
Saw the plugwise Binding, added and configured the thing. unfortunately error:

Status: OFFLINE - CONFIGURATION_ERROR Unknown HTTP status code 500 returned by the controller

The login works as it should, with a bogus login i get a login failure. So thats good. :slight_smile: But it seems the API is different anyway. pity…
I had it working in my own php-written domotica solution, but i am abandoning this in favor of openHAB. I hope i can manage to get this working…

I happen to know since I created the binding - but unfortunately the Stretch is not (yet) supported. I do not own this device and as such I’m unable to inspect the API it uses and incorporate it into the binding.

The Stretch and circles are also slightly ouside of the scope of the PlugwiseHA binding since it aims to manage boiler and thermostat related devices and if I understand correctly the Stretch is a different product aiming to provide insight in power usage. Having said that, if someone would lend or buy me a Stretch I would be willing to write a working binding for it.

Isn’t the ‘Stretch’ supported by the Plugwise binding in OpenHAB (not my binding, but the one that manages the ZWave network by Plugwise?

I’m assuming you are referring to the binding not working with the ‘Stretch’?

Note: If you use OpenHAB-2.5.0M3 or newer the XStream library is once again included in the build and you should not have to install the XStream library separately.

The OpenHab Plugwise binding is working directly with the ‘stick’. Actually there is a stick inside the Stretch (I opened the stretch a long time ago), but i’m not sure that stick will work; and the disadvantage of this is that i cannot manage the circle’s normally anymore. I prefer talking to the stretch. :slight_smile:

Well, i have one stretch 2 with 10 circles, and i can say i am experienced talking to the API with autoIT and php (curl). I can read the current states, used/produced power and toggle the circle’s on/off. (Just read that the stretch 3 should work to same way too.)
Maybe i can help you with the correct urls, xml data and testing?

Should this binding also work with the Anna thermostat and the Smile T? This box is currently available in the Netherlands for 99EUR. The Smile T has the network connection and sits between the boiler and the termostaat

I have installed the binding and the plugwise home automation gateway is online but I cannot see the Anna. Looks like the deviceid cannot be found?

I can confirm this works.

steps I did on Milestone 4:

  • Install the latest version of this binding.
  • Configure the Plugwise Home Automation Gateway (Same config as Adam)
  • Add thing manually “Plugwise room thermostate”
  • Enable trace log on this binding via Karaf
  • look for section Anna and copy appliance ID to the new added thing.

use the items and things described in the readme file mentioned in the start of this topic.

@ QNimbus Thanks for the great work!

@TBA thanks for the kinds words!

The Anna is supposed to be recognized automatically as a ‘Room thermostat’ ; that’s also how I’ve included my Anna in my plugwise binding. The only thing that’s not yet working is updating the setpoint on the Anna display when the associated room setpoint is changed by the user. The other way around does work however.

Do I understand you correct that if you are changing the setpoint in Openhab, you don’t see Anna updated?

In my case this works. Regardless if I use the Openhab app on my mobile or Habpanel, I can see the changes on the Anna display. If I use Anna, I see Openhab being updated.

Been using binding version 24-09 for 6 weeks now. And didn’t notice any problems. Thanks, really great. Any plans to submit it to master?


i’m trying to install the addon on a fresh install with all latest versions.

first threw me the com…xstream error, fixed that by dropping the jar as suggested
but now i get:

Unresolved requirement: Import-Package:

it’s a part of java as far as i can understand?

ok, like someone else in this topic after removing zwave binding and addons, restart, add them back, it worked… weird…

For anna, is there a thing/item for the schedule / modes?

@lsiepel Thanks for your kind words - I have created a PR to the OpenHAB addons repo, but I’m not sure that these things get picked up in a timely fashion.

The ‘Anna’ can be added as a regular thermostat (and it’s corresponding location).

With regards to the errors you had previously. the ‘xstream’ dependency was solved in (I think) OH 2.5.0 but can also be manually added as you have already seen. The second error is not something I’m familiar with - also I would not know why removing the ZWave binding would help. Maybe it was just the ‘restart’ of OpenHAB you did that solved your issue?

I don’t seem to be able to find the pr. Can you point me which pr you are refer too?

That is strange… I could’ve sworn that I created a PR some weeks ago. I cannot find it either - I will try to create PR later today. Apologies for the confusion… Thanks for pointing it out!

1 Like

Sorry for being a complete noob on OpenHAB…

I’ve installed it on my QNAP NAS and wanted to add my HUE system (succeeded in adding the Binding and all the Things I want :slight_smile: )
Then I tried to get my Plugwise stuff integrated (Adam HA, 4 x Tom, 2 x Plug, 2 x Lisa). But I could only find the Plugwise Binding in the list, which I believe is not the one that you have made. Because it only refers to the older Plugwise devices.
At least, I can’t discover anything in my network using this binding.

Do I somehow need to manually install your Binding?
Again, sorry to be a complete OpenHAB noob here!
I can’t find any option to do this (using the Paper UI)…

Can’t find it yet, could it be forgotten? Too bad it is too late for 2.5 release, but would be great if it get’s in a next milestone.

Searching for a thermostat working with openhab and reading this topic also bought an Anna with smileT. Only cannot get the gateway properly online. As host filled in the ip address and the proper smileID. But it gives back an error, bad request.
Do I need to change some more settings?
thnx in advance!

Do get the following error in the log:

2019-12-26 15:48:07.885 [DEBUG] [rnal.handler.PlugwiseHABridgeHandler] - Initializing the Plugwise Home Automation bridge handler with config = PlugwiseHABridgeThingConfig{host =, port = 80, username = smile, smileId = *****, refresh = 5}
2019-12-26 15:48:08.017 [TRACE] [pi.model.PlugwiseHAControllerRequest] - >> GET;@locale=en-US
2019-12-26 15:48:08.072 [ERROR] [rnal.handler.PlugwiseHABridgeHandler] - Unknown error while configuring the Plugwise Home Automation Controller
org.openhab.binding.plugwiseha.internal.api.exception.PlugwiseHABadRequestException: Bad request
at org.openhab.binding.plugwiseha.internal.api.model.PlugwiseHAControllerRequest.getContent( ~[bundleFile:?]
at org.openhab.binding.plugwiseha.internal.api.model.PlugwiseHAControllerRequest.execute( ~[bundleFile:?]
at org.openhab.binding.plugwiseha.internal.api.model.PlugwiseHAController.executeRequest( ~[bundleFile:?]
at org.openhab.binding.plugwiseha.internal.api.model.PlugwiseHAController.getDomainObjects( ~[bundleFile:?]
at org.openhab.binding.plugwiseha.internal.api.model.PlugwiseHAController.getUpdatedDomainObjects( ~[bundleFile:?]
at org.openhab.binding.plugwiseha.internal.api.model.PlugwiseHAController.refresh( ~[bundleFile:?]
at org.openhab.binding.plugwiseha.internal.api.model.PlugwiseHAController.start( ~[bundleFile:?]
at org.openhab.binding.plugwiseha.internal.handler.PlugwiseHABridgeHandler.initialize( [bundleFile:?]
at org.eclipse.smarthome.core.thing.binding.BaseThingHandler.thingUpdated(BaseThingHandler.jaa:166) [bundleFile:?]
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_222]
at sun.reflect.NativeMethodAccessorImpl.invoke( ~[?:1.8.0_222]
at sun.reflect.DelegatingMethodAccessorImpl.invoke( ~[?:1.8.0_222]
at java.lang.reflect.Method.invoke( ~[?:1.8.0_222]
at org.eclipse.smarthome.core.internal.common.AbstractInvocationHandler.invokeDirect( [bundleFile:?]
at [bundleFile:?]
at [?:1.8.0_222]
at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:1.8.0_222]
at java.util.concurrent.ThreadPoolExecutor$ [?:1.8.0_222]
at [?:1.8.0_222]

Once in a while i see this WARN message (using 2.5.0 stable):

2019-12-28 18:45:14.202 [WARN ] [rnal.handler.PlugwiseHABridgeHandler] - Unhandled exception while refreshing the Plugwise Home Automation Controller plugwiseha:gateway:home - null

Maybe it should be handled in some way that it 1. tells me what is wrong or 2. give a possible solution or 3. set it to debug if it is not affecting the usage of the binding at all.