POPP Smoke Detector (4001)

Dear all,

I’m going to have 6 Popp Smoke Detectors in a few days and I’m not very shure how to optimal setup should look like. Due to the fact that these are security devices I want to make sure that everything works perfect. Up to now I have the followng items for each of them:

Switch RM1_Alarm "Feueralarm WZ" (gAlarm) {channel="zwave:device:1fe54a1a:node3:switch_binary"}
Number RM1_Battery "WZ Batterie [%s %%]" <battery> (gRauch) {channel="zwave:device:1fe54a1a:node3:battery-level"}
Switch RM1_Smoke "WZ Rauch[%s]" <fire> (gRauch) {channel="zwave:device:1fe54a1a:node3:alarm_general"}

Besides that I have parameter 5 and 6 configured with the default value and Association Group 1 is connected to the Controller. But I just found this in the manual .

Please note that this meshing is not recommended for networks with more than 3 smoke detectors. In this case please control theme using a central controller and turn off the meshing function by setting configuration parameter 5 and 6.

So how is your configuration and why


So i testet it and decided to react if one of the Smoke Detectors detects some smoke to switch the others on via group switch. Seems to work good, the only disadvantage is that this will not work if the controller is down.

Hi Chr1s,

I have just set up a similar configuration with 6 Popp’s.
Yesterday I wanted to try out the behavior of the system with a low battery in one sensor. So I replaced it with an old one which had about 7.5V. This ened up in a desaster :slight_smile: Plugging in this battery somehow triggerd an alarm which was send to all Popp’s. I was not able to stop that, except by pulling out all Batteries!

Can you maybe post your setup of the Items, sitemap and rules?
I would like to have one Alarm-Off button to stop such a false-alarm :slight_smile:

Thanks, Holger

Dear Holger,

I only use the notification on all sensors for the fire alarm but it will work the same for battery as well if you want to use this.

I work with group switches.
The group gRauch is assigned to the alarm_general channels and gFeuerAlarm to all switch_binary channels.


Group:Switch:OR(ON,OFF) gRauch  "Feueralarm global[%d]"		(gAlarm)			
Group:Switch:OR(ON,OFF) gFeuerAlarm  "Feueralarm global[%d]"		(gAlarm)	
Switch 	RM1_Alarm 	"Feueralarm Wohnzimmer"	(gFeuerAlarm)	{channel="...:switch_binary"}
Switch 	RM1_Smoke   "Wohnzimmer Rauch[%s]"  (gRauch, gSensorWZ)	{channel="...alarm_general"}


rule "Feueralarm_an"
		Item gRauch changed to ON
		logWarn("Feueralamr","Feueralamr an")
		sendBroadcastNotification("Achtung Feueralarm!")
		sendCommand(gFeuerAlarm, ON)

rule "Feueralarm_aus"
		Item gRauch changed from ON to OFF
		logWarn("Feueralamr","Feueralamr aus")
		sendBroadcastNotification("Feueralarm bendet")
		sendCommand(gFeuerAlarm, OFF)

Besides that I added the group switch to my sitemap if i want to deactivate the alarm manually. This seems to work because my wife accidently test it by adding some smoke to the kitchen air :slight_smile:


@chr1s, I just have seen your items for the Popp smoke detector.

Isn’t the channel “alarm_general” the tamper alarm channel? I wonder if smoke detection is recognized by Z-Wave this way correctly. I have “sensor_binary” channel as smoke trigger and the smoke detector sends direct Z-Wave events to other detectors or alarm groups in case of smoke alarm. So no issue if the gateway fails…

Switch 	RM1_Alarm 	"Feueralarm Wohnzimmer"	(gFeuerAlarm)	{channel="...:switch_binary"}

The “switch_binary” channel is the channel to activate and deactivate the siren (e.g. for an alarm system). Independent of any fire alarm (on / off possible).

Curious to see that the above setup works properly - just my thoughts about the item definitions :wink:

@HolgerL, sounds like you activated the tamper alarm by removing the detector and changing the battery?

My item definitions look like this (no tamper alarm item defined):

Switch Rauchmelder_Wohnen       "Sensoralarm Rauch Wohnzimmer [%s]"   (EG_Wohnzimmer, gRauchmelder)     { channel="zwave:...:sensor_binary" }
Switch Sirene_Wohnen            "Schalter Sirene Wohnzimmer"  (EG_Wohnzimmer)     { channel="zwave:...:switch_binary" }
Number Batterie_Rauchmelder_Wohnen   "Rauchmelder Wohnzimmer Batterie: [%s %%]"  (EG_Wohnzimmer, gBatterie)  { channel="zwave:...:battery-level" }


Dear Bernd,

so the only difference between our configuration is that you use sensor_binary instead of my alarm_general. So it seems both will work.

have “sensor_binary” channel as smoke trigger and the smoke detector sends direct Z-Wave events to other detectors or >alarm groups in case of smoke alarm. So no issue if the gateway fails…

How did you do that. If I want to associate the other sensors I can only add 4 other sonsors because this would be my preferred solution as well. Besides that, which association group did u use? I guess you deactivated the automatic association as well?


I have 5 Popps, I had exactly the same problem. I changed Parameter 3 to 99 (from -1 =255) and Parameter 5 and Parameter 6 to “inactive”. Then I put them into “Assoziation Groups” 2 and 3. But it’s recommended only to put 4 further more sensors into one group!

@chr1s, I’m currently running 3 detectors - so it seems I do not have reached the limits of >4 nodes per group…

Hi, what does this do? The description of the POPP only says that you can set it from 0-99, but what is the effect?

It’s the Value of BASIC Set On-Command.


… and why is this then default =-1 ?

I think that -1=255 but I haven’t understood why 99 instead of -1 (255). @Celaeno1 could you please enlighten me? :slight_smile:

In user manual of Popp and in Z-wave database of Chris Jackson the Default value is 99.

Support of Popp told me that the value depends on the z-wave controller. ?? (I have zwave.me UZB1)

Support also told me -1 should be the correct one.

But the siren get switched to ON with both, 99 and -1.

But when I tested my 5 Popp with -1 and I only switched one to ON, then ALL were beeping after a while. General Alarm and Fire alarm were switched to ON, too.

When I changed to 99, only the Popp that was triggered was changed to ON.

1 Like

Thanks @Celaeno1 for the clarification. So basically it’s an ALL ON or ONE ON if I understand you correctly. Good to know…


I am just wondering what the right “item received command” attribute is, when checking in a rule?

Is it “Alarm” and “Ok” as indicated in the Paper-UI Control? Or is it ON / OFF ?

if item ZAlarm2 received command Alarm {


Quick questions :slight_smile:

Is the POPP smoke detector WITH siren worth it?
Would you recommend the 10 years battery detectors?
Can you change batteries of the devices? I’m not sure how the 10 year fixed battery statement is meant…


The 10 years batteries can’t be changed. But you anyway should not use a smoke detector for more than 10 years, because they collect dirt and may not function correctly anymore! So each somke detector shall be replaced after 10 years, independent which battery they use.


1 Like

I’m unsure if I should get the 10 years version or the 4001 - they are all quite expensive if you need a lot :confused:
Any experience with battery duration on the 4001?

In my first test device the batery was empty after 1,5 years with a lot of testing and using it as siren. The very good thing with the detector is that it supports meshing and will forward the signals of other nodes. From my point of view battery life is OK and you will have a very stable network if you have a lot of them in your house.

1 Like

I think I will also get the 4001 - the other version are just too expensive. Even the 4001 is expensive compared to non-zwave ones.