Problem accessing /start/index. Reason: Not Found


I am trying to setup OH2 and while I can make OH 2.0.0 (official release) work and see PaperUI (although I have some other problems), there is no way I can do the same with the OH 2.1.0 snapshot (I am trying build #909, and I also tried build #906 with the same result).

When I launch OH 2.1 snapshot and try to connect to PaperUI I get this message:

"Problem accessing /start/index. Reason: Not Found "

and there is no way to connect to PaperUI.

I have seen some posts where other people complained about experiencing this problem with a RaspPI. However I am using Windows 7.

I have tried almost everything: wait for several minutes, launch as admin, disable firewall, disable antivirus, change the port in setenv.bat…


Is this a bug?
Why does the official version work and the snapshot does not? I don’t understand…
What am I missing?

Please help.

Try to connect to your Karaf console to check if the PaperUI is installed.

ssh -p 8101 openhab@localhost

Karaf Console

bundle:list | grep ui


Indeed, PaperUI was not installed!!

bundle:list | grep UI
(UI in capital letters) returns:

137 | Installed | 80 | | Eclipse SmartHome UI
138 | Installed | 80 | | Eclipse SmartHome UI
171 | Installed | 80 | | openHAB Dashboard UI

This raises two more questions:

  1. Why is PaperUI not installed?? I just launched the start.bat. It should be installed, right?

  2. What can I do to install it? Can it be done through the console with the “bundle:install:” command.
    In case the answer is yes, what is the argument that the install command needs?

Did you connect to your openHAB ip after you run the “start.bat” ?

It should show you something like this

Also did you check the Documentation ?

I tried. However, this “Welcome to OpenHAB” webpage does not appear at all.
I get the "Problem accessing /start/index. Reason: Not Found " message when I try to connect to

It does appear when I use OH 2.0.0 (official release), though, using the very same computer (a PC with Windows 7) the very same web-browser, etc. Isn’t it crazy??

I have re-installed Java. It’s the 64bit version of Java.
I have checked almost everything.
I have tried also build #910.
I have tried to change the port from 8080 to some other values, and then I get the failure message when I used the changed port instead of 8080, so in some way, the port-changing feature works, but the result is the same.

I have even tried to install OH 2.1.0 in another computer with a Windows 10, and it works fine there, but I need to install OH2 in the PC with Windows 7.

In fact, PaperUI is not the only component missing. I only have 171 bundles when there should be some more. I don’t understand what is is wrong but I cannot make this work…

Try setting the following in your C:\openHAB2\conf\services\addons.cfg

package = expert
ui = basic,paper,habpanel,habmin

It should help…

Thanks for the suggestion, but it does not seem to make any difference.
I still get the same message, and I have even deleted the whole OH folder and re-install it again.

Check (just in case) folder permissions and set also the JAVA_HOME system variable (see:

That was the problem!!!
Many thanks!!!

I had a previous Java installation (for OpenHAB 1.x I think) and my JAVA_HOME was set to:
C:\Program Files\Java\jdk1.7.0_09

I’ve changed it to:
C:\Program Files\Java\jre1.8.0_131

and now it works.

I honestly didn’t think that was the problem because “java -version” returned 1.8.0_131, and OH 2.0.0 official release worked with the previous value of JAVA_HOME.

Can someone explain the mistery??

1 Like

I was probably to quick in saying it was solved…

Paper UI is there but I only see a webpage with this text over an orange strip:

{{title}} > {{subtitle}}

Something is terribly wrong with this installation…
What I don’t understand is why OH 2.0.0 works.

Are you OH2 Snapshot #911?
If yes, see: PaperUI Empty after upgrade to Snapshot #911

It will be fixed soon :slight_smile:

No I am with #910.

In any case, I have removed all Java installations, re-install the latest 64 bit JRE, re-install OH 2.1.0 #910 and now it works (apparently) well.

Thanks anyway.

1 Like