Problem with configuration and control of Logic Group ZDB 5100 Matrix Zwave device

I’m hoping someone can help me with a few issues that I’m having with the particular zwave device configurations. But I am a Zwave newbie, so I’m most likely missing something basic…

First things first.
I’m running openHABian on a RPi4 with OH 3.1 - its a fresh install, and I have Zwave binding and controller up and running fine with a couple of other devices - I have seemingly no other issues with with any other devices, controllers or anything else.


The problems I have are that some commands being sent from OH to the device do not seem to reach it.
A) I’m unable to control the color of the push buttons of the physical device when I create a color item linked to the “Color, pushbuttonX” channels - it is the case for all the color channels. When the item is created the value reads NULL - after 24+ hours it is still not updated. The usual sliders never appear, and look like this.

I have tried setting parameter 10 (advanced LED control) to 1 - also tried setting it back to 0, and then 1 again.
I can make the sliders appear by linking the item to another channel of another device, but when changing the color levels afterwards I get the following error:

2021-08-03 22:16:12.769 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 4: Command received zwave:device:dbf3a74e52:node4:color_color4 --> 0,85,100 [HSBType]
2021-08-03 22:16:12.770 [ERROR] [nal.common.AbstractInvocationHandler] - An error occurred while calling method 'ThingHandler.handleCommand()' on 'org.openhab.binding.zwave.handler.ZWaveThingHandler@19373f6': null
java.lang.NullPointerException: null
	at org.openhab.binding.zwave.internal.converter.ZWaveColorConverter.receiveCommand( ~[?:?]
	at org.openhab.binding.zwave.handler.ZWaveThingHandler.handleCommand( ~[?:?]
	at jdk.internal.reflect.GeneratedMethodAccessor72.invoke(Unknown Source) ~[?:?]
	at jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke( ~[?:?]
	at java.lang.reflect.Method.invoke( ~[?:?]
	at org.openhab.core.internal.common.AbstractInvocationHandler.invokeDirect( [bundleFile:?]
	at org.openhab.core.internal.common.InvocationHandlerSync.invoke( [bundleFile:?]
	at com.sun.proxy.$Proxy555.handleCommand(Unknown Source) [?:?]
	at org.openhab.core.thing.internal.profiles.ProfileCallbackImpl.handleCommand( [bundleFile:?]
	at org.openhab.core.thing.internal.profiles.SystemDefaultProfile.onCommandFromItem( [bundleFile:?]
	at jdk.internal.reflect.GeneratedMethodAccessor71.invoke(Unknown Source) ~[?:?]
	at jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke( ~[?:?]
	at java.lang.reflect.Method.invoke( ~[?:?]
	at org.openhab.core.internal.common.AbstractInvocationHandler.invokeDirect( [bundleFile:?]
	at [bundleFile:?]
	at [?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:?]
	at java.util.concurrent.ThreadPoolExecutor$ [?:?]
	at [?:?]

After fiddling around re-including the device, I noticed that all values for linked items are NULL untill that items channel reports a new value. I do not have a way in OH to change the value of the colors, using this parameter, so if there is a way to do it ‘manually’ I could try that - if someone knows how to send a particular value to a specific setting in the Zwave controller on OH3 then please let me know!

B) When I try to change the state of the pushbuttons from OH the log shows the following output:

2021-08-04 19:05:36.440 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 8: Command received zwave:device:dbf3a74e52:node8:switch_binary1 --> ON [OnOffType]
2021-08-04 19:05:36.441 [DEBUG] [converter.ZWaveBinarySwitchConverter] - NODE 8: Command class class COMMAND_CLASS_SWITCH_BINARY for endpoint 1 not found
2021-08-04 19:05:36.441 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 8: No messages returned from converter
2021-08-04 19:05:36.427 [INFO ] [openhab.event.ItemCommandEvent      ] - Item 'ZWaveAfbryderKokken_Statepushbutton1' received command ON
2021-08-04 19:05:36.428 [INFO ] [penhab.event.ItemStatePredictedEvent] - Item 'ZWaveAfbryderKokken_Statepushbutton1' predicted to become ON
2021-08-04 19:05:36.436 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'ZWaveAfbryderKokken_Statepushbutton1' changed from OFF to ON

As the device database states I have changed configuration parameters 19, 27, 35, 43 to value 2, to ensure push button activation should work.
I have tried to reinitialize the device, which had no effect, and I have tried excluding the device, and including it again, also without any difference in behavior. (That is why the node number changed in the logs provided)

Since I am still learning about the hidden secrets on zwave, I’ve come across these association groups - I’ve still not gotten my head around those, but could that be needed for the buttons to work properly, so that the OH command somehow needs to be associated with the individual buttons??

Sending a command on the dimmer channel does work, but I noticed above the log shows that class is written 2 times - could that be an issue, if it is not an issue with association?

Command class class COMMAND_CLASS_SWITCH_BINARY for endpoint 1 not found

I hope someone can point me in the right direction or maybe has some experience with a working version of the device with the zwave binding

Can somebody help with this??

I did the entry in the zwave-db for the zdb5100. I have several of these devices installed, and can confirm that it works from the openhab 3.1 gui.

I know that this info does not help you, but I will try to include a new device to see what happens as soon as possible (most likely in the weekend).

My first feeling about the issues that you are seeing is that something went wrong during the inclusion of the device.

I managed to do at inclusion(not secure) of a brand new device in openhab 3.1.

I did this:

  • Started the scan for new zwave devices
  • Pushed the include button on the device ONCE
  • After a while (20 sec) the device appeared in the inbox
  • Added the device as a new thing
  • Change parameter 10 to 1
  • Change parameter 14 to 4294967040 (this is FFFFFF00)
  • Saved
  • Added link to a new item for “Color, pushbutton 2”
  • Observed that I was NOT able to change the colour for the item “Color, pushbutton 2”
  • Added link to a new item for “State, pushbutton 2”
  • Flipped the On/Off switch of the item “State, pushbutton 2”
  • Observed that the device changed color when flipping the switch
  • Changed the color or item “Color, pushbutton 2”
  • Observed that the color of pushbutton-2 on the device changed


Thanks for taking an interest, and making the entry to the DB - and actually trying this out in 3.1 for me!

I’ve included the device in secure mode, other than that my steps were exactly the same, but without your result - when I change the parameter 14 in OH, and physically press the device button I can see the switch LEDs change to the given color, so the parameter settings do work (a sidenote though is that the value in the OH item is negative when byte 1 is above 127, for example the value you gave, 4294967040, give me a value of -256 in the OH item).
When i use the ON/OFF item switch I can see in the log, when set to debug, I get the following:

2021-08-12 08:20:05.744 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 10: Command received zwave:device:dbf3a74e52:node10:switch_binary1 --> ON [OnOffType]
2021-08-12 08:20:05.749 [DEBUG] [converter.ZWaveBinarySwitchConverter] - NODE 10: Command class class COMMAND_CLASS_SWITCH_BINARY for endpoint 1 not found
2021-08-12 08:20:05.750 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 10: No messages returned from converter

I’m pretty confident that this is not normal, and take note that in the second line it reads “class” twice. Whether this is just a log entry error, or is that maybe the command that is being sent that is wrong, which is why the push buttons do not work?

I will try and include it insecurely, but since I have tried including the device securely 3 times all of them with the same results, I’m a bit hesitant to think that the same thing has gone wrong 3 times during the inclusion process. Do you have any of your ZDB devices added securely?

For most devices, just the lifeline is required for the device to send status reports. However, as a general statement, associations are absolutely what is required to ensure devices report. If not needed though, you should avoid adding associations as that can also cause problems as you’ll get multiple reports. I don’t know this device, but I would just expect the lifeline to be configured.

This log shows you sending a command TO the device - if I understand your issue above (which I might not) the problem is that you are not receiving state commands? If so, then this will not be linked to your issue.

This will have no effect on anything - the log file text is in no way linked to commands that are sent or received.

…and I haven’t. It was merely IF associations were needed for these things to work, but clearly not.

My issue is that the device does not seem to recieve the commands being sent from at least 1 particular channel, COMMAND_CLASS_SWITCH_BINARY, this command is not recieved on all 4 endpoints (4 buttons on the device, that should be controllable through OH pushbutton items).

No, have not tried to include securely.

So I think the solution was to include it insecurely, which I marked as the solution.
After researching a bit more as to why this was the case, I was hoping perhaps one of you could confirm my theory, since I’m just starting to learn the technicalities.
The table shows the supported command classes, where I notice that the “Insecure on secure inclusion” shows only a few are supported which could be why I was unable to send commands to the switch and LED colors - does that sound about right?

This does leave me with 2 follow-up questions I was hoping someone would explain to me:

  1. “Secure on secure inclusion” does that imply inclusion using S2 security and authorization (Which I know the OH controller does not support) or would I be able to do that as well using S0?

  2. What security am I actually omitting when including insecurely? I’ve read about the difference between S0 and S2, but haven’t been able to find anything about what caveats there are with including something insecurely.