Problems include z-wave NAS-WR01ZE wall plug

I try to include a wall plug switch from NEO Coolcam. the device is in Jackson Database, but I get always this error:
Device discovery could not resolve to a thingType! 0258:0200:1027::2.21
I tried factory reset the device, etc.
Openhab 2.4, Z-Wave Binding 2.4
What can i do?

When was the device added to the database (there is a change log at the bottom). OH 2.4 is nearing a year old. You need a version that was compiled after the date that the entry was added to the database.

First added to database on -0001-11-30 00:00:00. Current released version is 15.
Last updated by Super User on 2019-09-26 19:32:19 (2 months ago).
Approved on 2019-09-28 08:50:50, and last exported on 2019-09-28 08:50:51.

Update 2 months ago

His device type and id were added in January this year, so he needs to upgrade to 2.5 snapshot.

At first, thanks for this really fast support. that’s great!

Is upgrading the openhab the only way to get the switch working? The Upgrade to 2.4 was not so easy for me… I had many problems afte upgrading…

You either may update the core or just the zwave binding:

hmmm… ok, I think I’ll try the 2.5 Snapshot at weekend. Maybe the troubleshooting takes a while… and my wife hates cold mornings without tv and light lol
Do I have to delete and re-include the z-wave devices?


You do not have to exclude & re-include the devices but you need to delete the Things (except the controller) from OH and get them rediscovered by the new binding. The thing IDs stay the same so Items and rules are not broken.

That was only the case when moving from OH 2.3 to 2.4. Since that point we do not have to recreate the Things every time we upgrade, until told otherwise I suppose.

I have found I need to do that when moving to a newer binding that adds or changes support for a Z-Wave device. I believe Chris has advised that too.

here i’m again…
after the update to 2.5.1 my neo wallplugs marked to delete in HABmin. Also one Danfoss LC-13 Thermostat. I tried to delete (tested with the LC13) and reinclude the device. Now it’s a unknown device…
Has anybody an idea?

You need to keep waking up the device until it is fully discovered by OH.

This could have been easily solved with deleting and readding the device.
Now do as @Bruce_Osborne suggested.

1 Like

I tried readding. I often done this after updates. The device keeps status unknown:

I think we are mixing things up:

deleting a Thing and readding a Thing is different to excluding a Device and reincluding a Device.
Deleting and readding just adds and removes a Thing if that device is already included to the network.
You can’t delete or readd a Thing if that device is already excluded form the zwave network (because it simply does not exist)

So if you excluded your device from the zwave network you need to wake it up multiple times.

Sorry maybe my fault. I didn’t exclude any device.
I just deleted one for testing, after I have seen that HABmin has a problem with 3 devices ( 2 Neo wallplugs , 1 Danfoss Thermostate).
Sorry for the bad wording.

No problem, happens to all of us :grinning:
So, does everything work now?

On that I would exclude, factory reset the device and then include.
In my experience some of these cheap devices would only include properly after being factory reset.

Before I do the factory reset, one question. Could it have to do with the last approve and Export Date in the jackson db? For danfoss lc-13 it’s the 17.01.2020. Around this Date I updated to oh 2.5.1.