Problems saving widgets

  • Platform information:
    • Hardware: docker on synology DSM 7.0
    • openHAB version: 3.3.0
  • Issue of the topic: problems saving widgets


I tried the Daikin aircon /HVAC widget by copying the code to a new widget.
But when i try to save the code, the content of the code is alternated.
Some lines are deleted or parts of the line is missing.

I tried it with multiple widgets code from the widget marketplace.
Same result.

Do i do something wrong?
Is my “widget” file corrupt?

Rest of my OH 3.3.0 is working fine only widgets give me problems.

Can someone help me.



The best way to install the marketplace widgets is through the settings in your OH.

Go to the settings page and click on the User Interfaces link under Add-ons. There you can select and install the widget you want.

Hi Justin,

Ok , but what if the widget is not in the market place user interface like for instance the Daikin Aircon widget :

see Daikin Aircon / HVAC

You should be able to copy the code and put it in a new widget and save it as is.
Why is the code “changed” as i save it?



Best course of action would be to contact the creator of the widget and ask them to add the proper tags (published) to the post to get the widget to appear in the regular marketplace.

However, you can still get to it because it is in the marketplace category even if it doesn’t have the proper tags. You can go to your settings and click on Community Marketplace under the system settings. There you check the option for “Show unpublished entries” and save the setting. Then you’ll be able to see all the widgets that don’t have the published tag as well (including the Daikin widget).

That said, you are correct that copy-pasting the entry should also work, and I just tested it and it does work just fine for me. This means that it has something to do with the system that you are copy-pasting with. Did you highlight all the code manually or did you click on the copy button in the upper right-hand corner of the code frame?

Hi Justin,

Thanks for your help.

I think i found why after some hours testing and trying!

If i use firefox (lastest version) to save the widget, i have problems.
If i use chrome, no problems …

Crazy, but i do not know why !!!
But as long as the work around works.

Hope that is the solution.