Problems with Shelly BLU Door/Window Sensor

I have some problems with the blu sensors from shelly. The blu thing is going online but there are now updates. The number or the contact still display “NULL”.

Some details about my setup:

  • openhab-4.1.1 (Stable Version)
  • regular openHAB Shelly Binding
  • Shelly Plus 2PM (Firmware: 1.1.0 → up to date) = Bluetooth (Gateway)
  • Shelly BLU Door Window Sensor (Firmware is up to date)

My install routine:

  1. Enable Bluetooth on the Shelly 2PM (Enable Bluetooth, Enable RPC, Enable Bluetooth Gateway)
  2. Connect the BLU Sensor in the Shelly Cloud App with the Shelly 2PM
  3. Installed the latest Firmware with the Shelly Cloud App
  4. Check the sensor function in the Shelly Cloud App (open, close)
  5. Enable “BLU Gateway Support” in the thing configuration (Shelly 2PM)
  6. Check if the script “oh-blu-scanner.js” was installed
  7. Press the button on the BLU Sensor
  8. Check the openHAB Inbox – a new thing was shown
  9. Add the thing with the GUI / At a another configuration, I have tried to configure with the shelly.things file
  10. In both, the new sensor thing is displayed with the state “CONFIG_PENDING”
  11. Click the device button again, the binding gets another event and creates the channels and thing changes status to ONLINE
  12. Create an new item with the GUI / At a another configuration, I have tried to configure with the shelly.items

The following isn’t Working:

  • Every time an event is received sensors#lastUpdate and channels are updated with the reported values

What I have already tried:

  • Configure another Shelly BLU Sensor
  • Configure without the Shelly Cloud App
  • Check the state (open/close) in the Shelly Cloud App
  • Reset the Shelly 2PM to the factory defaults
  • I Can see in the log file the state “shelly:shellybludw:b0c7de061db1:relay#button triggered SHORT_PRESSED” Event

Any ideas? Thanks Sebastian

Hello,

I have a similar problem.
Can you check on the Shelly, which serves as your gateway, whether the script is on play or pause?

For me, I have to press play manually, then the script runs for some time (hours?, I still have to test how long).
As long as the script is running, all status changes are sent to Openhab.
At some point the script is paused and then status is no longer passed on.

I can’t say why the script on the Gateway Shelly pauses.

Olli

Hi, I observe the same problem. Adding additional Shellies as gateways do not helped. Maybe problem is caused by weak bluetooth signal ? At my case it is showing 1 or 2 level.

No, I do not think so.
The status of Shelly Cloud works absolutely without any problems.
So BLU Device to Gateway Shelly to Cloud is error free.
BLU Device to Gateway Shelly to Openhab does not work permanently.

I’m currently testing how long it works, or how long the script on the Gateway Shelly is on play.
Maybe the ECO mode of the Gateway Shellie plays a role?

In my case (https://community.openhab.org/t/shelly-blu-door-window-frozen/153404) the script also stopped working. Strangely enough it did also break the connection with the cloud: in the Shelly app no changes to lux or the window opening/closing were detected. As soon as I manually ran the script again, the changes were reported.

I’ll also monitor how long the script stays active.

Not even 2 hours…

Here only between 1 and 2 hours too.
ECO mode on or off makes no difference.

There may be something in the logs as to why the script stops.

You mean the Shelly logs? Where would those be hidden? :slight_smile:

This thread is a little weird because you guys seem to be operating in a vacuum. I noticed you have tagged the thread with the shelly tag. I’m surprised the developers of the binding haven’t replied. Good on you guys for trying to figure the issue out on your own.
Have any of you posted in the shelly binding thread?
I don’t want to ping them directly but maybe post in that thread and provide a brief description of your issue and a link to this thread

Sorry for my late answer, the script is in this Status. I have tried also a reboot.

No, a weak bluetooth signal is not the problem. In the Shelly cloud app the sensor updates his status very fast. I think the script or the binding are buggy.

I have ping this post at the thread

1 Like