Problems with Zigbee binding since Openhab 2.5.10?

Hello everyone,

since a couple of weeks i have the problem, that all zigbee_neighbors = [] and all zigbee_routes = []. This is the situation for all zigbee devices and the coordinator cc2531.
I have this problem since

  • I upgraded to Openhab 2.5.10
  • I integrated two new Ikea plugs

To solve the problem i restored a openhab backup (done with openhab_cli) and then the zigbee_neighbors were there again, even with openhab 2.5.10. Then i changed properties and added the ikea plugs and the zigbee_neighbors disappeared from device to device.
It is strange that i still can see all items online in PaperUI. The zigbee network is working fine, I can switch the plugs, light, etc.

Then i bought a new CC2531 stick, removed all zigbee things, removed coordinator, uninstalled zigbee binding, installed binding again, flashed stick, added coordinator, added all zigbee devices. Then network is working, zigbee items are online, I can switch the plugs and lights - but there are no zigbee_neighbors.

My feeling is, that the zigbee_neighbors support broke in openhab 2.5.10. zigbee_neighbors property are freezed until you change something. Then they become []. Can someone confirm this?

This is strange for me too, but it is the only conclusion if have.

Some information:

  • The zigbee_neighbors are used in a zigbee network map script that i use to see the link quality and routes in the network. Now the script shows no links, routes, quality, etc.
  • zigbee_neighbors = [] in Rest and Paper UI
  • Openhab is running on a raspberry pi 2
  • I have a cc2513 coordinator, 2 ikea bulbs, 2 osram plugs, 2 ikea plugs
  • I checked the log with debug switched on for zigbee, but found nothing special

I don’t think there have been any changes. Certainly the main zigbee libraries have not changed in 2.5.10, but even if they had, the neighbour table code hasn’t changed for a while.

What do you mean? So the neighbour requests are working fine then?

In PaperUI and in the /rest/things the zigbee_neighbors = []. Is this normal in a zigbee network with 6 items that are online and working? Can this be true?

I am not an expert for the log and the loviewer seems to bee down, but i searched the log for “zigbee” and found no problem there. But maybe i only do not see it.

It depends on your system. For starters, do you have updates enabled? If so, how often?

Unfortunately the cloud server died yesterday so I have to restore this :cry:

So it is requesting the neighbour updates ok or not? It’s really hard to comment - if you say the logs show everything is ok, then I don’t know how to respond.

1 Like

I think upgraded from 2.5.8 to 2.5.10. It was not 2.5.9.

Can you help with the log? Shall i upload it? Shall i search for some text?

Either way, I don’t think the libraries that do the ZigBee requests have changed very much, and I don’t think that the neighbour requests changed.

Sure - I’ll take a look. Hopefully the log viewer will be back up later this afternoon :roll_eyes:

1 Like

What is this? Where do i have to enable updates? Maybe this is my problem.
Is it the “Mesh Update Period”? If so, it is 1 Day. But i also tried 30 Mins.

Exactly - if you set it to 1 day, then it will only try to update the mesh information every day.

Okay, i changed the Update period to 5 mins. This was 47 mins ago. In the log i see:

2020-12-06 13:55:38.893 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - null: Configuration update: Processing zigbee_meshupdateperiod -> 300
2020-12-06 13:55:38.899 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - null: Unhandled configuration parameter zigbee_meshupdateperiod >> 300.

I can see no other effect. zigbee_neighbors and zigbee_routes are still []. zigbee_lastupdate is still “”. Is there a log message, that shows that the mesh update is executed.

Try restarting the binding - it might be that this cannot be changed dynamically. Otherwise please provide the debug log so I can see what is happening.

How can i restart the binding?

Use the console restart command (if I remember correctly) - get the list of bundles with the list command first.

Or just restart OH, but that’s a bit more hassle I guess.

Success :joy: :clap:
I restartet Openhab and after some time the coordinator and the devices have zigbee_neighbors. The coordinator and some devices have zigbee_routes.

I am happy, but i do not know the reason for the problem. I only changed the Mesh Update Period to 5 mins to solve the problem. Before i had a period of 1 Day and the problem was there for more than two weeks. So the Update should have been done in this period also.

Yesterday i reinstalled the binding and all devices. Maybe this solved the problem. And since yesterday there was no period of 1 day for the mesh update.

Thank you very much for your help.

I was happy to early.

When i setup the zigbee network new (Install coordinator and pair every device), the coordinator is immediately online and also all devices are online. The zigbee_neighbors and zigbee_routes are empty.
When the mesh update period is over, then the zigbee_neighbors and zigbee_routes are there.

Unfortunately after a while the zigbee_neighbors and zigbee_routes of the coordinator and all devices disappear. And then also some devices go offline.

There is a relation between mesh update time and time when the zigbee_neighbors disappear.
If the mesh update is every 5 mins, then zigbee_neighbors disappear after about 1h.
If the mesh update is every 30 mins, then zigbee_neighbors disappear after about 6h.
If the mesh update is every 1h, then zigbee_neighbors disappear after about 10h.

Can the reason be the wrong firmware for the CC2531? I use the CC2531ZNP-Pro-Secure_LinkKeyJoin.hex (original TI 1.2.2.a). With the koenkk firmware CC2531ZNP-Prod.hex (CC2531_DEFAULT_20190608) i have the same effect.

But i have not tested the CC2531ZNP-Pro-Secure_Standard.hex. Some years ago i had problems with it and since then i use the CC2531ZNP-Pro-Secure_LinkKeyJoin.hex.

I am facing the same issue you discribed in your post. At the beginning I thought it is somehow an issue with my setup (at that time i was running the CC2531 via a serialproxy), but had never seen the connection with the update to 2.5.10. Before there was no reason to complain, everything worked in the OH were also neighbor information etc. to see

Most of the time my zigbee bulbs are toggled by a remote and controling it via OH was a less used minor function.

Starting playing around with OH3 I picked up the issue to give a try with a fresh OH3 on a Raspi2 with a CC2531 USB Stick as coordinator. And I exactly ending up in the same behavior as you described. Anything is working until the mesh update periode expires. Routes and Neighbour Informations are never “visible” in OH3 and Things become offline after mesh update.

Have you gained any new insights on this topic ?

Meantime i solved my issue, but not with the zigbee binding. I had to change to Zigbee2MQTT. With this the same system is stable. I have the same RPi4, the same Openhab installation, the same devices at the same locations, same Channel, same PANID etc.
At the moment my system is running for some weeks without any issue. I never had this stable situation with the zigbee binding since i change to 2.5.10 or 3.0.0. With the version before this (2.3 to 2.5.6 or 2.5.8) the system was also allways stable with the zigbee binding.
But to be fair i have to say, that some parameters may be different. E.g. in Zigbee2MQTT i cannot find a paramter for mesh update period. So i don’t know when or if this is done automatically. The Zigbee binding is better to handle than Zigbee2MQTT, because of the additional MQTT layer. I still like the zigbee binding very much, but highest priority is the stable network.

I have one hint, that might help to find the reason for the issue. When i change to Zigbee2MQTT i had to reflash the sticks firmware with same firmware. So i think there was something damaged on the stick (parameters, tables, etc.) and this happens when running together with the zigbee binding. With the zigbee binding i reflashed the stick also a couple of time, but withou any success. @chris maybe this information is important for you.

I regularly check the changes in the zigbee binding and my indention is to change back to the zigbee binding when the issue is solved, because i think this should be the standard for zigbee with openhab. But at the moment i have no preassure to do so.

I’m not really sure how you reflash the stick with the binding? It doesn’t support reloading the firmware in the CC2531 devices - only Ember devices.

Thanks for reporting - I’m not sure I can directly help a lot with the 2531 devices as I use the Ember chips, and nearly all commercial customers also use the Ember chipsets. I did support one company a couple of years back who used the 2531, but they then moved to Ember as well. I know the DT use the binding, but again, this is with Ember coordinator.

I used the TI flash programmer software to flash it. I wanted to say that i reflashed the stick serveral times while i used the zigbee binding. So the reason of my issue cannot be one bad/wrong flash procedure.

I totally share your opinion. I think this problem is related to the CC2531. But it especially occurs with the latest zigbee binding. Maybe i also have to change to an ember based device. I already was thinking about this.