Problems with ZWay in OH 2.2 / Openhabian 1.4

Hi all,

I observed some problems with the ZWay Binding after updating to Openhab 2.2.
My system is a RPI3 with a RazBerry Z-Wave daughter board.

After a fresh reboot, everything works fine, but how longer the system is running, the longer it takes until item commands for ZWay things are executed.
Means, it can take minutes (!) after the change of an item state and the reaction of the Z-Wave device.
In the log, I can see that the command is directly prompted but the item state update comes with a delay.

After the system runs for some days and the delay gets longer and longer, I also see this warning in the log:

[WARN ] [nternal.profiles.ProfileCallbackImpl] - Handler for thing 'zway:zwayDevice:192_168_2_2:4' takes more than 30000ms for handling an update

I also recognized, that the CPU load of the RPI gets higher and higher with the time… From around 0,1% uptime to 1,5% after a few days.

I then tried a fresh installation of the newest Openhabian 1.4 and only ZWay and the ZWay OH binding.

First problem was, that the current ZWay version is not compatible with the latest Debian Lite (stretch) version. A workaround was posted here:

After fixing this, everything works fine. But as before, after some time reaction times get longer and longer :frowning:

Anyone experienced similar behavior?
Any idea of the root cause?
I am very frustrated after hours of research without a progress :frowning:

OK, just found the latest posts in

were the delay issue is solved! Thanks to @Wire82 !!!

For the compatibility issue of ZWay with the stretch version of Debian Lite we have to wait for an RazBerry update :confused: