Publishing weather data from openHAB to Weather Underground?

Does anybody know if it is possible to publish the various weather data gathered from my own sensors from openHAB to any online weather service, for example Weather Underground?

I’ve created an openHAB rule which pushes a temperature sensor to Weather Underground. It might help you: https://eryk.io/2017/02/submit-temperature-openhab-weather-underground/

Wow, that’s amazing! Thx a lot.
I’ve set it up this morning but maybe need to wait a little longer to get the correct data.
At the moment it shows wrong data, although my logInfo looks to be correct:

2017-02-12 08:25:00.243 [INFO ] [.eclipse.smarthome.model.script.FILE] - Temperature send to WU PWS: -1.3 °C (29,7 °F)
The 29,7 comes from the variable temp

But when I compare that to the xml file, downloaded from WU, it shows strange values:

<observation_time>Last Updated on February 12, 8:25 AM CET</observation_time><observation_time_rfc822>Sun, 12 Feb 2017 07:25:00 GMT</observation_time_rfc822><weather/><temperature_string>-999.9 F ( C)</temperature_string><temp_f>-999.9</temp_f><temp_c>-573.3</temp_c>

But the setup is only running for 30 minutes now, I’ll wait and see what happens:

Thanks again.

That is strange. I’ve just tried it with a new stationID and it worked as soon as the first data was send to WU. But I don’t use the API to test it. I’ve tried the station dashboard (http://www.wunderground.com/personal-weather-station/dashboard?ID={your_station_id}), how is that working for you?

Unfortunately no data …

Do I need some special prerequisites to use sendHttpGetRequest?

You need the HTTP binding (https://github.com/openhab/openhab1-addons/wiki/Http-Binding), but I guess you should have seen an error in your logs if you did not have that one…

Yes, got that one.

I’m starting to think that the casting for my temperature item needs to be different:
Number Temperature "Temperatur [%.1f °C]" (gInfluxdb) { mqtt="<[mosquitto:/esp8266four/temperature/shadow:state:default]" }
Because my humidity sensor does not work at the moment I tried
var double humval = 83
and it is published to Wunderground instantly.
So I will tinker around a little bit …

Okay, got it working, thx again.

On my setup I had to remove the String:format (it made the numbers appear as 29,7 instead of 29.7) and Wunderground did not accept that.

So my rule looks now like:

var Number tempval = TemperatureShadow.state as DecimalType
var Number temp = tempval*9/5+32;
1 Like

can someone post the rule here, as mentioned website is not working anymore.thanks