QR-Code not shown in homekit config in OH3

I upgraded to OH3. My homekit bridge wasn’t recognized after upgrade so I tried to re-add it via scanning the QR-code in OH config. The problem is, that the config screen does not show the required QR-code - it is just missing.

QR code was introduce recently and is not part of the official release. you would need to install SNAPSHOT version or wait for next release in order to get QR code.

documentation shows always the latest snapshot features

For a newbie… how do I install this latest snapshot version of the Homekit binding with QR Code?

do you know how to access karaf console? (if not, check this The Console | openHAB)

in karaf console you need to execute following commands (assumption a homekit binding is installed):

  1. find ID of installed homekit binding using this command

list | grep -i homekit

  1. remember binding ID, in my case it is 488

  2. execute following command to update to the snapshot. replace with your binding ID

update <ID> https://openhab.jfrog.io/artifactory/libs-snapshot-local/org/openhab/addons/bundles/org.openhab.io.homekit/3.1.0-SNAPSHOT/org.openhab.io.homekit-3.1.0-20210203.032507-42.jar

e.g. in my case

update 488 https://openhab.jfrog.io/artifactory/libs-snapshot-local/org/openhab/addons/bundles/org.openhab.io.homekit/3.1.0-SNAPSHOT/org.openhab.io.homekit-3.1.0-20210203.032507-42.jar

  1. verify that you have newer version with

list | grep -i homekit

if homekit binding is not installed yet, you use instead of “update” an install:

install https://openhab.jfrog.io/artifactory/libs-snapshot-local/org/openhab/addons/bundles/org.openhab.io.homekit/3.1.0-SNAPSHOT/org.openhab.io.homekit-3.1.0-20210203.032507-42.jar

this is how it looks like on my side

Thank you!!

I’ve been unsuccessful with Homekit integration on OH3. I have addons snapshot 3.1.0~S2204-1 and can use the QRCode/pin but Home reports it can’t add openHAB. I have only one item with Homekit metadata. Does anyone have recent success with the integration? Thank you.

what is that item? there is an issue with colour temperature

It is a light switch. I’ve used “Lighting” as the accessory/characteristic.

ok. this should work. can you tell what kind of error you see in home app? how you item is defined? if you have access to openHAB logs or karaf console this could also help to troubleshoot

Thank you for getting back to me. I think I found the issue…

On my test machine I am able to add the accessory but not on my production server. Both have the latest addon snapshot but only the test machine has the latest openhab snapshot (3.1) the production server runs the stable version (3.0).

1 Like

having the same issue, on main OH3 branche. Any plan when this fix will make it into main?

there were several issues in the this thread.
which one you have? do you see QR-Code?

anyone, to my knowledge, the next stable release 3.1 is planned for summer 2021. on the way to that release we will probably have milestone releases every month or so.
note: you dont need to upgrade the openhab but only the homekit binding.

sorry for being unprecise - yes, that missing QR code is my issue as well. can’t yet tell what happens next, as I am blocked by that.

to your not: when will the homekit binding update get released? Or do you suggest to update it manually the way explained above?

just installed your latest - today - build, QR is displayed now. Will keep you posted on my progress.

really hadn’t expected my next update to be that soon, ran into next problem:

I have added some Homekit-metadata to some of my items, but nothing shows up in the Homekit App. Thus, I checked in the OpenHAB console - also there, nothing.

Then I found that while the the console tells me I am of the Homekit Binding, the OH3 UX shows I am still on 3.0.1 (which can’t be true, otherwise I wouldn’t have the QR code)

digging deeper,I found this in my events log. This item is a Fibaro Roller Shutter 3, and I have channels for blinds and lamella control. I added homekit-metadata to the item group (WindowsCovering) and underlying items (WindowsCovering.CurrentPosition and WindowsCovering.CurrentHorizontalTiltAngle), but have no glue where to add the required TARGET_POSITION and POSITION_STATE

adding a Philips Hue light worked without any problems :slight_smile:

add them to the same item as currentPosition.
Rollershutter type can handle currentPosition, currentPosition and position state

you can either add all 3 of them, e.g.
WindowsCovering.CurrentPosition, WindowsCovering.TargetPosition, WindowsCovering.PositionState

or you can just add WindowsCovering as tag to them item and it will get automatically considered for all mandatory attributes

so, you will have “WindowsCovering” at group and item… looks maybe strange, but should work

ah, that was not immediately clear to me, maybe something to add to the documentation.

As explained, I have two items per roller shutter, one for the blinds control channel, another one for the lamella control channel. Both are part of a group for that roller shutter.

Initially, I had WindowsCovering as metadata on the group, I have now deleted that.

I added WindowsCovering, WindowsCovering.CurrentPosition, WindowsCovering.TargetPosition, WindowsCovering.PositionState and WindowsCovering.HoldPosition to the blinds channel item.

And I added once again WindowsCovering, plus WindowsCovering.CurrentHorizontalTiltAngle and WindowsCovering.TargetHorizonalTiltAngle to the lamella channel item.

This results in two controls in Homekit, one for the blinds and one for the lamella, and both work just fine. So I am almost there.

My hope was I could have one Homekit control, that would then be able to control both the blinds plus the lamella, but it seems this is not possible?

yes, almost there, you just need to put the group back.
here is the example in the text notation

Group           gBlind    			    "Blind with tilt"       						{homekit = "WindowCovering"}
Rollershutter   window_covering         "Blind"                         (gBlind)        {homekit = "WindowCovering"}
Dimmer          window_covering_htilt   "Blind horizontal tilt"         (gBlind)        {homekit = "WindowCovering.CurrentHorizontalTiltAngle, WindowCovering.TargetHorizontalTiltAngle"}
Dimmer          window_covering_vtilt   "Blind vertical tilt"           (gBlind)        {homekit = "WindowCovering.CurrentVerticalTiltAngle, WindowCovering.TargetVerticalTiltAngle"}

tried that; it only gives me another lamella control for the same thing

it looks like something is wrong group configuration.
with the config above i get one control - for blinds and lamella. but i have not tried to create it with UI