Raspberry PI 3 B+ Kernal Panic

I have purchased a new Raspberry PI 3 B+ with a 32GB SD Card. I have verified it’s working by trying it out with the standard Raspberian image.

I have downloaded the image from https://github.com/openhab/openhabian/releases/tag/v1.4.1

I have MacOS so I used the Unarchiver GUI to extract the .img file and then I used a utility called Apple Pi Baker to write the image to the SD-CARD.

The Pi has only this card, an ethernet cable, HDMI, USB keyboard and power connected.

When booting it fails with a panic.

(end Kernel panic - not syncing : VFS : Unable to mount root fs on unknown-block(179,2)

I’ve repeated the sd-card creation a couple of times for good measure but I’m stuck now.


Have considered to do it like the documentation suggests ( using etcher…), I did it that way last week on three devices. No problem observed.

1 Like

Like @opus mentioned, try to install and use Etcher. If Etcher is not an option then I would make sure you reformat the SD card so it wipes out anything from the Rasp image then try the new image.

Thank you - I guess I was not looking at the correct place. I tried Etcher and that worked ok.

To be honest I spent most of time time working around the fact that the new Macbook Pros only have USB-C connectors. So I’ve got an adapter now which will come in handy.

Now off to the land of OpenHab… exploring