Raspberry pi 4 reboot issues

Hi All

my SD card corrupted on the pi 3 so decided to rebuild on a pi 4

Its just not booting reliably

after multiple reseats of the card and power cycles I can get it to boot from cold but never from a reboot shuts down but wont restart

its not a lack of power issue was using the official pi PSU but tried the 65W psu from my laptop till has the issue

I’m wondering if I have a faulty pi Ive cut the image not on 3 cards from 2 different manufactures

cards work fine in my PI 3

Any ideas ?

I assume you are using openHABian.

Did you use the latest openHABian v1.5 release?

yes downloaded it this morning I’m going back to using the pi 3B for now and try and sort this out later
as wasted a day on this already

Just to make sure… You did not reuse the old SD-Card, right? :smiley:

No I used a brand new out the box cards

think this seller may have ripped me off with the psu the pi 4 needs 5.1V stable and the ones they sent are labeled 5v and look nothing like the official ones they sold them as

have ordered a new psu and will retest

1 Like



* 5V DC via USB-C connector (minimum 3A*)
* 5V DC via GPIO header (minimum 3A*)

How much Ampere does your current power supply deliver?

3 amps

Did you try the default raspbian image?

no will try that tomorrow have run out of time with is now as need to go to work

Alright, wish you a relaxed shift :slight_smile:

1 Like

I have found the easiest way is to install NOOBS. You can then install Raspbian Lite and follow the openHABian install instructions for Linux.


1 Like

The easiest and safest way is to install the RPi openHABian image.
We advise not to install the OS yourself as that will quite almost and quite for sure result in little differences on everyone’s boxes, probably depending on the user’s UNIX knowledge level.
But these little differences can be enough to make a standard solution (that works for an image based box) no longer work for everyone.
So please, start with the image and don’t change anything unless you’re really knowledgeable enough in Linux and aware of all of that change’s consequences.

1 Like

They already tried that, I thought.

If your RPi4 isn’t the latest revision, your laptop’s power supply might not be able to supply it due to the USB-C incompatibility. It should be fine if you’re using an official RPi power supply, but as you’ve noted, maybe that’s not what you were sold.

1 Like

just to follow up look like a faulty pi

problem still remains with official psu

have rebuilt my openhad on pi 3b and its running fine going to get a replacement pi4

got my replacement pi today put Sd card in powered up first go reboot every time

first time ive had a doa pi got 5 of the 3s all fine

I would recommend to store your data on an attached usb-harddrive instead… I got tired of sd-cards corrupting after a while…

I dont beleve in having sd-cards as a storage for a server enviroment…poor quality of cards and too many read/writes…

So I moved the data to a harddrive (you’ll still have to have an sd-card inserted to get the system started…but otherwise it isn’t used…). For me has worked like a charm for several years now!

A guide for doing this:

1 Like

I’d consider to setup your new box using the ZRAM feature in openHABian.
No need for an off-mainstream solution with external HW.

Try to update your firmware if not already did. Using rpi-update