RaZberry 7 Z-Wave shield is UP and RUNNING with OH3.3 ZWave Binding (and connects to Z-Wave Device Devolo thermostat successfully)

Hi all,

I have bought a brand new RaZberry 7 PRO shield (Z-Wave 700 Series) from z-wave.me and connected the new shield to my openhab 3.2 installation on my Raspberry B3+ - I was really dissapointed…

After reinstalling the z-wave binding, the shield was online but it was not able to connect successfully to my z-wave devices. There was a problem to recognise the manufacturere ID and in consequence to gather the Thing Definition from Chris Jacksons great z-wave database… I searched the web and tried to configure manually, did a fresh OH install, analysed the debug logs… Nothing helps.

I just found the info in the web: Z-Wave 700 is actually not supportet… great sh :poop:

After a few days I suddenly saw that the manufacturer Devolo was detected, but the channels were always not displayed correctly, no values were transmitted and I always got the messages in the log:

[WARN ] [l.serialmessage.ZWaveCommandProcessor] - SerialMessage class null is not implemented!
[WARN ] [ave.internal.protocol.ZWaveController] - TODO: Implement processing of Request Message = – (0xa8)

that means for me, that some communication works…?..ah, ok, to be continued? never give up…


  1. install on a virgin Raspberry: the complete SD Card image of Raspbian Buster including Z-Way software (hhtps://razberry.z-wave.me/z-way-server/razberry.img.zip)

  2. do a firmware update to clean RaZberry 7 shield to version (2021-12-08)

  3. after that I included (just for testing) the Devolo Danfoss thermostat z-wave device within the up and running z-way OS - now I saw that the manufactuerer Devolo was recognised an thermostat device with firmware and values correctly

  4. Changed SD-Card to OH 3.3.0 Snapshot installation, install Z-Wave Binding again (maybe you don´t need this?), scan for devices and voilà: the Devolo thermostat is in the Inbox.

  5. after linking channels to items you can see the real values also.

IT WORKS !!! Great news and thanks to Chris Jackson and all the other contributors for making all this holy things possible :hugs:@chris

Cheers Nick


I ran into this too and switched to the z-way-server installation on the PI and moved the OpenHAB 3 to Docker and used the z-way addon there. This works like a charm.


Can anyone confirm that only an firmware-update is needed?
Or do we need the whole procedure over a fresh image?
I would like to install z-way in parallel (as a service) like I allways do and trigger the update there.

Did you inclueded other deviced out of OpenHAB 3.3 or do you have to switch back to z-way for every device?

1 Like

Can you please exclude (remove) the device from the controller, restart OH and try including it again ? It’s worth to know to all others if the inclusion just worked because you did it in z-way or if things started to work because of the firmware upgrade.

You can install but not run z-way in parallel to openHAB, they both need exclusive access to the serial device.

All 700 series and 800 series only have bridge controller firmware available and are not supported by the z-wave binding.

There is no firmware upgrade available that would make them compatible.

There is no way to support these under the current z-wave + V2 standard without big changes. I am not sure how z-way have added support but they might have built a proper solution to the standards.

Some other projects have a hacked version that they hope will be certified but there is no indication that this will be possible from the z-wave alliance.

But when it does not work, what is he talking about here?

Does this apply to 7(8)00 serie controllers and sub-700 devices ?
Note while it’s all talk about 700 series features such as long range, reality is that there’s 700 controllers but hardly 700 devices out there, so it is about making a new controller work with older devices.
I’d guess that any controller vendor will implement the existing 500 series code in addition to the new stuff so his great new stick is compatible with older devices, too, won’t he ?

New slave devices are compatible with older controllers. It is just new controllers that are not compatible with the z-wave binding.

That is an interesting question. For vendors who integrate the controller in a device like Homey, Hubitat, Fibaro and all, the controller you get is what they support. A bridge controller firmware is available for 500 series so it is possible to make the same software support both chips. Fibaro have done this with a 500 chip in their HC3 and 700 chip in their other controller which use the same stack.

For software like Homeseer it is more difficult to be compliant with the standard and support older controllers with a non bridge firmware so I have no idea if any commercial software is supporting everything or how z-way have made their solution.

Some have chosen to ignore the standard and built a serial interface compliant with both bridge controller firmware and static controller firmware. They are gambling that the standards agency may change their minds as they apparently want to be certified. Possibly they are correct and they will get certification.

Incidentally as you mention long range it is worth knowing that Long range only exists just now for the US frequency. The old US spec had a lower power RF but the power has been increased for LR in the US which no longer uses a mesh. I have no idea when LR firmware will be available for other frequencies. They are certainly not in the latest release so if you are not in the US it is not going to be anytime soon.

Another development is that there is no USB 800 series controller with the latest 800 development kit. Third parties might choose to build one but in the past silicon labs made a reference design for each series. The UZB-3 and UZB-7 being the ones for 500 and 700. There is not one for 800 so a 800 series USB controller will be a while.

1 Like

@mstormi @chris

I tried to remove the device via OH, but “remove device from controller” it was not possible.
Step1: So I “only” deleted the thing in OH.

Step2: I started the Raspi with the above mentioned Z-Way Expert UI from image and excluded the Danfoss Devolo in the RaZberry 7 Pro shield.

—> So I had the status like yesterday evening before the whole action: the RaZberry 7 Pro shield was not aware of the Devolo thermostat.

Step3: Now I have triggered the integration of the device as desired via Openhab. Via “Things - ADD” I selected the RaZberry 7 Pro serial controller bridge and started the scan, pressed a button on the thermostat and voilà: the thermostat was visible.

Step4: Then I added the device as a Thing and a short time later I was able to read the first values like temperature and battery status via the channels…

Since the firmware update of the RaZberry 7 Pro shield in generally the communication with the Z-Wave Binding is ok, but not all is tested…
I have made screenshots of all steps, pls see PDF attached
Cheers, Nick
Razberry7 compatibility with Z-Wave Binding screenshots.pdf (786.3 KB)

After above described firmware update of RaZberry 7 PRO shield to (2021-12-08) I was able to include the z-wave devolo thermostat without the zway-Software. Today i found the z-way software is also neccessary to exclude devices from the RaZberry 7 Pro shield - this doesn´t work with the Z-Wave binding…

to be sure I have successfully connected to RaZberry 7 Pro a completely box-new and virgin Devolo (Danfoss) z-Wave thermostat, that has never been used before. And again, there was no big problem with the z-wave binding and adding the device via OpenHab…
I only had to correct the “Wakeup Interval” from 0 to my default 300 (but maybe I have not been able to wait and see if the value comes later :see_no_evil: )

ah… and the wakeup node under Thing settings is “0” … thats also incorrect. But i think this is a zwave binding issue and not a compatibility problem between ZWave Binding and RaZberry 7 Pro…


So, I have now made another test. I excluded both radiator controls (via the described way), deleted the Z-Wave things and then uninstalled the Z-Wave binding. So everything is now completely reset.

After the OH start I installed the Z-Wave Binding and included as thing. Then via “Add devices” searched for the radiator controls, found and also integrated as a thing. They were immediately recognized with the correct node ID MT02650 Devolo thermostat (09356). I also added this as a thing and added new items in the channels. Voilà, the values are transferred and I can at least read the values. Whether I can also set which, I will still test on the weekend…

FYI: Tested 2022-02-08 with

  • openHAB 3.3.0-SNAPSHOT - Build #2733
  • Raspberry 3 Model B+
  • RaZberry 7 PRO shield (z-wave.me) FW: (2021-12-08)
  • Devolo (Danfoss) Radiator Control MT02650 FW: 1.0

In 9 from 10 cases I did not get excludes devices from network with teh 500er RaZberry :frowning:
(So there may be an generall issue?)

Can someone provide the “Thing Properties”-Count for " “Devolo (Danfoss) Radiator Control MT02650”, so that Griswold could compare? In my cases when inclusion was to fast the Inerview was not fullfilled 100% and the indication were:

  1. 20/23 “Thing Properties” present (sometimes even less; I got the value “23” from over 13 well included devices)
  2. The Button “Reinitialize” was not present

Most of the Time I cound fix this with some “heals” directly after inclusion (and pressing something on the devie; not sure if that was neccessary)
If that dip not help: I marked the device “as failed” + “removed from controller” (not sure if it was really removed) and started inclusion again (that time the device was even faster there and get full name some seconds later)

[Not sure if such has to be mentioned here: superiorly in a tutorial section for slow inclusion; but as you can see, I am unsure in some steps and dont want to propagate half-truth-stories]

I know this workaround and posted it here some times for people having trouble to include z-wave devices under OH 1 and 2. Back then I always used HABmin to start inclusion several times while repeatedly pressing the connection button on the device, leading to a “step-by-step inclusion” of otherwise not including devices.

Thank you so much for your postings on the new Razberry. I am about to switch to my new OH3-Installation on a new Raspberry 4 and still think about the migration of my z-wave devices. I would love to keep the old installation “untouched” in case of a necessary rollback. A new Razberry - even the new model - and the backup and restore feature of the z-wave.me software would be a good chance to realise this. Good to hear that the new model will work with OH3 and will allow to add new z-wave devices.

Have z-wave.me managed to achieve restore of controller from pre 700 to 700 series controllers?

I have just tested exclude on 3.3 M1 and both uzb-7 and uzb-3 exclude from openHAB but did not remove the thing. I would need to do more testing to see if there is a PR needed but the thing had a very clear error that the node was not found on the controller after I paused and enabled the controller. Manual deletion of the thing was not a big issue anyway.

Again it is very useful to have a zniffer to see the protocol transfer and request exclusion/node info messages for inclusion and exclusion.

Many slave devices are a bit temperamental about entering inclusion or exclusion so it is often the slave device did not enter and send the appropriate messages. On the add the most common error people make is to think it is not added and manage to add and remove all in one. With no zniffer you will know you have done this by a missing node ID. With a zniffer you see the message so stop clicking.

Good question! I just assumed it.

I am sure they will answer you if you ask.

The architecture of the chip is so different the file would need to be rewritten which would be very involved and clever thing to do but they are smart people so they might have done it.

I would also hold your horses until someone has really proved compatibility before getting one if you want to stick with openHAB binding. It would be fantastic if these were compatible but more devices working and some explanation of what the firmware is would help.

Great news, today in addition to my first attempt with the devolo Radiator Control I successfully paired a box new Fibaro FGWPF-102 ZW5 v3.2 230V Wall Plug with the RaZberry7 Z-Wave shield for the Raspberry.
The binding is running, the wall plug can be switched out of OH and I also get the power of the consumer transmitted.

The binding process was straightforward, after starting the scan via the official OH Z-Wave Binding and pressing the button on the Fibaro Wall Plug 3 times, a new Z-Wave Node was detected and after about 15 seconds the name came up: “Z-Wave Node 0006: FGWP102 Metered Wall Plug Switch”.
I added it to the house model via “Create Eqipment from thing” and my test lamp could be switched on and off immediately via the item. Likewise, the power consumption was also immediately displayed to me.
The communication in both directions works.

Cheers, Nick