Replacing openhab2 Paper UI installed binding with custom jar

I Like to the a new Modus binding >(Modbus support for transformations, roller shutter items, read-only items, write-only items, and others).

Actually, I use the 1.9 binding in OH2.

I copied the 1.10 binding in the addon folder but it is not recognized. Also uninstalling the 1.9 does not help…

Can anybody help?


1 Like


Do you have openhab1 compatibility layer installed?

Yes and actually I use the 1.9 binding… I cannot “replace” this binding which comes via the repository.


Thanks! Not sure I follow though…

Have you installed the 1.9.0 addon as documented here?

Do you have openhab2-addons-legacy package installed?

What do you have in /usr/share/openhab2/addons?


okay … lets see…

  • I have the Debian packages openhab2 installed.
  • Via the PaperUI I have activated access to the remote repository and include legacy 1.x bindings.
  • The /usr/share/openhab2/addons folder only contains the org.openhab.binding.modbus-1.10.0-SNAPSHOT.jar file.

May be I turn of the remote repository, use the package and replace the binding file?

Thanks, this now cleared your setup at least.

Not sure how the openhab2 configuration is done but you would think that it would be possible to remove the modbus 1.9.0 somehow… Unfortunately I’m still not familiar with the new openhab. Let’s wait for for other users to pitch in.

Perhaps you should rename the title as “Replacing openhab2 Paper UI installed binding with custom jar”?


EDIT: noticed that the docs refer to kar files

When running a manual installation, it is possible to pre-download add-ons or legacy add-ons if you want to install any bindings at a later date without connecting to the internet. Simply download the kar files (the latest builds can be found here) and move them to the /opt/openhab2/addons folder.

and also jar files:

While the openHAB distribution already contains many add-ons of openHAB 1, there are still quite some of them missing - please help testing them - if they are confirmed to be working, they can be included in the distribution. Test a not included add-on is very straight forward:

  • Start your runtime
  • Install the 1.x compatibility layer by running feature:install openhab-runtime-compat1x in the openHAB console
  • As with openHAB 1.x, simply take the jar file of your add-on and place it in the ${openhab.home}/addons folder.
  • Copy your personal openhab.cfg file to ${openhab.home}/conf/services/openhab.cfg.

Not sure if both are correct but at least I’m confused now :slight_smile:

Thanks for your work! In my setup I also turned of in PaperUI the “access remote repository” to “motivate” openhab2 to have a look into the add-ons folder without success…



Found something that might help you. Perhaps you need to follow these steps (of course adapting as necessary as the guide is for zwave)

Most importantly ensure that you have serial feature installed and if necessary you might need to start the bundle from karaf it seems


I was a few days offline. Your hint worked fine with the addition of
feature:install openhab-transport-serial

Thanks, now I can test it.