RESOLVED: TKB Home TZ67E Device is Not In Database: Unknown Device

HI, I have several TKB TZ67E dimmers already recognised and working fine in Openhab (2.5.0.M1). I recently bought 3 new dimmers and Openhab is saying they are unrecognised. Habmin shows:

Manufacturer: “Not Defined”
Type/ID: 0003:0008
Firmware Version: 2.48.

The only difference between this non-working one and the working one is that the manufacturer is not being reported by the device. I contacted Vesternet who sent me the following response. I apologise for copying and pasting all of it, but my understanding of how the zwave binding works is not all that great.

"Hi Sham,

We sometimes see this with various devices, the manufacturer doesn’t set the manufacturer code - this is typical of devices that share a common hardware base (i.e. the hardware may be produced in China and then re-branded by TKB, Philio, Zipato, NEO, etc).

It could be argued that the device is “faulty” as it’s not technically compliant with the Z-Wave specifications, but in the real world it could also be argued that the device “works” fine.

*OpenHAB uses the manufacturer data in order to present the device in its system and doesn’t appear to provide any fallback mechanism to present the device based on its Command Class support, or to allow the user to override the device that’s been detected. *

Other Z-Wave controllers such as Vera, Fibaro, Zipato, HomeSeer, SmartThings, etc typically don’t rely solely on that data, but if they do use it, then they also fallback to other methods or allow a manual override.

As it stands your options are likely to be:

1) Contact TKB and see if they can supply an updated firmware that sets the manufacturer - Z-Wave Plus devices can be OTA updated, assuming that OpenHAB supports that

2) Ask OpenHAB developers if there’s a way to override the recognition

3) Return the device for an exchange, however it’s not guaranteed that a replacement wouldn’t have the same issue""


@chris, could you advise if anything can be done from the openhab side?

Many thanks.


2 Likes

manyt thanks, @sihui! I did do a search but clearly my search skills need some work. Appreciate the direction.

Just in case anyone has similar issues with the TKB TZ67 dimmer socket, following the instructions in the linked posts I managed to resolve the issue.

If anyone needs an updated firmware file for the TZ67, please PM me and I will happily share.
Thanks.

2 Likes

Hi @shamim,

Thanks very much for sending the firmware file to me. I just tried it, but after the module reports successful completion nothing else happens and the old firmware remains. I tried waiting a while and forcing a re-inclusion.

Do you remember if you did anything differently from the instructions in the above linked linked thread?