Ring Alarm Components - Zwave

I have removed the two gen 2 sensors, re-included them (recognition seems to be ok).

Unfortunately I do see 4 channels each, but non of these are firing:

I am using the SNAPSHOT

Since you included again, is the device fully configured? Do you have an XML file for the node in the userdata/zwave folder and five lines on the UI page?
Five Lines of configured node

For Node 36 (Motion Gen2) both is true.
For Node 35 (Contact Gen2) I don’t have an xml in place and “Reinitialize” is missing.

I wonder what this means:
9: Motion Detection Mode
There is no documentation about this parameter.

The network map does none of both.

It is common for the channels to not begin to “fire” until fully initialized. Based on your post, Node 36 is fully initialized (and should be working), but node 35 will still need to be awakened until XML/Reinitialize appear.

The network map is not a problem. Once initialized you can heal the device and they will appear in the map. You could heal 36 now, but not 35.

I see the motion detection mode in the device DB and manual, but not sure what it means either. The default is 3, min is 0 and max is 4.


edit: If 36 is still not working, try to change parameter 2 to 5, from 1. That will increase the number of retries, (Maybe communication with the controller is not working?) Also the “heal” may help 36 with additional routes.

I did an it appeared in the network map.
So far so good. :wink:

I will try you other suggestions.

Thanks for your help, Bob!

I think that shouldn’t be a problem. The 26 is now (after a heal) directly connected to the controler:

One more question:
I am using this USB stick since 2015:
Z-Wave USB Stick (ZMEEUZB1)

Is it possible that this is the culprit and outdated?
Should I get a Aeotec AEOEZW090-C Aeon Labs USB Stick instead?

If I start from scratch: Does it make a difference if I exclude all devices or set them back to factory settings?

The parameters listed here are not matching those in my thing config (some are mixed up):
manuals-backend.z-wave.info/make.php?lang=en&sku=Motion Detector v2&cert=ZC12-20050057

e.g. Motion Detection Mode is 8 (and 9 on my thing - which is the same like in the official manual)

There was obviously an issue with the earlier version, but this should be fixed (Supervisory report timeout):
Ring 2nd Gen Motion Sensor - Off-Topic - openHAB Community
Why was this changed to 1 Byte? - the manual mentions 2 Byte ?
I have issues with the Motion Sensor as well.
What is the name of the channel reporting correctly the Motion in your case?

I’m assuming you mean 36. Anyway the map only represents neighbors found during the Heal process, not the actual routing. Of some concern are the two dead nodes 3 & 6 those should be removed. Here is a link to a recent post that might help.

What you should try next (re; Node 36) is to put the zwave binding in Debug and try to trigger the motion sensor and see what info (if any) is revealed. Move it closer to the controller for a while.

There is a next to nothing chance (IMO) it is the controller since it appears other devices are working.

If you do start over, it is best to use the Controller UI page to “exclude devices”. If you just reset the device, it will still be in the zstick memory. Then you will need to reset that to factory. The exclude devices takes care of both.

I’d stick with the official manual.


Indeed - sorry

I deactivated them on purpose (some wallplugs lying around without use yet).
You mean that’s not how it supposed to be?

Will do - thanks.

I will check also the debug mode.

Thank you for your patience.

I did this in the past as well (removed Nodes with Silabs).
One question though.
After that and deleting the node, I still found an XML in the z-wave directory.
Is this potentially confusing the system or is this just a harmless relict?

Here is the result of a restart for Node 1 and Node 36.
I opened the case (tamper alarm?) at 7:37, but nothing was reported.

I believe it is harmless, but probably should be deleted. When devices are removed by “exclude Devices” on the UI Controller page (those still powered) the xml is deleted. You will have to factory reset the device, before (if) you plan on including in the future.

As to the debug log, it is hard to tell anything except Zwave communication is very slow (Red times- should be like 25ms). I have devices that can restore to “DONE” from a restart in 0.5 - 1.5 seconds. Node 36 took edit (i don’t know what I was looking at) it was 3 minutes.** and seemed to be repeating messages. Can you post the raw, unfiltered debug file?


edit #2 I guess I’m still not awake. What also is missing is the application handler update. Se below;
dynamic values
So the device is Acking, but not sending the data.

Thanks for your endurance helping me out.

In the past I had the impression, that the Z wave network is pretty slow.
So your comments seem to support this impression.
In the past I also have removed and re-included some devices and wonder if I really should start from scratch – at least with the Z wave network– not everything else.

Because I just moved to a new house with concrete floors, this definitely has an impact on the network – at least in comparison to my previous apartment.

Maybe the density of the network itself it’s not high enough for this house.
But in general – I assume - the ring device should work - even if it’s very slow.
But this does not seem the case.

I will create a new raw log file tomorrow and will update you then.
Again, thank you very much for your support!
Much appreciated!

I did think about the start over idea, but held off recommending it until I saw the raw log file. There is definitely a communication problem with at least node 36, but maybe with others as well. Another idea is to do a network heal now that 3 and 6 are gone. Also try a fresh battery in node 36. Lastly if you do start over, grab the may 23 zwave binding it has my zwave battery device changes that should help with the battery device inclusions.


Fair enough :slight_smile:

Node 36 is brand new (Ring Motion Gen2), so the batteries are new - but I will switch these to be on the safe side a s well.
I reactivated 3 and 6 (also to get a better coverage with the reinforced concrete ceilings).
After that I did a heal - and actually the USB stick does a heal every day at 2 am.
By the way: Node 35 did not change (no xml, nor a reinitialize option).

I will definitely do that.

Please alllow one more question:
Inclusion should be close to the controller.
Because I have some zwave Sensors fixed installed, would you go with the Aeotec Stick?
This has a battery and I could go closer to the various devices during inclusion.

Any newer would be ok as well, I assume!?


edit: also the aeotec stick would allow you to turn the other zstick into a zniffer. That would help with traffic analysis

Thank you.
I will consider this.
My Aeotec Stick just arrived yesterday I will hopefully find some time to start this week.

Would you recommend to include with the battery function of the Aeotec or should I bring the OH host closer to the fixed installed devices?
The outdoor motion sensor (230v) is about 12m away.
Another option would be a usb extension cable to get closer with the stick.

Zwave plus devices are capable of network wide inclusion, so the closeness is only critical for older non-plus devices, but should work either way. The only devices that must be included while the controller is plugged into the server/binding are those with security (like locks).

edit: I include all my devices with the controller attached, and did have a problem once with doing it detached, so would try attached first.

Will do - thank you.

Finally I started from scratch and use the Aeotec stick.
I have included all my devices and everything seems to be fine.
I did not check the logs yet in detail for long response times though.
When including the ring motion sensor, it seems to be working, because it was recognized and it’s online.
However at the end of the inclusion the red LED was glowing solid, which means, that it was not successful according to the manual.
I will check later if the sensor reports something

So do each of the devices have 5 lines (Reinitialize Device?). Is there a xml for each node, with Node 1 being the earliest date? If yes, yes, all could be fine.

I guess the key is if the sensor reports. I’m assuming the Door/window is working too?