Rollershutter Fibaro FGR-222 Rev 02 - Positioning - OH2

Tags: #<Tag:0x00007f61838640c0>

Hi,

I’m rather new to OH2 and and recently installed my first Fibaro rollershutter. Everything works as it should regarding the implentation into basicUI via items using Eclipse.

The question that arises:
Is it possible - and if so how - to tell the rollershutter to stop - for example - at 70%? I couldn’t find any command strings so far and the experiment using dimmer failed.

On the one hand I want to implement a rule like:
IF nobody@home AND sunny weather AND 2pm THEN close rollershutters and stop at 70%.

On the other hand I’d like to have a slider in basicUI, to set the position manually.

I appreciate any ideas, thanks in advance.

Cheers
Sven

Item.sendCommand(70) in your rule should work fine (it does at my setup :slight_smile: )

Yes, you have to use this in your sitemap file:

	Switch	item=gRollladenEG label="Rollos" mappings=[1="AUF", STOP="STOP", 99="ZU", 88="3/4"] icon="rollershutter"

Regards, Christian

Edit: sorry, my configuration is for the sitemap, to show you some buttons in BasicUI for example.
@sihui has the command for your rules

Thanks for your replies.

@sihui:
It’s not working. :disappointed:
All that happens is that I hear the relais click.
I created a dummy switch in items and use the following code in rules

rule "Rolladen 70%"
	when
		Item TestSwitch changed
	then
		wz_rs_re.sendCommand(70)
end

Any ideas? I’m really new to programming rules in OH2.

@all:
Is there any chance to implement a slider in basicUI?

You need to define the item as a “Rollershutter”, not as a switch …

Edit: text config would be something like:
Rollershutter FibFGR222_Kitchen_East "Jal Küche Ost [%d %%]" (gInfluxdb) {channel="zwave:device:158b44ebf65:node11:blinds_control"}

2nd Edit: slider in your sitemap should be:
Slider item=TestSwitch

Note that you still have to define your items file with “Rollershutter”

@sihui
The shutter itself is configured as rollershuter and works fine (up, stop, down):

Rollershutter	wz_rs_re	"WZ Rollladen rechts"					(EG_WZ , gShutter)	  	{ channel="zwave:device:53f77a1c:node5:blinds_control" }

I just wanted to use a dummy-switch to test sendCommand(70) and trigger the Command.

Using the slider @sitemap results in a binary function of completely up or down.

Does the fibaro controller even support percentage values?

Sure, as long as you configure parameter 10 correctly: Blind with positioning

@sihui
Guess this is one big step towards the solution, how do i do that?

Didn’t you configure the zwave parameters on the device ?
Use habmin to access it.

Did you calibrate the shutter? (set param #29). Driving to a percentage probably won’t work without.

@mstormi

THERE we go.
No, I didn’t do that, didn’t even know, that there is such a detailed configuration in habmin. Thanks a lot.

param #10 has been set correctly. Do i have to switch to start calibration process as param #29 says deactivated?

And are there more things I should be aware of regading the rollershutter’s configuration?

yes
Make sure you have a motor that stops automatically at upper and lower end (Endlagen sollten korrekt eingestellt sein, macht man am Motor).

Well, as it usually stops automatically, even if the switch is still triggered, it SHOULD be correct. Hopefully … :wink:

WOW, thanks a lot, everything works perfectly well now.

But interestingly, the command(70) sets the blind to approx. 50%.
/Edit: Well, yes. 100% closed is more than touching ground. :smiley:

Just one last questions:
How do I reverse the slider so that it closes the blind when I slide to the right instead of sliding to the left that 70% does NOT mean 70% open but 70% closed?

Sven

Go to channel config in either HABmin or PaperUI and set “Invert percentage value” to active.

Perfect, thank you!

Just thought again about your question: maybe in your case you need to set “Invert control”.

Slider works as intended now, percentage doesn’t but I can live with that. Guess one doesn’t alter rules that often. :wink:
Thanks

It should.
Play around with those two options and both should work correctly …

hi, I will reply to this topic, because my question is about the positioning with the FGR-222.
I´m the only one who has the problem that the Roller/Shutter will loose his “calibration” after a few up and downs ?
My rule in the morning let the FGR´s go to 98% ( I do not want to raise the roller shutters to the limit !).

This will work after calibration. If I move the roller shutter now a few times to various % (30% to 70%, than to 40% and so on…), then he drives the next morning suddenly back to the full limit.
But I cannot re-calibrate the FGR-222 every day … any ideas or is it “simple - normal” ?

Can’t give a definite answer but to some extent that’s normal as it’s caused by the material.
The blinds/shutter material lengthens/shrinks due to temperature changes, repeated moves etc, so you need to recalibrate every now and then. But certainly not every day, it should rather be on the order of once a year.