Rollershutters stops operating with Alexa today, direction inverted

So I noticed from the item definition you listed above that you have one of your Rollershutter item not inverted while the other is. So I assume you are referring to persiana5 as being inverted. You can set the inverted=false metadata parameter since Rollershutter items are now inverted by default.

Rollershutter persiana5 "Persiana Cinco" <persiana> { alexa="Blind" [inverted=false], channel="mqtt:topic:mosquitto:persianes:P5" }
Rollershutter persiana6 "Persiana Seis" <persiana> { alexa="Blind", channel="mqtt:topic:mosquitto:persianes:P6" }

Same problem like OC, resolved like this :

Rollershutter VoletSalon "Volet Salon" (Salon) ["Blinds"] {channel="mqtt:topic:419dba15:voletsalonmqtt", alexa="RangeController.rangeValue" [category="EXTERIOR_BLIND", friendlyNames="@Setting.Opening", supportedRange="0:100:10", unitOfMeasure="Percent", actionMappings="Close=100,Open=0,Lower=(+10),Raise=(-10)", stateMappings="Closed=0,Open=1:100"]}


Rollershutter VoletSalon "Volet Salon" (Salon) ["Shutter"] {channel="mqtt:topic:46ee3805:voletsalonmqtt", alexa="Shutter"}

thanks @jeshab

1 Like

Although the tag is not relevant at least from the skill perspective.

1 Like

Yes, I have one in each direction to test witch one works correctly… but both, and also with {alexa=“Blind”}, still works reversed. The only thing that I haven’t tested yet, is trigger a device discovering on Alexa Echo Dot. Re-reading all the post I found that you say that is “mandatory” rediscover the items (but also is not necessary to delete them on Alexa App ,is ok?)

Thanks, and I hope that this afternoon can do more tests.

Very annoying breaking change.
I was not able to bring back the correct functionality.
I tried


and all combinations of actionMappings mentioned in this thread.
Of course did a rediscovery with every conf change.

So I will stick to “wrong” commands to get my shutters going. :hot_face:

Did you test the inverted=false feature as well


I did read every single post, but: overlooked that one.
It works, thx you soooo much :smiley:


Has anyone else noticed that there are no controls in the Alexa app (ios) after this change? However, voice commands still working, but no longer control via smart devices in the app.
Addendum: Of course, only applies to blinds. Light still ok.

You have to trigger a discovery each time you are making changes to your Alexa configuration on your OH server. You don’t need to delete them beforehand though. However, it doesn’t hurt to do so to confirm a given device was properly rediscovered.

This is a known issue as mentioned above.


Not yet… I will make each blind with a diferent combination to test witch one works correctly.

Still work reversed with both options. I have rediscovered devices, deleted and rediscovered again to be sure that there are really rediscovered. All time works at oposite with inverted and without it :frowning:

Any other things that I can test?

Rollershutter persiana8 "Persiana Ocho" <persiana> { alexa="Blind", channel="mqtt:topic:mosquitto:persianes:P8" }
Rollershutter persiana9 "Persiana Nueve" <persiana> { alexa="Blind" [inverted=false], channel="mqtt:topic:mosquitto:persianes:P9" }

Can you provide your event logs associated to the Alexa commands you requested?

This is the code of this all 4 blinds:

ollershutter persiana5 "Persiana Cinco" <persiana> { alexa="RangeController.rangeValue" [category="EXTERIOR_BLIND", friendlyNames="@Setting.Opening", supportedRange="0:100:10", unitOfMeasure="Percent", actionMappings="Close=0,Open=100,Lower=(-100),Raise=(+100)", stateMappings="Closed=0:49,Open=50:100" ], channel="mqtt:topic:mosquitto:persianes:P5" }
Rollershutter persiana6 "Persiana Seis" <persiana> { alexa="RangeController.rangeValue" [category="EXTERIOR_BLIND", friendlyNames="@Setting.Opening", supportedRange="0:100:10", unitOfMeasure="Percent", actionMappings="Close=100,Open=0,Lower=(+100),Raise=(-100)", stateMappings="Closed=50:100,Open=0:49" ], channel="mqtt:topic:mosquitto:persianes:P6" }
Rollershutter persiana8 "Persiana Ocho" <persiana> { alexa="Blind", channel="mqtt:topic:mosquitto:persianes:P8" }
Rollershutter persiana9 "Persiana Nueve" <persiana> { alexa="Blind" [inverted=false], channel="mqtt:topic:mosquitto:persianes:P9" }

With all of them, if I say “Alexa Baja Persiana X” (Alexa Down Persiana X), in MQTT I receive a 100 command, no matter what combination I have, all four of them receive a 100 command.



I would have expected that your persiana8 and persiana9 items to receive an UP command opposed to 100 as it was previously. This sounds like these items haven’t been rediscovered. Can you provide the actual content of your event logs?

Thanks Jeremy. I will check the log, because I have to enable a lower level of verbossing on log. Actually doesn’t see any information about Alexa. Can I enable a lower level only for Alexa?


I am referring to events logs (events.log) opposed to server logs (openhab.log). There are generated with the standard log level.

Sorry for before post. I have checked again. This is what I received on Persianas 6, 5, 8 and 9 for telling to do Down:

2021-12-16 19:45:43.227 [INFO ] [openhab.event.ItemCommandEvent      ] - Item 'persiana6' received command 10
2021-12-16 19:45:43.274 [INFO ] [penhab.event.ItemStatePredictedEvent] - Item 'persiana6' predicted to become 10
2021-12-16 19:45:43.274 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'persiana6' changed from 0 to 10

2021-12-16 19:45:50.507 [INFO ] [openhab.event.ItemCommandEvent      ] - Item 'persiana5' received command 10
2021-12-16 19:45:50.529 [INFO ] [penhab.event.ItemStatePredictedEvent] - Item 'persiana5' predicted to become 10
2021-12-16 19:45:50.538 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'persiana5' changed from 0 to 10

021-12-16 19:45:57.349 [INFO ] [openhab.event.ItemCommandEvent      ] - Item 'persiana8' received command DOWN
2021-12-16 19:45:57.364 [INFO ] [penhab.event.ItemStatePredictedEvent] - Item 'persiana8' predicted to become DOWN
2021-12-16 19:45:57.364 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'persiana8' changed from 0 to 100

2021-12-16 19:46:03.956 [INFO ] [openhab.event.ItemCommandEvent      ] - Item 'persiana9' received command DOWN
2021-12-16 19:46:03.988 [INFO ] [penhab.event.ItemStatePredictedEvent] - Item 'persiana9' predicted to become DOWN
2021-12-16 19:46:04.003 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'persiana9' changed from 0 to 100

All four defined as before post.

So I just realized that your items are linked to the MQTT binding. I will assume that your integration doesn’t support UP/DOWN/STOP commands? If this is the case, why not use Dimmer items over Rollershutter?

Anyway, if you insist using Rollershutter items, you will have to specify the action mappings since this is not the standard use case for these items.

Rollershutter persiana5 "Persiana Cinco" <persiana> { alexa="Blind" [inverted=false, actionMappings="Close=0,Open=100,Lower=0,Raise=100"], channel="mqtt:topic:mosquitto:persianes:P5" }
Rollershutter persiana6 "Persiana Seis" <persiana> { alexa="Blind" [actionMappings="Close=100,Open=0,Lower=100,Raise=0"], channel="mqtt:topic:mosquitto:persianes:P6" }

Otherwise, if you transition to Dimmer items (not inverted by default)

Dimmer persiana5 "Persiana Cinco" <persiana> { alexa="Blind", channel="mqtt:topic:mosquitto:persianes:P5" }
Dimmer persiana6 "Persiana Seis" <persiana> { alexa="Blind" [inverted=true], channel="mqtt:topic:mosquitto:persianes:P6" }

I will test both and tell you.
Really it is linked to MQTT because the home automation of blinds are not standard and I use a custom software to send commands to it (I could also recompile it for using reversed, but I prefer to know what is happening with OH before).

I could also change my automation part to UP/STOP/DOWN (maybe it could be better), because my blinds really have two buttons to up and down, and really I can’t control position, only all open or closed. But, to MQTT broker never arrives UP/DOWN commands, only number percent values, no matter I use “Blind”. Probably could be the better option, but… what can I do to receive de UP/DOWN command on MQTT instead of 0/100?

Thanks in advance.
EDITED: Works!!!.. all four suggestions work in the correct direction!
And also I suppose that need to change the “things” type of this MQTT commands to allow UP/DOWN reach the broker instead of number.

Thanks very much, and sorry for all messages.

If there are only two states and you can’t stop your blinds while transitioning from one state to the other, you should probably use a Switch item and map the on/off commands with the blind integration connected to your MQTT server, assuming you can make that change.

Doing so would basically switch the Blind device type default attribute, at the skill level, from PositionState to OpenState. Also, if the current state of your blinds aren’t retrievable, you should add metadata parameter retrievable=false on each item (command only support).

Switch persiana5 "Persiana Cinco" <persiana> { alexa="Blind", channel="mqtt:topic:mosquitto:persianes:P5" }
Switch persiana6 "Persiana Seis" <persiana> { alexa="Blind" [inverted=true], channel="mqtt:topic:mosquitto:persianes:P6" }