Rollershutters stops operating with Alexa today, direction inverted

I gave it another try, with default options:

but it doesn’t work.


The only reason I was asking this question is to determine if the group was configured as a group endpoint which therefore the item you are having issue with would roll under that endpoint. While troubleshooting discovery issues, I had a user not noticing that the group was configured as such.

So to be clear only the item in question cannot be discovered. Other new ones get discovered? If so, have you tried to rename that item?

curious to see that I can force the old configuration through code

value: RangeController.rangeValue
  supportedRange: 0:100:10
  unitOfMeasure: Percent
  friendlyNames: "@DeviceName.Shade"
  actionMappings: Close=100,Open=0,Lower=(+20),Raise=(-20)
  category: EXTERIOR_BLIND
  stateMappings: Closed=100,Open=0:99

and it doesn’t get discovered anyway (while I still have other 7 rollershutters configured like that which I didn’t touch and they still work, well… they work inverted of course, but they work).

I think that’s because you didn’t delete them beforehand. If the discovery process fails, previously configured devices will remain on the account. Can you please be crystal clear that you can add a new switch item configured for Alexa and it will be discovered on your Alexa account?


To be independent from any possible issue with device IDs, I created one new shutter and one new switch (with no physical device attached). The switch is discovered while the shutter is not. To also test the impact of the group, I created them in the same group so to have same configuration of the parent.


I haven’t to do any discovering, only restart OpenHAB, but…
There is any posiibility to get it working like before?
Now if I say “up blinds” then it goes down, and backwards, no matter I put on Items:

Rollershutter persiana5 "Persiana Cinco" <persiana> { alexa="RangeController.rangeValue" [category="EXTERIOR_BLIND", friendlyNames="@Setting.Opening", supportedRange="0:100:10", unitOfMeasure="Percent", actionMappings="Close=0,Open=100,Lower=(-25),Raise=(+25)", stateMappings="Closed=0,Open=1:100" ], channel="mqtt:topic:mosquitto:persianes:P5" }
Rollershutter persiana6 "Persiana Seis" <persiana> { alexa="RangeController.rangeValue" [category="EXTERIOR_BLIND", friendlyNames="@Setting.Opening", supportedRange="0:100:10", unitOfMeasure="Percent", actionMappings="Close=100,Open=0,Lower=(+25),Raise=(-25)", stateMappings="Closed=100,Open=0:99" ], channel="mqtt:topic:mosquitto:persianes:P6" }

The solution is listed above. You can either invert your semantic mappings metadata parameters or configure your blind items with the new syntax as {alexa="Blind"}.

I have tried the mapping solution (as you can see on the code section), trying both solutions with open at 100 or closed at 100… none of them works for me. Blinds are still reversed on both. I will now test the {alexa="Blind"} and report here…

Thanks in any case.

Tested with {alexa=“Blind”} and still reversed. When I say “sube” (up in spanish), doesn’t matter I put on items, that blind goes down… and “baja” (down), blind goes up. It works correclty for years until some days ago.

I only restart OpenHAB, doesn’t “scan for new devices” on Alexa. I think it is not necessary as the system recognizes all Blinds, but reversed. But now I am not sure… Have I to delete all blinds and add all again?

It is very anoying working on the oposite direction :confused::man_facepalming:

Thanks in advance.

Still stuck here. Almost certainly my own fault (lack of knowledge)

Tried the below

Rollershutter Down_Stairs_Blind  "Down Stairs Blind" {alexa="Blind" [category="INTERIOR_BLIND", friendlyNames="@Setting.Opening", supportedRange="0:100", unitOfMeasure="Percent", actionMappings="Close=0,Open=100", stateMappings="Closed=0,Open=1:100"], channel="rfxcom:rfy:b6a20466:shutter:command"}

When i ask Alexa to open the Downstairs Blind, she responds positively and i see the below in the log;

2021-12-15 20:57:09.538 [ome.event.ItemCommandEvent] - Item 'Down_Stairs_Blind' received command 0

2021-12-15 20:57:09.544 [nt.ItemStatePredictedEvent] - Down_Stairs_Blind predicted to become NULL

but nothing actually happens with the Blind. Tried swapping the “Blind” with “Shutter”, same deal, doesn’t appear to work for me


Rollershutter Down_Stairs_Blind  "Downstairs Blind" {alexa="Blind", channel="rfxcom:rfy:b6a20466:shutter:command"}

(Updated item label based on my previous comment)

No need to overcomplicate :smiley:

That certainly looks a helluva lot simpler! So, it’s now the below;

Rollershutter Down_Stairs_Blind  "Down Stairs Blind" {alexa="Blind", channel="rfxcom:rfy:b6a20466:shutter:command"}

Alexa responds fine, and the log shows the below, but nothing happens. Should point out i am deleting the device from the Alexa app and discovering again each time

2021-12-15 21:31:34.810 [ome.event.ItemCommandEvent] - Item 'Down_Stairs_Blind' received command UP

2021-12-15 21:31:34.814 [nt.ItemStatePredictedEvent] - Down_Stairs_Blind predicted to become NULL

So the skill is sending the expected command to your server. But your rfxcom binding doesn’t seem to act on it. That’s beyond the skill control. Did you link the same channel on two items by any chance?

So I noticed from the item definition you listed above that you have one of your Rollershutter item not inverted while the other is. So I assume you are referring to persiana5 as being inverted. You can set the inverted=false metadata parameter since Rollershutter items are now inverted by default.

Rollershutter persiana5 "Persiana Cinco" <persiana> { alexa="Blind" [inverted=false], channel="mqtt:topic:mosquitto:persianes:P5" }
Rollershutter persiana6 "Persiana Seis" <persiana> { alexa="Blind", channel="mqtt:topic:mosquitto:persianes:P6" }

Same problem like OC, resolved like this :

Rollershutter VoletSalon "Volet Salon" (Salon) ["Blinds"] {channel="mqtt:topic:419dba15:voletsalonmqtt", alexa="RangeController.rangeValue" [category="EXTERIOR_BLIND", friendlyNames="@Setting.Opening", supportedRange="0:100:10", unitOfMeasure="Percent", actionMappings="Close=100,Open=0,Lower=(+10),Raise=(-10)", stateMappings="Closed=0,Open=1:100"]}


Rollershutter VoletSalon "Volet Salon" (Salon) ["Shutter"] {channel="mqtt:topic:46ee3805:voletsalonmqtt", alexa="Shutter"}

thanks @jeshab

1 Like

Although the tag is not relevant at least from the skill perspective.

1 Like

Yes, I have one in each direction to test witch one works correctly… but both, and also with {alexa=“Blind”}, still works reversed. The only thing that I haven’t tested yet, is trigger a device discovering on Alexa Echo Dot. Re-reading all the post I found that you say that is “mandatory” rediscover the items (but also is not necessary to delete them on Alexa App ,is ok?)

Thanks, and I hope that this afternoon can do more tests.

Very annoying breaking change.
I was not able to bring back the correct functionality.
I tried


and all combinations of actionMappings mentioned in this thread.
Of course did a rediscovery with every conf change.

So I will stick to “wrong” commands to get my shutters going. :hot_face:

Did you test the inverted=false feature as well


I did read every single post, but: overlooked that one.
It works, thx you soooo much :smiley: