Rollershutters stops operating with Alexa today, direction inverted

Great reply, I’ll give that a try - thank you very much! :grinning:

I have already check it… and doesn’t works :-(… Groups through Alexa App doesn’t works for Blinds (although it works before the skill update).

Maybe fixed changing to “Shutters” as madshi say? (or he is refering to other thing?)


I tested the “{alexa=“Shutter”}” feature as well. Basically “up” and “down” are working as expected.
I have some strange behaviour with “stop”.
I say “Alexa stoppe Rollo” sometimes it works, sometimes not.
So I checked the event.log and I see that the spoken command “stoppe Rollo” is always recognized.
But it is not always handed over to my rollershutter item. I do not have this issue with “open” and “up”.
Someone else can reproduce this behaviour?

Rollershutter rk1 "Rollo"   {alexa="Shutter", channel="loxone:miniserver:EE...2292"}

Tested… also for this, direction is also correct but not work into group. I can’t say “Down Salon” as before, or “Down Persianas” (I have groups in Alexa App with this names, and it works before update). Alexa say that this is not compatible. But with Lights for example it still works, so I think is something related to semantic meanings.

alexa="Shutter" [inverted=false, actionMappings="Close=0,Open=100,Lower=0,Raise=100"]

Tested also adding, category=“EXTERIOR_BLIND”, because I have this before syntax change, but it doesn’t affect to the behavior, work ok individually, but not with group.


More information, is something related to “Blind” or “Shutter” property. If I add a dimming Light defined as this:

Dimmer it_regcorten "Luz corten [%d %%]"  <light> { alexa="PowerController.powerState,BrightnessController.brightness" [category="LIGHT"], channel="mqtt:topic:mosquitto:regulable:llumcorten" }

Group action works, and if I say “Up Salon” it rises dimming light if I put in this group. So is something related to “blinds” property.


So I am able to reproduce to some degree after you pointed this out. I think the issue is that the term “stop” (similar to “cancel”) can be interpreted as “don’t do anything”. It can be tricky sometimes even though you noticed that your voice request was translated as expected.

Unfortunately, this is not something we have control at the skill level. One recommendation to improve the success rate, I found during my testing, is to add a small pause between the “stop” action and the name of the device.

1 Like

Could you provide the exact utterances that you are using in your own language to control your blind and light groups? The problem here is that up/down actions aren’t supported in English language. So it makes it hard to understand what the issue is. Since you are comparing to lights, I am inclined to say you are actually requesting increase/decrease but with blind in the mix, it could be open/close or raise/lower.

No problem. I am trying to do a workaround (not working at moment), but I try to explain.

I create in Alexa App several groups, one for each room, and one for all blinds. In each room I put the blinds of that room, example “Office”. And in Blinds grous I put all blinds, and call them “persianas” (blinds in spanish).

When I say “encender oficina” (swtich on office), the lights go on. If I say “subir oficina” (I am not sure if could be “up office” or “raise office”, all the blinds in the group go up like I say “blind X up” for each one). If I say this on a group without that kind of items (no blinds or no dimmer lights), Alexa say that there aren’t compatible objects in this group. This is what is happening now after Alexa Skill update. Until now it was working and was very useful.

Do you undersand?

For blinds, you should be using “open” (abrir) or “close” (cerrar). I just ran a test and it is working. “lower” and “raise” along with “increase” and “decrease” will only affect lights.

I have found a workaround that is working.
If I replace “Blinds” for “BrightnessController.brightness”, it works now. Only Alexa tells me that is a Dimmer, but no problem, because I only activate through voice or OpenHAB.

Rollershutter persiana6 "Persiana Seis" <persiana> { alexa="Blind" [inverted=false, actionMappings="Close=0,Open=100,Lower=0,Raise=100"], channel="mqtt:topic:mosquitto:persianes:P6" }

Changed to:

Dimmer TestPersiana "Persiana Prueba" {alexa="BrightnessController.brightness" [category="EXTERIOR_BLIND", actionMappings="Close=0,Open=100,Lower=0,Raise=100"], channel="mqtt:topic:mosquitto:persianes:P6"}

No need to change things or sitemap.

Ohhh shit!!! :man_facepalming::man_facepalming::man_facepalming::man_facepalming::man_facepalming::man_facepalming:… that is true… omg… with open or close it works.
“Mea culpa”, before I always use up and down.

Thanks so much. I keep all as Rollshutter and blinds now.

I tested another workaround. I changed the word for STOP via the supportedCommands Option. With the new stop recognition shutter stops immediately. But it does not “feel good” because I have no good phrase.
I wanted to use “halte” (hold) at first place but it seems to be interpreted to stop alexa as well.

Keep in mind that the “stop” action is a hack at the skill level that uses the Alexa native playback stop capability in the background. So there is no way around using that term unfortunately. This is the same for “resume” and “pause” actions.

Alexa doesn’t open or close my rollershutter.
I have the item configured as the image attached.
How do i change the item to make it work again with alexa?
Thank you

Stop used to work for my blinds now it doesn’t. I have done a remove and discover but still not working.

Are you using the new syntax?

What do you mean by not working?

Tags are no longer supported in OH 3.x.

You need to set the Alexa metadata on your items as described in the documentation.

I’m using openhab 2.5.4.
The shutters have not worked for two weeks without having touched anything. Should I change the syntax as indicated in the link?

What do you mean by not working?

It’s highly recommended to do so.