Rollershutters stops operating with Alexa today, direction inverted

If I say to alexa: “open my shutter” or “close my shutter” alexa does nothing. On the other hand, if I tell Alexa “set my roller shutter to a percentage value”, then Alexa moves the roller shutter to that value.
But until 15 days ago everything was working correctly. What has changed now? I haven’t changed anything. I have Openhab 2.5.4.

Thanks and best wishes for a Merry Christmas to all!

Are you using metadata to configure your items for Alexa? Could you please provide your full item definition for your Rollershutter items in code fences?

I have openhab 2.5.4 and if I can I would like not to update it. I have a Raspberry Pi with an .items file in which I have inside the commands for the rollershutters:

Rollershutter Tapparella Grande “Tapparella Grande [%.0f %%]” [ “Blind” ]

You will have to use metadata configuration at some point :smiley:

Can you please post your event logs for this item associated with the Alexa requests? It is either your voice requests which are not understood or your binding can’t handle UP/DOWN commands on open/close requests. This is the only difference for this device type that was introduced in the major skill update along with Rollershutter items being inverted by default as highlighted in this thread.

So tired, the last trying to figure out what is going with the rollershutters.
A bit frustrated too… Is there any centralized place where I could figure out a solution?
Rollershutters are working inverted and when I deleted one of them through the alexa app it never came back or discovered again.
Any reply would be realy apreciated.

Agree, frustrating. I had a similar issue, the rollershutter didn’t seem to be discovered as I got the message “no new devices found” but in reality the shutters were discovered. Did you look into your list of devices?

1 Like

Could you provide the item definition for your rollershutters? That would help at least iron out configuration issues.

It never worked for me, even when I changed the syntax.

No it’s never appear back to the devices either. Unfortunately…

I have tried several syntax. Now I still work with my old one

Rollershutter Living_room_1 "Living Room 1" <rollershutter> (rollershutters) [ "Switchable" ]  { channel="somfytahoma:rollershutter:5d98230908:c4d08b20-d121-47dc-a6de-f019132743af:control" }

Can you share the details on what you tried to configure, what you expected and what you actually experienced?

If you are on OH 3.x, tags are no longer supported. So the item you mentioned above will not be discovered.

Happy New Year everyone,
I have tried to make a device discovery with this syntax

Rollershutter Kitchen_5 "Kitchen 5" <rollershutter> (rollershutters) { alexa="Blind", inverted="false", channel="somfytahoma:rollershutter:5d98230908:e77b276e-ab57-4863-a2ac-ec4ec28352a9:control" }

Which actually worked but without any notice in Amazon app. and without been able to invert the working way.
The invert bullet is not working for me, when I save the settings and get back it doesn’t save it, same in non-graphical way.

Wrong syntax, check the older posts in this thread for the correct one

It is

{ alexa="Blind" [inverted=false], channel=...

That worked for me finally, but it still a lot of work for the rest items with this change, thanks a lot!

1 Like


For my blinds I can’t get stop to work reliably anymore. It used to work nicely…

This sometimes works:

alexa="Blind.RangeValue" [supportedCommands="UP=@Value.Up:@Value.Open,DOWN=@Value.Down:@Value.Close,STOP=STOP", supportedRange="0:100:1", unitOfMeasure="Percent", actionMappings="Close=DOWN,Open=UP,Lower=(-5),Raise=(+5),Stop=STOP", stateMappings="Closed=100,Open=0:99"], channel="

Using for commands STOP=@Value.Stop as per the docs doesn’t work but changing it to STOP=STOP does.

Also, a comment

For me fully open is 0%, fully closed is100%. Thats fine, but when commanding to a percentage position the blind responce is inverted and appears to be a % of fully open position and not % of fully closed position as expected.

eg command blinds to 20% and the blinds stop just before fully closed, as if I asked for 80%. I was expecting them to be almost fully open as 100% is fully closed.

Increase and decrease are also inverted. eg Increase the blind 10%, results in the blind moving nearer to the close position


With this setup I am able to control my blinds like it was befor with the old skill - even % position is correct:

alexa="Blind.RangeValue" [inverted=false, capabilityNames="@Setting.Position", supportedCommands="UP=@Value.Open,DOWN=@Value.Close,STOP=@Value.Stop",  supportedRange="0:100:10", unitOfMeasure="Percent", actionMappings="Close=DOWN,Open=UP,Lower=(+10),Raise=(-10),Stop=STOP", stateMappings="Closed=100,Open=0:99"]

Same issue here, but @jeshab explaints that’s an “alexa problem”:


That’s not a bug, it’s a feature according to the documentation :slight_smile:

For position request, since Rollershutter range value are inverted by default, when requesting *Alexa, set the blind to 40%* , the item state will be set to `60` .

But with the setup above you should get the old behaviour.

To stop the blinds, I still use the proxy item what we discussed some time ago :wink:

1 Like

The point is raise lower, increase decrease, %position are inconsistent in their use.

If I use: inverted=false,
then increase/decrease, %position are now correct but raise and lower become inverted