RPi3 + Z-Wave UZB + Eurotronic Z-Wave Comet Thermostat

Hi there! I’m totally new to the OpenHAB scene, so greetings to you all in the first place.
Now, well, as always its a bit tricky for a newbie to start with OpenHAB, so this is my situation:

  • Downloaded OpenHABian, pushed it on to my sdcard (I’ve done that after my apt-get installation crashed once)
  • Now I was able to download the z-wave addon, and configure my UZB stick to be “online”.
  • When I search for new things, the stick blinks, so I guess thats ok.
    I bought the thermostat “Eurotronic Z-Wave Comet” for testing purpose. When I push the button for 5 seconds the thermostat goes into including-mode. (If you speak German, you can check the thermostat howto here: https://www.siio.de/heizenenergiesparen/eurotronic-comet-z-wave-schnellinstallation-maenner-brauchen-keine-anleitung/)
    But openhab cant find it! Now I’m out of ideas, I reseted a few times, but nothing changes.

Any ideas/suggestions?

PS: I was once able to connect the thermostat with the uzb stick with OpenHAB (with the previous apt-get installation), but it wasnt working, although openHAB showed “online” in the things tab). Already hard reseted my uzb stick in the habmin ui… so I guess there shouldnt be any devices in the stick anymore).

Well, when I have a look at the Siio article, the device indeed is NOT in inclusion mode when you push the button for 5 seconds. It should be, but according to Siio it didn’t worked that way. At least the mentioned 4 steps for a successful inclusion doesn’t state a five second button push. Or am I wrong?

There is another thread with user experiences for this device:

But be careful, some of the users are still on OH 1.x.

noticed the advice about clicking once for a NIF -> OpenHAB says nothing to it…
made a apt-get update/upgrade and rebooted, but this didnt help either.
Also: my zwave serial controller says online but in the configuration it shows “Key not found” - is that normal?

That could be related to the fact that the controller tries to include the device in secure inclusion mode. This doesn’t work well (at the moment), so you should deactivate secure inclusion. You can do so by choosing the controller in Habmin, change the settings to “show advanced settings” (don’t know the exact wording) and then search for the inclusion mode in the options. Look what’s the setting at the moment (the default could be to use secure inclusion) and change it to “do not use secure inclusion” (might also be named similar).

Then try again to include the device. Maybe it’s necessary to exclude it before and also reset the device itself.