S300TH binding problem since openHAB 2.5.3


since upgrading to 2.5.3 I cannot use the S300TH binding anymore.

I used 1.14.0 SNAPSHOT from here which I then upgraded to 1.15.0 but it did not work either:

2020-03-23 13:54:27.923 [WARN ] [org.apache.felix.fileinstall        ] - Error while starting bundle: file:/usr/share/openhab2/addons/org.openhab.binding.s300th-1.15.0-SNAPSHOT.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.s300th [205]
  Unresolved requirement: Import-Package: org.openhab.core.binding

        at org.eclipse.osgi.container.Module.start(Module.java:444) ~[org.eclipse.osgi-3.12.100.jar:?]
        at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:383) ~[org.eclipse.osgi-3.12.100.jar:?]
        at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle(DirectoryWatcher.java:1260) [bundleFile:3.6.4]
        at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles(DirectoryWatcher.java:1233) [bundleFile:3.6.4]
        at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:520) [bundleFile:3.6.4]
        at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:365) [bundleFile:3.6.4]
        at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:316) [bundleFile:3.6.4]

Any idea? Looking here in the forum and Google did not help me much. “Unresolved requirement: Import-Package: org.openhab.core.binding” is a strange error in my eyes.

Thank you and regards,

From what version?

That is a community binding? I see no posting of users tryng that on 2.5.x. There could be compatibility issues.

From 2.5.2 to 2.5.3.

I think it was part of openHAB 1.x and until now, not many people are still using it.

For me it is quite important as I run 4 temperature/humidity sensors (which I could replace by something else) but also a weather station (temperature, humidity, wind, rain), which is not that easy to replace.

As I wrote, it worked as version 1.14.0 on openHAB 2.5.2 without problems and now it does not work anymore, 1.14.0 and also the 1.15.0 version from Februar 2020.

Since this is an old binding I would downgrade OH to 2.5.2 so you have it working and install another instance of OH with 2.5.3 and try to find a fix. Maybe reach out to the binding developer or set a bounty for a fix.

1 Like

I thought 2.5.3 was only a binding update though.

I am quite sure it still worked with 2.5.2 as the devices delivered data until I upgraded yesterday.

No idea what the changes are from 2.5.2 to 2.5.3, but /etc/init.d/openhab2 is also missing now, so systemctl commands need to be used (also when monitoring openHAB using a watchdog).

Just restarted my openHAB machine and now I do not see any errors in openhab.log which point to a problem with the S300TH binding. Strange. But I will have to wait a while to see data coming in from the sensors and the weather station. Will keep you posted here.

I also noticed yesterday that there seems to be a difference between
systemctl restart openhab2
systemctl stop openhab2
systemctl start openhab2
as with the first command openHAB still tried to use the 1.14.0 version of the binding which I already had replaced with version 1.15.0 before.

Well, I am more thinking about getting the weather station replaced. I “only” need wind and rain as I can use a cheap Xiaomi sensor in a self 3D-printed outdoor case for temperature and humidity.

But it is still not that simple, easy and cheap to get something nicely working for wind and rain though.

Works! Rebooting the box did the job. No idea why…

Clearing cache & restarting openHAB up to 3 times jas become a commonplace part of upgrades recently. :frowning:

How do I clear openHAB cache? :thinking: Or do you mean the web browser cache?

Thank you very much @Bruce_Osborne for the link and information. I guess that some of my recent problems were problems with old cache.