SamsungTV - Thing going Offline


I’m using the SamsungTV binding on OH2 and in general, it is working.
I can Mute, change Volume, power TV off…but unfortunately only for a certain time(something like 5-10 minutes), then the Thing Status changes to “Offline” and TV can not be controlled any more. I noticed that in PaperUI “Control”, the name of the thing was truncated, so i changed the TV name on the TV itself to something shorter and amended the Thing accordingly. Did a search, thing came online but problem remains the same.
Thing goes to offline after a while and TV can not be controlled any more (neither through BasicUI nor through HABDroid or rules)
The TV however is definitly on (Network thing pinging the TV agrees).
I can reproduce this: I go to Inbox, Search, Samsung TV Binding…it searches, finds nothing new but after that the Thing is Online…but only for a while :frowning:
Any ideas what could be the issue or how to solve this?
TV is a model: UE40EH5300W
Many thanks in advance,
Best Regards,
P.S.: Under OH 1.8.3 i did not have that issue.

1 Like

i checkes my logs some more.
4 days ago, TV went offline:

2017-03-04 23:38:33.839 [hingStatusInfoChangedEvent] - 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183' changed from ONLINE to OFFLINE

and even though it has been turned on/off several times since then, no log entries…until today, i did a Search, Samsung TV Binding again. No new devices, but:

2017-03-08 21:00:34.212 [hingStatusInfoChangedEvent] - 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183' changed from OFFLINE to ONLINE

Checking the logs further back it looks like the typical time until status changes from ONLINE to OFFLINE even though TV is on is around 30 minutes. Once OFFLINE, it won’t come back ONLINE until i perform a search. This renders the Binding quite useless.
As a workaround, would it be possible to send some kind of request to the channel forcing it to go online?

I suppose we can discount the possibility that your TV has been hacked by the CIA?

Is there a refresh interval in your Thing?
Your ping test presumably confirmed the TV is not changing IP (by DHCP or suchlike)

To force a poll, the binding should support 'RefreshType’

Thanks for making the paranoia in me strong again :wink:
But if it was the CIA, surely they would not switch the TV to OFFLINE…right?
jokes aside, yes refresh is set to 1000 ms(default)
All my devices have a fixed IP.
EDIT: Is far as i could gather reading up on the RefreshType.REFRESH you can send this to an Item, but I’d need to send it to the channel itself…

As i understand it, the CIA hack allows the TV to eavesdrop (and presumably read your emails, letters, etc while also vetting your friends and looking in the cupborads) all while appearing to be off.
An unexpected OFFLINE status could well be a result, so that proves it must be true !

OK have to go to the kitchen real quick!!

Safely sitting with my newly folded tinfoil hat i can report that for the last 20 some hours the binding is working OK.
Here’s what i did: did an nmap to my TVs IP. changed the port setting in binding config first to 7676(reported by nmap as UpnP port)…didn’t work at all. changed port to 9090(reported by nmap as Samsung UE55D7000 TV http config). didn’t work at all.
Changed port back to default 55000…and it’s been working ever since!
Can I explain that? Nope
Can I live with the outcome? Yes i can.

Of course, now we want to know if it stops working when you take the hat off …

I have to say as a dinosaur OH1 user, I note thread after thread here for OH2 which seem to revolve around poor handling of a config change, edit, or deletion.

I’m too chicken to take the hat off ever again :slight_smile:
I was very reluctant to migrate to OH2 as well. But finally I did.
And yes, there has been some re-configuring,re-learning,re-thinking, hair pulling and curses…lots of curses…
But all in all I do not regret it and would definitely recommend it.

I really should have not taken off that hat.
The Binding stopped working again, and the trick with the port change does not help any more.
Even a bundle:stop / bundle:start does not help.
Only by removing and readding the TV thing i get it Online again.
After it was working OK i did an apt-get update/upgrade (OH was updated) so i assume that’s the cause.
D’oh! Back to square one :frowning:

Basicly Samsung TV binding monitors discovery events. When thingRemoved event is received, TV is set to offline state. Those discovery event are generated from UPnP stack. Some reason UPnP stack things that TV is not online.

Is your TV connected via Ethernet or WiFi?

thanks for looking into this.
the TV is connected via Ethernet, as is my openhab server. I’ve set the Binding to Debug to get more info.
what i find real strange is that the samsung tv binding reports ZWave-devices?
BTW i thought maybe the binding does to many refreshs and set value to 60000ms. Good or bad idea?
Here some examples:

2017-03-12 10:26:53.876 [DEBUG] [org.openhab.binding.samsungtv       ] - BundleEvent STARTING - org.openhab.binding.samsungtv
2017-03-12 10:26:53.887 [DEBUG] [org.openhab.binding.samsungtv       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.config.discovery.UpnpDiscoveryParticipant}={,,, service.bundleid=187, service.scope=bundle} - org.openhab.binding.samsungtv
2017-03-12 10:26:53.893 [DEBUG] [covery.SamsungTvDiscoveryParticipant] - Discovered a Samsung TV '[TV]WoZi' model 'UE40EH5300' thing with UDN '07bfa480_0082_1000_b3aa_50856976b183'
//above is repeated several times
2017-03-12 10:26:53.937 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Create a Samsung TV Handler for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:26:53.940 [DEBUG] [org.openhab.binding.samsungtv       ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandlerFactory}={,,, service.bundleid=187, service.scope=bundle} - org.openhab.binding.samsungtv
2017-03-12 10:26:53.966 [DEBUG] [org.openhab.binding.samsungtv       ] - BundleEvent STARTED - org.openhab.binding.samsungtv
2017-03-12 10:26:54.556 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Initializing Samsung TV handler for uid 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:26:54.563 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - thingDiscovered: DiscoveryResult [thingUID=samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183, properties={hostName=}, flag=NEW, label=[TV]WoZi, bridgeUID=null, ttl=-1, timestamp=1489310813908]
2017-03-12 10:26:54.564 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - thingDiscovered, thingUID=samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183, discoveredUID=samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183
//ok i understand the LMS..UPnP
2017-03-12 10:26:54.564 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - thingDiscovered: DiscoveryResult [thingUID=squeezebox:squeezeboxserver:EE3A354D-8CD0-4694-9740-D1E26E0311B9, properties={, cliPort=9090, webport=9002}, flag=NEW, label=Logitech Media Server [xxxxxx], bridgeUID=null, ttl=-1, timestamp=1489310814546]
//but zwave?? because it is a thing?
2017-03-12 10:27:03.036 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - thingDiscovered: DiscoveryResult [thingUID=zwave:device:908f55eb:node4, properties={zwave_class_basic=ROUTING_SLAVE, zwave_class_generic=BINARY_SWITCH, zwave_frequent=false, zwave_version=25.25, zwave_listening=true, zwave_deviceid=4096, zwave_nodeid=4, zwave_routing=true, zwave_beaming=true, zwave_class_specific=NOT_USED, zwave_manufacturer=271, zwave_devicetype=1536}, flag=NEW, label=Z-Wave Node 4: FGWP101 Metered Wall Plug Switch, bridgeUID=zwave:serial_zstick:908f55eb, ttl=-1, timestamp=1489310823009]
//then lots of stuff that looks good
2017-03-12 10:27:06.214 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Check and create missing UPnP services
2017-03-12 10:27:06.216 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Ignore device=(RemoteDevice) Identity: (RemoteDeviceIdentity) UDN: uuid:123402409-bccb-40e7-8e6c-C80E14D948B8, Descriptor:, Root: true
2017-03-12 10:27:06.217 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] -  modelName=UE40EH5300, udn=07bfa480-0082-1000-b3aa-50856976b183, type=MediaRenderer
2017-03-12 10:27:06.227 [DEBUG] [nternal.service.MediaRendererService] - Create a Samsung TV MediaRenderer service
2017-03-12 10:27:06.227 [DEBUG] [nternal.service.MediaRendererService] - Start refresh task, interval=60000
2017-03-12 10:27:06.230 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] -  modelName=UE40EH5300, udn=0d1cef00-00dc-1000-8fe8-50856976b183, type=MainTVServer2
2017-03-12 10:27:06.232 [DEBUG] [internal.service.MainTVServerService] - Create a Samsung TV MainTVServer service
2017-03-12 10:27:06.232 [DEBUG] [internal.service.MainTVServerService] - Start refresh task, interval=60000
2017-03-12 10:27:06.242 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] -  modelName=UE40EH5300, udn=0bebc200-00c8-1000-a85f-50856976b183, type=RemoteControlReceiver
2017-03-12 10:27:06.244 [DEBUG] [rnal.service.RemoteControllerService] - Create a Samsung TV RemoteController service
2017-03-12 10:27:06.244 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Ignore device=(RemoteDevice) Identity: (RemoteDeviceIdentity) UDN: uuid:EE3A354D-8CD0-4694-9740-D1E26E0311B9, Descriptor:, Root: true
2017-03-12 10:27:06.244 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Ignore device=(RemoteDevice) Identity: (RemoteDeviceIdentity) UDN: uuid:fa095ecc-e13e-40e7-8e6c-c80e14d948b8, Descriptor:, Root: true
2017-03-12 10:27:06.244 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Ignore device=(RemoteDevice) Identity: (RemoteDeviceIdentity) UDN: uuid:7f6cf512-85fa-8c2c-ffff-ffffc0dc401f, Descriptor:, Root: true
2017-03-12 10:27:06.245 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] -  modelName=UE40EH5300, udn=0c845880-00d2-1000-98ad-50856976b183, type=dialreceiver
2017-03-12 10:27:06.245 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Ignore device=(RemoteDevice) Identity: (RemoteDeviceIdentity) UDN: uuid:95802409-bccb-40e7-8e6c-C80E14D948B8, Descriptor:, Root: true
2017-03-12 10:27:06.245 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Ignore device=(RemoteDevice) Identity: (RemoteDeviceIdentity) UDN: uuid:00113223-a233-0011-33a2-33a223321100, Descriptor:, Root: true
2017-03-12 10:27:06.381 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received value 'volume':'9' for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:27:06.393 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received value 'channel':'65535' for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:27:06.407 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received value 'mute':'OFF' for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:27:06.421 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received value 'sourceId':'67' for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:27:06.422 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received value 'sourceName':'HDMI1/DVI' for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:27:06.433 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received value 'brightness':'45' for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:27:06.447 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received value 'contrast':'95' for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:27:06.490 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received value 'sharpness':'20' for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:27:06.503 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received value 'colorTemperature':'3' for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:27:19.228 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - channelLinked: samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183:volume
2017-03-12 10:27:19.231 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - channelLinked: samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183:mute
2017-03-12 10:27:19.234 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - channelLinked: samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183:power
2017-03-12 10:28:06.251 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received value 'volume':'9' for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:28:06.264 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received value 'channel':'65535' for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:28:06.265 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received value 'mute':'OFF' for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:28:06.284 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received value 'brightness':'45' for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:28:06.300 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received value 'sourceId':'67' for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:28:06.301 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received value 'sourceName':'HDMI1/DVI' for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:28:06.302 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received value 'contrast':'95' for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:28:06.318 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received value 'sharpness':'20' for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:28:06.332 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received value 'colorTemperature':'3' for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:28:45.999 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received channel: samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183:mute, command: ON
2017-03-12 10:28:46.001 [DEBUG] [nternal.service.MediaRendererService] - Received channel: mute, command: ON
2017-03-12 10:28:46.111 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received value 'mute':'ON' for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'
2017-03-12 10:28:51.137 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received channel: samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183:mute, command: OFF
2017-03-12 10:28:51.138 [DEBUG] [nternal.service.MediaRendererService] - Received channel: mute, command: OFF
2017-03-12 10:28:51.253 [DEBUG] [g.samsungtv.handler.SamsungTvHandler] - Received value 'mute':'OFF' for thing 'samsungtv:tv:07bfa480_0082_1000_b3aa_50856976b183'

Hi @pauli_anttila Just wanted to give some feedback:
I did a complete patch, reboot of every piece of equipment(OH, Router, tablets, hair dryer…and TV of course) and ever since then the Bindings works flawless (for almost a week now so save to assume it’ll stay that way). Do you see any chance to add a channel for Play/Pause? Currently TV gets muted when a call comes in; would be extra cool if I could also pause when watching a stream.
Many thanks for providing the binding,

9 Days of joy…and today, after another OH update/reboot(Samsung TV updated itself as well) thing stays OFFLINE. the moment i had it ONLINE it would not accept commands saying:

Channel 'samsungtv:tv:xxx:mute' not supported
Channel 'samsungtv:tv:xxx:volume' not supported

Edit: Only the bold…removed & re-added thing; works again :slight_smile:

And stopped working again. I’m about to give up and install the 1.x binding. @pauli_anttila : does the 1.x version run on OH2 in general?

yep, also here nothing is working anymore, even mute and volume which were working before :frowning:

Yeah, once you get used to the TV muting when a call comes in and unmuting when you hang up you really start missing the comfort when it breaks :wink:
What OH Version / Build are you running?
I’m currently on 2.1.0-SNAPSHOT Build #889 and ever since one build before that it’s working quite reliable. Whenever i try the TV responds. Knock on wood…


I m brand new and just start with openHAD. I have a used the Samsung TV binding :

It find my Samsung Serial 6 65 inch and show online. If I try any command it moves to offline and no action at TV.

Had anybody since April get it done ?


I have a similar behavior where my Samsung has been offline for awhile. I know that it worked with the 1.0 binding. Any suggestions on how I can troubleshoot it? @Oli, how can enable debug messages for the Samsung binding?

Edited Post: Turns out that I or someone in my house denied access in allshare settings. Working again now. Thx.

Hi & sorry for the late reply,

in case you haven’t found the answer by now:
I would suggest setting the log level for the binding to DEBUG via karaf console; instructions here: