Scheduled CRON Rule timezone seems to be GMT not local

  • Platform information: Debuan Buster (on Qnap container station)
    • Hardware: intel/4GB/Terabytes of storage
    • OS: what OS is used and which version
    • Java Runtime Environment: 11
    • openHAB version:3.0.1

Vanilla setup - oh3 has been working for a long time, but never used schedules, so I created one. Then looked at the schedule UI and it showed nothing was going to run today at 8am, but it would tomorrow and it was currently 6am.

I am east coast - GMT - 4 right now, so fiddling with rule trigger time I set it to 4 hours ahead of local time, - and presto it shows up as going to run today.

The OS time is local and correct. Anything to check as to why OH3 is not using local time?

  - id: "1"
      cronExpression: 0 25 8 ? * MON,TUE,WED,THU,FRI *
    type: timer.GenericCronTrigger
conditions: []
  - inputs: {}
    id: "2"
      itemName: KidsDesk_Power1_i
      command: ON
    type: core.ItemCommandAction


Thanks rossko57 ! that’s got me in the right direction - been fiddling with the config file - but after reading a bit more maybe I have the wrong config file?

Using: /etc/default/openhab (that’s a file not a folder)

Restarted - no effect.

Is there another config file within OH3 on Debian?

Try changing add there karaf.override.user.timezone=x.
Issue is observe comes from basic fact that timezone setting made by openhab is not reflected everywhere for all libraries. Been there. What is your operatong system timezone anyways?

trying it out shortly.

TZ on OS from using debian command


is: America/New_York

Rebooted linux and the trigger is working at the correct local time (did not try the adjustment), the EXTRA_JAVA_OPTIONS is in place.
However in the schedule view: URL /#!/settings/schedule doesn’t show it the calendar as “scheduled” today but it does run at the correct local time.

Other days in the week show it in the calendar.

I will upgrade to 3.1.0 and report back in a week or so.

Pay attention that openhab stuff uses its own timezone abstraction mechanism which you can override via Settings > Regional.