Schlage BE469 not finding thing on inclusion

Hello, I’m running OH2.5 with an Aeotec Gen 5 USB controller and have one other secure zwave device functioning (Aeotec Garage Door Controller). I’m trying to get this Schlage door lock added to the network:

I’ve started the inclusion in Paper UI and I’ve tried it in HABmin both many times and follow the instructions to start the inclusion:
Schlage button + [6 digit programming code] + 0 and the lock will flash yellow for a few seconds and it always shows a red X when done (green check should be successful inclusion). I also do not ever see it mentioned in the Openhab logs like I do when a new device is discovered. Most of my other ZWave devices are functioning so communication with the controller is successful.

I started trying with OH2.4, but when it failed I went ahead and upgraded and rebooted.

I have boxes of several different zwave sensors and otherwise that I haven’t gotten around to installing yet. While troubleshooting I was only able to add a Zooz PIR sensor via the pushing the button on the Aeotec controller, so I’m wondering if maybe for some reason the binding is not properly starting the inclusion mode on the Aeotec controller. Exclusion seems to be fine because I was able to exclude the device I added with the push button.

You can’t use the controller button to start inclusion for secure devices, you need to use the graphical user interface (preferable HABmin). Also bring the lock very close to your controller.

@sihui thank you for your response.

You can’t use the controller button to start inclusion for secure devices

Sorry that wasn’t a secure device I was including by using the button. I was doing that to troubleshoot not being able to include the lock through the GUI. These PIR sensors I was troubleshooting with have been very hit or miss though; I have 7 of these and have only used 3, one was easily joined a few weeks ago, the second was not. I opened up the third one yesterday while troubleshooting and could not join it via the GUI, but did join it through the button on the controller and excluded it through HABmin.

Also bring the lock very close to your controller

I brought it within 3 feet of the Pi with a controller several times while initiating a GUI inclusion through Paper UI and HABmin and was not able to join it.

Make sure you are using the correct button sequence for your device to go into inclusion mode.

@sihui thanks again for responding and working with me on this. I am following the instructions in the manual:

Schlage button + [6 digit programming code] + 0

I obtained the programming code from a sticker on the back of the lock, and I believe that if I was entering an incorrect code I would not get the same result. I double checked the instructions from my paper copy of the manual with the internet and found the instructions to be the same on the SmartThings website and a pdf version of the manual (Page 13):

I have even performed a factory reset of the device which should return the programming code back to the one listed on the sticker.

As far as I can tell, based on the feedback from the device, I am performing the correct button sequence to get it into inclusion mode. I will try again this evening with a random 6 digit code to see if I receive different feedback from the device to verify that they printed the correct security code on the sticker though. If it provides a different feedback with an intentionally incorrect code then I’ll know I’m using the right code; if it provides the same feedback I’ll reach out to support to see if they provided an incorrect code. I have confirmed that the two default user codes printed on the same sticker are accurate, so I have been operating under the assumption that the default security code is also accurate.

Have you had a look through the debug logs to see if it shows anything? It’s often difficult to work out what’s happening with security, so it may or may not help, but it’s worth a look…

Thanks @chris I actually have never had to use the debug logs before. I found your post on setting debug logging and I’ll play with it when I get home.

Great - if you want me to take a look, then feel free to yell. If you post a log, it might be best to raise a ticket on my website as the logs may contain the security keys so probably best not to post on the open internet unless it’s a short log that you’ve vetted first :slight_smile:

Try closer… as in touching the controller. There are many threads in the forum discussing including this device.

You got it; I certainly don’t want my encryption keys floating around :slight_smile:

@5iver I will certainly try even closer. When I was searching for other threads most of what I saw were based on using the older ZWave binding that didn’t support security. I’ll go back through though, I probably didn’t spend as much time on it as I should have.

1 Like

I guess maybe I have something else wrong… came home and all of my lights were left on and now I only have one Z-Wave node functioning, everything else is reported as Node not found in Z-Wave network. I’m going to try to reset and rejoin all of these before I continue working on the lock. Thanks for everyone’s help.

Ugh, everything is in pretty bad shape. I’ve excluded and readded several devices now. For the most part after including again they are working but it seems like the nodeid changed, however in things the nodeid is the same. Only two are showing online, one of them is working and the other doesn’t appear to be but I have no idea what it’s real nodeid so I’m not sure. Three of the switches that are showing offline and Node not found in Z-Wave network are currently functioning fine, but I can’t heal them because HABmin thinks they’re not in the network.

I think I’m going to break for now and wait for the 2AM network heal and see what things look like tomorrow.

Helo Chris,
I having hard time integrating the BE469 with openhab/paring.
I installed Openhab 2.5.0 Build #1754. I successfully configured the z-wave serial controller (AEOTEC Z-Stick Gen5) online. I am not sure what are the steps to make the lock communicate/integrated with Openhab

Start inclusion through the binding, not the controller button. Make sure the inclusion process is finished after 15 seconds, so not much time to hit the inclusion button on the lock.

Thanks Sihui for your reply. Can you provided me with the steps/tools that I need to use.

Use PaperUI or even better HABmin to start the binding inclusion mode.


Also read the binding docs:

Now I can see the BE469 online.
Not sure If all is good and what’s next (see below)

13:44:30.506 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 5: Got an event from Z-Wave network: ZWaveNodeStatusEvent

13:44:30.507 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 5: Setting OFFLINE

13:44:30.507 [DEBUG] [ave.internal.protocol.ZWaveController] - NODE 5: Node Status event - Node is DEAD

13:44:30.508 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - NODE 5: TID 183: Transaction completed

13:44:30.508 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - NODE 5: notifyTransactionResponse TID:183 CANCELLED

13:44:30.508 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - NODE 5: processing secure transaction -- TID:182

13:44:30.509 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - TID 182: Transaction event listener: DONE: UNINTIALIZED ->

13:44:30.509 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Completing UNINTIALIZED transaction 182!!! How?!?

13:44:30.512 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 5: Got an event from Z-Wave network: ZWaveTransactionCompletedEvent

13:44:30.512 [DEBUG] [ialization.ZWaveNodeInitStageAdvancer] - NODE 5: Node Init response (1) org.openhab.binding.zwave.internal.protocol.ZWaveTransactionResponse@74584283

13:44:30.513 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - ZWaveReceiveThread queue empty

13:44:30.513 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.

13:45:27.552 [DEBUG] [ZWaveSerialHandler$ZWaveReceiveThread] - Receive Message = 01 10 00 49 84 05 0A 04 40 03 5E 98 9F 55 6C 8A 22 A2

13:45:27.553 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - processReceiveMessage input 0<>128 : Message: class=ApplicationUpdate[73], type=Request[0], dest=5, callback=132, payload=84 05 0A 04 40 03 5E 98 9F 55 6C 8A 22

13:45:27.554 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Received msg (0): Message: class=ApplicationUpdate[73], type=Request[0], dest=5, callback=132, payload=84 05 0A 04 40 03 5E 98 9F 55 6C 8A 22

13:45:27.554 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - lastTransaction null

13:45:27.554 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Checking outstanding transactions: 0

13:45:27.555 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Last transaction: null

13:45:27.555 [DEBUG] [ave.internal.protocol.ZWaveController] - Incoming Message: Message: class=ApplicationUpdate[73], type=Request[0], dest=5, callback=132, payload=84 05 0A 04 40 03 5E 98 9F 55 6C 8A 22

13:45:27.555 [DEBUG] [message.ApplicationUpdateMessageClass] - NODE 5: Application update request. Node information received. Transaction null

13:45:27.556 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 5: Got an event from Z-Wave network: ZWaveNodeStatusEvent

13:45:27.556 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 5: Setting ONLINE

13:45:27.557 [DEBUG] [ave.internal.protocol.ZWaveController] - NODE 5: Node Status event - Node is ALIVE

13:45:27.557 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - 'zwave:device:16e6b2c35b1:node5' changed from OFFLINE (COMMUNICATION_ERROR): Node is not communicating with controller to ONLINE

13:45:27.557 [DEBUG] [ing.zwave.internal.protocol.ZWaveNode] - NODE 5: Node is ALIVE. Init stage is GET_CONFIGURATION.

13:45:27.557 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 5: Got an event from Z-Wave network: ZWaveNodeStatusEvent

13:45:27.558 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 5: Setting ONLINE

13:45:27.558 [DEBUG] [ave.internal.protocol.ZWaveController] - NODE 5: Node Status event - Node is ALIVE

13:45:27.558 [DEBUG] [otocol.commandclass.ZWaveCommandClass] - NODE 5: Unsupported command class COMMAND_CLASS_SECURITY_2

13:45:27.559 [DEBUG] [otocol.commandclass.ZWaveCommandClass] - NODE 5: Unsupported command class COMMAND_CLASS_TRANSPORT_SERVICE

13:45:27.559 [DEBUG] [otocol.commandclass.ZWaveCommandClass] - NODE 5: Unsupported command class COMMAND_CLASS_SUPERVISION

13:45:27.559 [DEBUG] [message.ApplicationUpdateMessageClass] - NODE 5: Application update - no transaction.

13:45:27.560 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - ZWaveReceiveThread queue empty

13:45:27.560 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.

First, always use code fences in your posts for logs and code. This makes things a lot easier to read. Next, is the lock securely included? Check this at Habmin> Configuration> Things> select the lock> Attributes> Security. This will show a green check mark if securely included or red X if not. If not securely included, search the forum for the many posts on how to include this lock.

It looks like the device might not be communicating well - I see it is considered DEAD which normally means that the device isn’t responding. This is normally caused by communications errors such as too much distance between devices.

I would suggest the following…

Exclude the lock, Reset the lock, perform the inclusion again, provide the full debug log of the inclusion.

Thank you Scott and Chris.
After intensive fight I got the below

I think I got it but I am not sure how to test the communication/status/operation of the lock (close /open)