[Shelly Binding] Not discovering Shelly H&T Plus

i bought myself a Shelly H&T Plus and activated it via Shelly App and connected it to my WiFi.
Everyting working from the Shelly-App so far …
I installed the current Shelly Binding 3.3.0.

I can not discover the device via Thing > Add > Shelly > Scan-Button
If i manually set the properties via static IP, the device keeps being

  • status: Unknown
  • Initializing or device in sleep mode.

I also tried to push the button under the back-cover several times or for a longer duration etc.

Nothing seems to work

Am i missing something or doing something wrong?
Or is the H&T Plus even too new and not yet supported by the binding?

Thanks in advance

Hey @SHUred
I installed a 1PM Plus last week. I couldn‘t use it with OpenHAB too, because it is a Plus product. But there is already a open PullRequest that add the new (plus) devices to the binding. Check GitHub PRs.

1 Like

Another user asked:

First reply was:

Later in the discussion:

seems to be the case

1 Like

Thanks to both of you

Luckily im not in a rush regarding this topic :wink:

1 Like

alternatively you may use MQTT to talk/listen to the device.

1 Like

Im alredy using mqtt for other devices and initially wanted to use the shelly stuff via mqtt.
But then i started to stumble upon the shelly-binding.

AFAIK this is also offline/locally working and i can deactivate mqtt and cloud function for the shelly devices right?
My current opinion is, that “directly” using the shelly binding is the best way for me to use these devices …

If something i mentioned is wrong, please feel free to correct my.
My target is to use these devices with “Cloud” function OFF → Only using the local network

I don’t have experience with exactly this product but as far as i understand it should work to control the device without shelly cloud functionality and just using local network functions.
Have a look at this thread which is for OH 2.5 ( it also has a link to OH3 related ) thread.

this is correct, the binding uses the local device api, Ou could use cloud in parallel, or even disable it. i‘m in close contact with Allterco and part of their beta program


I really love the way Shelly thinks about different approaches for the user
Not only having to use some proprietary cloud server

I’m looking forward to the binding update to add my H&T Plus to openHAB

1 Like

I‘m still waiting on a firmware fix. The new firmware implements so call outbound web sockets, which are used by the binding to get the sensor reports. However, this can cause the HT to go into setup mode. Allterco is working on the fix, but I have no timeline

1 Like

by the way, you need to wakeup the device to get ready for discovery (press the button inside the HT or remove and re-insert the battery)

1 Like

I also tried to push the button under the back-cover several times or for a longer duration etc.

Thats exactly what i did, but i could not discover the device, nor connect to it via manually configure IP etc.

I dont know if i did something wrong but regarding to the answers in this topic i will wait for updates on binding and/or firmware

I got an update from Allterco: This fix for the Plus HT will be included in the next beta scheduled by end of the week. This release is required for the binding. Currently the Plus HT is discovered, but when initialized to use WebSockets for events it returns to setup mode (AP mode) and looses the network connection

I updated the Gen2 build

  • fixes the issue that meters are not created when using the Pro 4PM with auth enabled
  • optimized WebSocket connections (doesn’t create WS on initialization, but on demand when needed)
  • filter for unexpected Notifications
  • Notifications will not be requested on device discovery

For TRV we have a breaking change:

  • Channel device#schedule has been moved to control#schedule (enable/disable scheduled profiles)
  • Channel control#selectzedProfile now has the selected profile id as raw information. The binding dynamically retries the profile list and provides a list to the UI (e.g. profile “1” will be mapped to Bathroom"

3.4.0-Gen2 build for Plus/Pro+Gen1 | 3.4.0-DEV Gen1 stable build
README | READMEbeta for more info on first installation
Avdanced Users - Shelly Manager - Bugs/Features - API Doc
Gen1: Firmware Index - Firmware Archive

fyi: PR 4 of 5 is in review, PR5 will then finally be the Plus/Pro support - a long path, but I tried to support @fwolter with easier review. Thanks Fabian for the efforts, good job :slight_smile:

Note: The DEV build is always newer than the version in the official Distro or the milestone builds


OK I’m not very into this
Are you talking about the openHAB binding or the Shelly firmware?

Just for me to know where to watch :cowboy_hat_face:

Gen2 build is the binding that is being updated/maintained by Markus.
Gen2 means next generation API for older and very new shelly devices.
It requires firmware from Shelly - this means firmware needs to be loaded ( updated ) into the Shelly.

Allterco (the manufacturer of the Shelly devices) promised me an alpha of the fixed version by tomorrow


I did now try to upgrad the Shelly H&T Plus to 0.11.0-beta3
Seems its still not getting discovered by openhab

One more question
The shelly API is always ON or do i have to set some settings before?

It also seems, that the shelly can only be reached via WebUI or cloud
I thought i could disable Cloud but still connect from Shelly Android App via local network whilst cloud is off

I tested PlusHT with 0.11beta and it works fine
The device has to be in setup mode for discovery, remove batteries, re-insert and then run OH discovery
Device API is always on, but the device is usually sleeping, you don’t need the cloud API

please continue the discussion here: Shelly Binding - #2655 by markus7017

1 Like

OK weird,
i pushed the button multiple times
i removed the batteries multiple times
i held down the button while booting after battery removing multiple times

I never was able to discover one of the devices in OH → Is there something with password etc. i have to take care of? I did not change anything and standard pw and un is admin